Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Определение двух значений по таблице - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Определение двух значений по таблице
Dalm Дата: Понедельник, 26.02.2024, 17:48 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 81
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Здравствуйте.
Помогите решить задачу.

На листе находится таблица.

Подскажите - как по ней, при помощи формулы найти два значения.
Определение выглядит так.

Число в желтой ячейке - представляет собой целую часть и дробную часть.
Дробная часть - ищется по горизонтали таблицы, а целая часть - по вертикали таблицы. И вот нужно найти число которое лежит на пересечении вертикали и горизонтали, и вписать то что получилось в ячейку D2.
И так же нужно обратную операцию. По числу в зеленой ячейке - найти - по той же самой таблице - дробную и целую часть (и вписать это число как единое - в ячейку D3)

Как это сделать формулами ?
К сообщению приложен файл: 8608832.xlsx (16.1 Kb)
 
Ответить
СообщениеЗдравствуйте.
Помогите решить задачу.

На листе находится таблица.

Подскажите - как по ней, при помощи формулы найти два значения.
Определение выглядит так.

Число в желтой ячейке - представляет собой целую часть и дробную часть.
Дробная часть - ищется по горизонтали таблицы, а целая часть - по вертикали таблицы. И вот нужно найти число которое лежит на пересечении вертикали и горизонтали, и вписать то что получилось в ячейку D2.
И так же нужно обратную операцию. По числу в зеленой ячейке - найти - по той же самой таблице - дробную и целую часть (и вписать это число как единое - в ячейку D3)

Как это сделать формулами ?

Автор - Dalm
Дата добавления - 26.02.2024 в 17:48
bigor Дата: Понедельник, 26.02.2024, 17:58 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1172
Репутация: 226 ±
Замечаний: 0% ±

нет
Dalm, для желтой ячейки
Код
=INDEX($G$7:$R$59;MATCH(INT(B2);$E$7:$E$59;1);MATCH((B2-INT(B2))*100;$G$5:$R$5;1))
 
Ответить
СообщениеDalm, для желтой ячейки
Код
=INDEX($G$7:$R$59;MATCH(INT(B2);$E$7:$E$59;1);MATCH((B2-INT(B2))*100;$G$5:$R$5;1))

Автор - bigor
Дата добавления - 26.02.2024 в 17:58
Dalm Дата: Понедельник, 26.02.2024, 18:26 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 81
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
bigor, спасибо.
А для зеленой как ?
 
Ответить
Сообщениеbigor, спасибо.
А для зеленой как ?

Автор - Dalm
Дата добавления - 26.02.2024 в 18:26
AlexM Дата: Понедельник, 26.02.2024, 20:35 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4517
Репутация: 1129 ±
Замечаний: 0% ±

Excel 2003
Для желтой
Код
=ВПР(B2;E7:R59;ПОИСКПОЗ(ОСТАТ(B2;1)*100;G5:R5)+2)
для зеленой массивная формула
Код
=МАКС((ЕСЛИ(B3-G7:R59>=0;B3-G7:R59)=МИН(ЕСЛИ(B3-G7:R59>=0;B3-G7:R59)))*(E7:E59+G5:R5%))
Но у меня другое значение получилось. Возможно вы не все условия рассказали.
К сообщению приложен файл: 8608832_1.xlsx (16.4 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеДля желтой
Код
=ВПР(B2;E7:R59;ПОИСКПОЗ(ОСТАТ(B2;1)*100;G5:R5)+2)
для зеленой массивная формула
Код
=МАКС((ЕСЛИ(B3-G7:R59>=0;B3-G7:R59)=МИН(ЕСЛИ(B3-G7:R59>=0;B3-G7:R59)))*(E7:E59+G5:R5%))
Но у меня другое значение получилось. Возможно вы не все условия рассказали.

Автор - AlexM
Дата добавления - 26.02.2024 в 20:35
i691198 Дата: Понедельник, 26.02.2024, 21:46 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 240
Репутация: 88 ±
Замечаний: 0% ±

Для зеленой у меня такая формула получилась.
Код
=ПОИСКПОЗ(B3;G7:G59)+ИНДЕКС(G5:R5;;ПОИСКПОЗ(B3;ДВССЫЛ("G"&ПОИСКПОЗ(B3;G7:G59)+6&":R"&ПОИСКПОЗ(B3;G7:G59)+6)))%
 
Ответить
СообщениеДля зеленой у меня такая формула получилась.
Код
=ПОИСКПОЗ(B3;G7:G59)+ИНДЕКС(G5:R5;;ПОИСКПОЗ(B3;ДВССЫЛ("G"&ПОИСКПОЗ(B3;G7:G59)+6&":R"&ПОИСКПОЗ(B3;G7:G59)+6)))%

Автор - i691198
Дата добавления - 26.02.2024 в 21:46
AlexM Дата: Понедельник, 26.02.2024, 22:23 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4517
Репутация: 1129 ±
Замечаний: 0% ±

Excel 2003
i691198, на базе вашей формулы
Код
=ПОИСКПОЗ(B3;G7:G59)+ИНДЕКС(G5:R5;ПОИСКПОЗ(B3;ИНДЕКС(G7:R59;ПОИСКПОЗ(B3;G7:G59);)))%



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщениеi691198, на базе вашей формулы
Код
=ПОИСКПОЗ(B3;G7:G59)+ИНДЕКС(G5:R5;ПОИСКПОЗ(B3;ИНДЕКС(G7:R59;ПОИСКПОЗ(B3;G7:G59);)))%

Автор - AlexM
Дата добавления - 26.02.2024 в 22:23
Dalm Дата: Вторник, 27.02.2024, 00:45 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 81
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Всем спасибо за ответы
 
Ответить
СообщениеВсем спасибо за ответы

Автор - Dalm
Дата добавления - 27.02.2024 в 00:45
_Boroda_ Дата: Вторник, 27.02.2024, 10:49 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16675
Репутация: 6481 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
С зеленой непонятно как считать нужно, а с желтой такой вариант еще
Код
=ИНДЕКС(G7:R59;B2;ОСТАТ(B2;1)/5%+1)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеС зеленой непонятно как считать нужно, а с желтой такой вариант еще
Код
=ИНДЕКС(G7:R59;B2;ОСТАТ(B2;1)/5%+1)

Автор - _Boroda_
Дата добавления - 27.02.2024 в 10:49
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!