Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Функция ЕСЛИ() - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Функция ЕСЛИ()
Gold_Barsik9945 Дата: Четверг, 29.02.2024, 03:33 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 40% ±

Не решается формула
[code]ЕСЛИ(КОНМЕСЯЦА(B1;0)=31;КОНМЕСЯЦА(B1;0)-1;КОНМЕСЯЦА(B1;0))
в чём причина?
Из месяцев с 31 днём не вычитает 1 день.


Сообщение отредактировал Gold_Barsik9945 - Четверг, 29.02.2024, 03:48
 
Ответить
СообщениеНе решается формула
[code]ЕСЛИ(КОНМЕСЯЦА(B1;0)=31;КОНМЕСЯЦА(B1;0)-1;КОНМЕСЯЦА(B1;0))
в чём причина?
Из месяцев с 31 днём не вычитает 1 день.

Автор - Gold_Barsik9945
Дата добавления - 29.02.2024 в 03:33
DrMini Дата: Четверг, 29.02.2024, 04:16 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1759
Репутация: 244 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Цитата Gold_Barsik9945, 29.02.2024 в 03:33, в сообщении № 1 ()
в чём причина?

Попробуйте искать 31 не в дате, (например 31.01.2024) а в количестве дней в месяце через функцию ДЕНЬ:
Код
=ЕСЛИ(ДЕНЬ(КОНМЕСЯЦА(B1;0))=31;КОНМЕСЯЦА(B1;0)-1;КОНМЕСЯЦА(B1;0))


Сообщение отредактировал DrMini - Четверг, 29.02.2024, 04:21
 
Ответить
Сообщение
Цитата Gold_Barsik9945, 29.02.2024 в 03:33, в сообщении № 1 ()
в чём причина?

Попробуйте искать 31 не в дате, (например 31.01.2024) а в количестве дней в месяце через функцию ДЕНЬ:
Код
=ЕСЛИ(ДЕНЬ(КОНМЕСЯЦА(B1;0))=31;КОНМЕСЯЦА(B1;0)-1;КОНМЕСЯЦА(B1;0))

Автор - DrMini
Дата добавления - 29.02.2024 в 04:16
Gold_Barsik9945 Дата: Четверг, 29.02.2024, 04:21 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 40% ±

Спасибо за верное решение.
 
Ответить
СообщениеСпасибо за верное решение.

Автор - Gold_Barsik9945
Дата добавления - 29.02.2024 в 04:21
_Boroda_ Дата: Четверг, 29.02.2024, 09:22 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16675
Репутация: 6481 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Также, только покороче чуть
Код
=КОНМЕСЯЦА(B1;0)-(ДЕНЬ(КОНМЕСЯЦА(B1;0))=31)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТакже, только покороче чуть
Код
=КОНМЕСЯЦА(B1;0)-(ДЕНЬ(КОНМЕСЯЦА(B1;0))=31)

Автор - _Boroda_
Дата добавления - 29.02.2024 в 09:22
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!