Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборка по ячейкам - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка по ячейкам (Формулы/Formulas)
Выборка по ячейкам
clickme690 Дата: Четверг, 29.02.2024, 12:41 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

2021
У меня есть лист Норма3 и лист1. В лист1 написал формулу В9 = 'норма 3'!A2. Формула работает!. Мне нужно чтобы в листе Норма3 когда я нажимал(выбрал) следующую строку оно должно появляться в листе (Лист1). В моем случае капитан Пупкин работает, мне нужно чтобы когда я выбирал майора Иванова его данные должны переносится на Лист1 и так далее следующие строки должны работать так же!
К сообщению приложен файл: obrazec_slichitelnoj_vedomosti.xlsx (28.8 Kb)
 
Ответить
СообщениеУ меня есть лист Норма3 и лист1. В лист1 написал формулу В9 = 'норма 3'!A2. Формула работает!. Мне нужно чтобы в листе Норма3 когда я нажимал(выбрал) следующую строку оно должно появляться в листе (Лист1). В моем случае капитан Пупкин работает, мне нужно чтобы когда я выбирал майора Иванова его данные должны переносится на Лист1 и так далее следующие строки должны работать так же!

Автор - clickme690
Дата добавления - 29.02.2024 в 12:41
bigor Дата: Четверг, 29.02.2024, 12:49 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1100
Репутация: 210 ±
Замечаний: 0% ±

нет
clickme690, т.е. вам нужно, что бы только ФИО подставлялось? Это формулами не решить,
вариант 1 макросы
вариант 2 рассылка писем, правда лист1 придется в ворде сделать (я так понимаю он для печати нужен)
 
Ответить
Сообщениеclickme690, т.е. вам нужно, что бы только ФИО подставлялось? Это формулами не решить,
вариант 1 макросы
вариант 2 рассылка писем, правда лист1 придется в ворде сделать (я так понимаю он для печати нужен)

Автор - bigor
Дата добавления - 29.02.2024 в 12:49
clickme690 Дата: Четверг, 29.02.2024, 13:08 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

2021
bigor, чтобы все данные подставлялось, не только ФИО
 
Ответить
Сообщениеbigor, чтобы все данные подставлялось, не только ФИО

Автор - clickme690
Дата добавления - 29.02.2024 в 13:08
bigor Дата: Четверг, 29.02.2024, 13:23 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1100
Репутация: 210 ±
Замечаний: 0% ±

нет
Ну тогда те же 2 варианта, только трудоемкость возрастет
 
Ответить
СообщениеНу тогда те же 2 варианта, только трудоемкость возрастет

Автор - bigor
Дата добавления - 29.02.2024 в 13:23
Nic70y Дата: Четверг, 29.02.2024, 14:28 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 8759
Репутация: 2273 ±
Замечаний: 0% ±

Excel 2010
в модуль листа норма 3
[vba]
Код
Private Sub Worksheet_SelectionChange(ByVal Target As Range)
    Sheets("Лист1").Range("a2") = Selection.Row
End Sub
[/vba]на листе Лист1 шрифт в ячейке A2 сделаете белым
и соот. формулы
Код
=ИНДЕКС('норма 3'!A:A;$A$2)
К сообщению приложен файл: 9956289.xlsm (35.0 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениев модуль листа норма 3
[vba]
Код
Private Sub Worksheet_SelectionChange(ByVal Target As Range)
    Sheets("Лист1").Range("a2") = Selection.Row
End Sub
[/vba]на листе Лист1 шрифт в ячейке A2 сделаете белым
и соот. формулы
Код
=ИНДЕКС('норма 3'!A:A;$A$2)

Автор - Nic70y
Дата добавления - 29.02.2024 в 14:28
AlexM Дата: Четверг, 29.02.2024, 14:47 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4490
Репутация: 1115 ±
Замечаний: 0% ±

Excel 2003
С выпадающим списком в Лист1!C9
К сообщению приложен файл: 1232314.xlsx (27.9 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеС выпадающим списком в Лист1!C9

Автор - AlexM
Дата добавления - 29.02.2024 в 14:47
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка по ячейкам (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!