Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Обьединение информации с разных листов в один - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Обьединение информации с разных листов в один (Формулы/Formulas)
Обьединение информации с разных листов в один
mabusaco Дата: Пятница, 01.03.2024, 14:05 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Добрый день, помогите, пожалуйста, как сделать так чтобы на листе общий показывались все значения, при текущей формуле он показывает только в случае если фомилия находится на одном листе, или показывает только первое значение. Заранее огоромное спасибо.
 
Ответить
СообщениеДобрый день, помогите, пожалуйста, как сделать так чтобы на листе общий показывались все значения, при текущей формуле он показывает только в случае если фомилия находится на одном листе, или показывает только первое значение. Заранее огоромное спасибо.

Автор - mabusaco
Дата добавления - 01.03.2024 в 14:05
mabusaco Дата: Пятница, 01.03.2024, 14:09 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Файл пришлось разбить, большой оказался


Сообщение отредактировал mabusaco - Пятница, 01.03.2024, 19:55
 
Ответить
СообщениеФайл пришлось разбить, большой оказался

Автор - mabusaco
Дата добавления - 01.03.2024 в 14:09
mabusaco Дата: Пятница, 01.03.2024, 14:13 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Если без открытия файлов, то есть такая формула:
=ВПР([@ФИО];ДВССЫЛ("'"&ИНДЕКС(УТ_ПСА[Список листов];ПОИСКПОЗ(ИСТИНА;СЧЁТЕСЛИМН(ДВССЫЛ("'"&УТ_ПСА[Список листов] &"'!A12:AM49");[@ФИО];ДВССЫЛ("'"&УТ_ПСА[Список листов] &"'!A12:AM49");"*")>0;0))&"'!A:AM");ДЕНЬ(E$5)+8;0)
она работает только в случае если [@ФИО] повторяется один раз на каком-то листе, а может быть на нескольких. В этом случае формула перестает работать. Как это исправить не могу понять.
 
Ответить
СообщениеЕсли без открытия файлов, то есть такая формула:
=ВПР([@ФИО];ДВССЫЛ("'"&ИНДЕКС(УТ_ПСА[Список листов];ПОИСКПОЗ(ИСТИНА;СЧЁТЕСЛИМН(ДВССЫЛ("'"&УТ_ПСА[Список листов] &"'!A12:AM49");[@ФИО];ДВССЫЛ("'"&УТ_ПСА[Список листов] &"'!A12:AM49");"*")>0;0))&"'!A:AM");ДЕНЬ(E$5)+8;0)
она работает только в случае если [@ФИО] повторяется один раз на каком-то листе, а может быть на нескольких. В этом случае формула перестает работать. Как это исправить не могу понять.

Автор - mabusaco
Дата добавления - 01.03.2024 в 14:13
bigor Дата: Пятница, 01.03.2024, 14:32 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1100
Репутация: 210 ±
Замечаний: 0% ±

нет
Все зависит от того какой у вас офис, для новых, поддерживающих =фильтр() переписать формулу будет проще, для старых придется или через аггрегате() или массивную формулу
 
Ответить
СообщениеВсе зависит от того какой у вас офис, для новых, поддерживающих =фильтр() переписать формулу будет проще, для старых придется или через аггрегате() или массивную формулу

Автор - bigor
Дата добавления - 01.03.2024 в 14:32
mabusaco Дата: Пятница, 01.03.2024, 14:57 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

К сожалению, ФИЛЬТР() нам не друг, а что за аггренате()? И куда его вставлять?
 
Ответить
СообщениеК сожалению, ФИЛЬТР() нам не друг, а что за аггренате()? И куда его вставлять?

Автор - mabusaco
Дата добавления - 01.03.2024 в 14:57
bigor Дата: Пятница, 01.03.2024, 15:08 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 1100
Репутация: 210 ±
Замечаний: 0% ±

нет
а что за аггренате()?

функция, на русском АГГРЕГАТ() кажется, пример ниже
К сообщению приложен файл: mabusaco_1.xlsx (5.7 Kb)
 
Ответить
Сообщение
а что за аггренате()?

функция, на русском АГГРЕГАТ() кажется, пример ниже

Автор - bigor
Дата добавления - 01.03.2024 в 15:08
mabusaco Дата: Пятница, 01.03.2024, 18:47 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Очень интересно, но ничего не понятно. В данном случае АГРЕГАТ работает как НАИМЕНЬШИЙ, и у нас получается список "ВАСЬ" и цифр, на против них, и самое главное это в формате одного листа, а каким бразом это приплести к нескольким листам? Искомое значение не наименьшее, оно находится на одном из листов и вопрос в том как найти значения для каждого "Васи" в столбцах других листов при наличии этого значенияи и вставить на лист.


Сообщение отредактировал mabusaco - Пятница, 01.03.2024, 18:59
 
Ответить
СообщениеОчень интересно, но ничего не понятно. В данном случае АГРЕГАТ работает как НАИМЕНЬШИЙ, и у нас получается список "ВАСЬ" и цифр, на против них, и самое главное это в формате одного листа, а каким бразом это приплести к нескольким листам? Искомое значение не наименьшее, оно находится на одном из листов и вопрос в том как найти значения для каждого "Васи" в столбцах других листов при наличии этого значенияи и вставить на лист.

Автор - mabusaco
Дата добавления - 01.03.2024 в 18:47
mabusaco Дата: Пятница, 01.03.2024, 19:57 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Все спасибо разобрался, как оказалось не нужно было искать по всей таблице оба параметра, а только по нужным столбцам и магия начинает работать, без всяких фильтров и агрегатов.
 
Ответить
СообщениеВсе спасибо разобрался, как оказалось не нужно было искать по всей таблице оба параметра, а только по нужным столбцам и магия начинает работать, без всяких фильтров и агрегатов.

Автор - mabusaco
Дата добавления - 01.03.2024 в 19:57
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Обьединение информации с разных листов в один (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!