Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Заполнение значений в определённые ячейки с учётом даты - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнение значений в определённые ячейки с учётом даты (Формулы/Formulas)
Заполнение значений в определённые ячейки с учётом даты
danxshine Дата: Пятница, 01.03.2024, 22:59 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

21
Добрый вечер, форумчане. Столкнулся с такой проблемой. Возникла необходимость составить таблицу с предстоящими платежами по кредитным продуктам с динамической сменой даты, в зависимости от времени в системе. Если с заполнением дат с помощью функции СЕГОДНЯ и добавлению календарного дня всё встало хорошо, то остро встал вопрос с заполнением значения суммы платежа из второй таблицы в первую, с учётом присвоенного значения в функции ДЕНЬ во второй таблице на втором листе. Долго танцевал с бубном около функции ВПР, но в итоге так ни к чему и не пришёл. Прошу помочь.
Так же хотелось бы поинтересоваться, реализуемо ли удаление лишнего дня в конце месяца, если, к примеру, в следующем 30 дней, а последняя ячейка принимает значение дня, следующего за ней, то есть за 30 днём в следующей строке стоит 1 число?
К сообщению приложен файл: graph.xls (29.0 Kb)


Сообщение отредактировал danxshine - Суббота, 02.03.2024, 01:08
 
Ответить
СообщениеДобрый вечер, форумчане. Столкнулся с такой проблемой. Возникла необходимость составить таблицу с предстоящими платежами по кредитным продуктам с динамической сменой даты, в зависимости от времени в системе. Если с заполнением дат с помощью функции СЕГОДНЯ и добавлению календарного дня всё встало хорошо, то остро встал вопрос с заполнением значения суммы платежа из второй таблицы в первую, с учётом присвоенного значения в функции ДЕНЬ во второй таблице на втором листе. Долго танцевал с бубном около функции ВПР, но в итоге так ни к чему и не пришёл. Прошу помочь.
Так же хотелось бы поинтересоваться, реализуемо ли удаление лишнего дня в конце месяца, если, к примеру, в следующем 30 дней, а последняя ячейка принимает значение дня, следующего за ней, то есть за 30 днём в следующей строке стоит 1 число?

Автор - danxshine
Дата добавления - 01.03.2024 в 22:59
Gustav Дата: Суббота, 02.03.2024, 02:51 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2742
Репутация: 1137 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
У меня ответ не на весь вопрос, а только на второй его абзац
реализуемо ли удаление лишнего дня в конце месяца

Да, например, такой формулой в ячейке A5 (и протягиванием ниже):
Код
=ЕСЛИОШИБКА(ЕСЛИ(МЕСЯЦ(A4+1)=МЕСЯЦ($A$4);A4+1;"");"")


МОИ: Ник, Tip box: 41001663842605
 
Ответить
СообщениеУ меня ответ не на весь вопрос, а только на второй его абзац
реализуемо ли удаление лишнего дня в конце месяца

Да, например, такой формулой в ячейке A5 (и протягиванием ниже):
Код
=ЕСЛИОШИБКА(ЕСЛИ(МЕСЯЦ(A4+1)=МЕСЯЦ($A$4);A4+1;"");"")

Автор - Gustav
Дата добавления - 02.03.2024 в 02:51
Gustav Дата: Суббота, 02.03.2024, 14:50 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2742
Репутация: 1137 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
По поводу ответа на первый абзац. Если таблица на Лист2 является законченной и не предполагается ее расширение, например, вниз (или вправо) путем добавления других платежных дней для каждого банка, то на данный момент вопрос вполне решает следующая формула на Лист1 для ячейки B4 (и последующего ее протягивания на диапазон B4:C34):
Код
=ЕСЛИОШИБКА(ЕСЛИ(ДЕНЬ($A4)=Лист2!B$2;Лист2!B$3;"");"")
К сообщению приложен файл: 6460901.xls (34.5 Kb)


МОИ: Ник, Tip box: 41001663842605
 
Ответить
СообщениеПо поводу ответа на первый абзац. Если таблица на Лист2 является законченной и не предполагается ее расширение, например, вниз (или вправо) путем добавления других платежных дней для каждого банка, то на данный момент вопрос вполне решает следующая формула на Лист1 для ячейки B4 (и последующего ее протягивания на диапазон B4:C34):
Код
=ЕСЛИОШИБКА(ЕСЛИ(ДЕНЬ($A4)=Лист2!B$2;Лист2!B$3;"");"")

Автор - Gustav
Дата добавления - 02.03.2024 в 14:50
danxshine Дата: Суббота, 02.03.2024, 19:42 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

21
По поводу ответа на первый абзац

Огромное спасибо, вопрос решён. yes
 
Ответить
Сообщение
По поводу ответа на первый абзац

Огромное спасибо, вопрос решён. yes

Автор - danxshine
Дата добавления - 02.03.2024 в 19:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнение значений в определённые ячейки с учётом даты (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!