Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как схлопнуть строки и получить общую сумму? - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как схлопнуть строки и получить общую сумму? (Формулы/Formulas)
Как схлопнуть строки и получить общую сумму?
technoir Дата: Воскресенье, 03.03.2024, 18:05 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Добрый день!

Подскажите пожалуйста.
Как схлопнуть строки и получить общую сумму?

Есть таблица с исходными данными, ее строки надо схлопнуть, указав значения некоторых столбцов через запятую (я так понимаю как то через CONCAT?) и далее получить общую сумму по строкам.
В тестовом файле я указал пример исходных данных, а также результат который я имею в виду.
Это возможно сделать?

Спасибо заранее!
К сообщению приложен файл: test_excel2.xlsx (11.4 Kb)
 
Ответить
СообщениеДобрый день!

Подскажите пожалуйста.
Как схлопнуть строки и получить общую сумму?

Есть таблица с исходными данными, ее строки надо схлопнуть, указав значения некоторых столбцов через запятую (я так понимаю как то через CONCAT?) и далее получить общую сумму по строкам.
В тестовом файле я указал пример исходных данных, а также результат который я имею в виду.
Это возможно сделать?

Спасибо заранее!

Автор - technoir
Дата добавления - 03.03.2024 в 18:05
bigor Дата: Воскресенье, 03.03.2024, 18:14 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1100
Репутация: 210 ±
Замечаний: 0% ±

нет
Какой у вас офис?
 
Ответить
СообщениеКакой у вас офис?

Автор - bigor
Дата добавления - 03.03.2024 в 18:14
technoir Дата: Воскресенье, 03.03.2024, 20:38 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
bigor, запускаться будет на 2019 и выше
 
Ответить
Сообщениеbigor, запускаться будет на 2019 и выше

Автор - technoir
Дата добавления - 03.03.2024 в 20:38
bigor Дата: Воскресенье, 03.03.2024, 21:52 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1100
Репутация: 210 ±
Замечаний: 0% ±

нет
Я не очень ориентируюсь в возможностях MSO, но если есть объеденить() и уник(), то можно такими формулами:
Для код
Код
=УНИК(A3:A16)

для товар
Код
=УНИК(B3:B16)

для площадка
Код
=ОБЪЕДИНИТЬ(",";1;УНИК(ЕСЛИ($A$3:$A$16=J23;$C$3:$C$16;"")))

для поставщик
Код
=ОБЪЕДИНИТЬ(",";1;УНИК(ЕСЛИ($A$3:$A$16=J23;$D$3:$D$16;"")))

для стоимость
Код
=СУММЕСЛИ($A$3:$A$16;J23;$E$3:$E$16)


пс ну и сводная получается почти похожая на программу максимум


Сообщение отредактировал bigor - Воскресенье, 03.03.2024, 21:54
 
Ответить
СообщениеЯ не очень ориентируюсь в возможностях MSO, но если есть объеденить() и уник(), то можно такими формулами:
Для код
Код
=УНИК(A3:A16)

для товар
Код
=УНИК(B3:B16)

для площадка
Код
=ОБЪЕДИНИТЬ(",";1;УНИК(ЕСЛИ($A$3:$A$16=J23;$C$3:$C$16;"")))

для поставщик
Код
=ОБЪЕДИНИТЬ(",";1;УНИК(ЕСЛИ($A$3:$A$16=J23;$D$3:$D$16;"")))

для стоимость
Код
=СУММЕСЛИ($A$3:$A$16;J23;$E$3:$E$16)


пс ну и сводная получается почти похожая на программу максимум

Автор - bigor
Дата добавления - 03.03.2024 в 21:52
i691198 Дата: Вторник, 05.03.2024, 21:01 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 218
Репутация: 85 ±
Замечаний: 0% ±

Добрый вечер. Для "программы максимум" вариант с макросом.
К сообщению приложен файл: test_excel2.xlsm (19.9 Kb)
 
Ответить
СообщениеДобрый вечер. Для "программы максимум" вариант с макросом.

Автор - i691198
Дата добавления - 05.03.2024 в 21:01
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как схлопнуть строки и получить общую сумму? (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!