Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск значения по столбцам с копированием - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значения по столбцам с копированием (Формулы/Formulas)
Поиск значения по столбцам с копированием
haysik Дата: Среда, 13.03.2024, 15:30 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

MS office std 2016
Всем привет, подскажите, нужно из колонки A найти равное значение в колонке D и и его значение из колонки С скопировать в колонку B напротив искомого.... Заранее благодарю!
К сообщению приложен файл: forum.xlsx (9.2 Kb)
 
Ответить
СообщениеВсем привет, подскажите, нужно из колонки A найти равное значение в колонке D и и его значение из колонки С скопировать в колонку B напротив искомого.... Заранее благодарю!

Автор - haysik
Дата добавления - 13.03.2024 в 15:30
AlexM Дата: Среда, 13.03.2024, 16:10 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4490
Репутация: 1115 ±
Замечаний: 0% ±

Excel 2003
Код
=ИНДЕКС(C$1:C$10;ПОИСКПОЗ(A1;D$1:D$10;))



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Среда, 13.03.2024, 16:10
 
Ответить
Сообщение
Код
=ИНДЕКС(C$1:C$10;ПОИСКПОЗ(A1;D$1:D$10;))

Автор - AlexM
Дата добавления - 13.03.2024 в 16:10
Gustav Дата: Среда, 13.03.2024, 17:06 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2742
Репутация: 1137 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
В свежих версиях Excel на смену связке ИНДЕКС+ПОИСКПОЗ приходит функция ПРОСМОТРX (XLOOKUP) с аналогичным набором аргументов:
Код
=ПРОСМОТРX(A1;D$1:D$10;C$1:C$10)

[p.s.]Забавно, но, тем не менее, уточню, так как самому при наборе вручную приходилось на секунду останавливаться в раздумьи:[/p.s.]
Последняя буква X в идентификаторе функции ПРОСМОТРX - это латинская "икс" (с кодом 88), а не русская "хэ" (с кодом 213) yes


МОИ: Ник, Tip box: 41001663842605

Сообщение отредактировал Gustav - Среда, 13.03.2024, 17:20
 
Ответить
СообщениеВ свежих версиях Excel на смену связке ИНДЕКС+ПОИСКПОЗ приходит функция ПРОСМОТРX (XLOOKUP) с аналогичным набором аргументов:
Код
=ПРОСМОТРX(A1;D$1:D$10;C$1:C$10)

[p.s.]Забавно, но, тем не менее, уточню, так как самому при наборе вручную приходилось на секунду останавливаться в раздумьи:[/p.s.]
Последняя буква X в идентификаторе функции ПРОСМОТРX - это латинская "икс" (с кодом 88), а не русская "хэ" (с кодом 213) yes

Автор - Gustav
Дата добавления - 13.03.2024 в 17:06
Serge_007 Дата: Четверг, 14.03.2024, 12:47 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 16475
Репутация: 2749 ±
Замечаний: ±

Excel 2016
при наборе вручную
А зачем вручную набирать название функции полностью?
Достаточно, ведь, 4-х символов


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
при наборе вручную
А зачем вручную набирать название функции полностью?
Достаточно, ведь, 4-х символов

Автор - Serge_007
Дата добавления - 14.03.2024 в 12:47
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значения по столбцам с копированием (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!