Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выпадающий список с выбором данных из редактируемой ячейки - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Выпадающий список с выбором данных из редактируемой ячейки
BBC Дата: Среда, 13.03.2024, 22:14 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 0% ±

Excel LTSC
Доброго времени суток. Есть несколько групп сотрудников по 4 человека. Они работают 2 через 2, я веду учет. В ячейках ведомостей задал условие ЕСЛИ в зависимости от выпадающего списка и прописываю ФИО в формулу. Сотрудники часто меняются в группах или увольняются. Постоянно менять условие ЕСЛИ устал. Как сделать, чтобы выпадающий список выбирал данные из конкретной ячейки, в которую легче вписать ФИО ?
К сообщению приложен файл: dezhurstva_v_gruppakh.xls (59.5 Kb)


Сообщение отредактировал BBC - Среда, 13.03.2024, 22:18
 
Ответить
СообщениеДоброго времени суток. Есть несколько групп сотрудников по 4 человека. Они работают 2 через 2, я веду учет. В ячейках ведомостей задал условие ЕСЛИ в зависимости от выпадающего списка и прописываю ФИО в формулу. Сотрудники часто меняются в группах или увольняются. Постоянно менять условие ЕСЛИ устал. Как сделать, чтобы выпадающий список выбирал данные из конкретной ячейки, в которую легче вписать ФИО ?

Автор - BBC
Дата добавления - 13.03.2024 в 22:14
DrMini Дата: Четверг, 14.03.2024, 05:32 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1759
Репутация: 244 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Здравствуйте BBC,
Для двух комбинаций на Лист1
вариант в ячейку C3:
Код
=ЕСЛИ(СЧЁТЕСЛИ(B$3;E$3);$F3;$F5)

в ячейку C4:
Код
=ЕСЛИ(СЧЁТЕСЛИ(B$3;E$3);$F4;$F6)

Получше вариант на Лист2
в ячейку C3:
Код
=ИНДЕКС(F3:F10;ПОИСКПОЗ(B$3;E$3:E$10;))

в ячейку C4:
Код
=ИНДЕКС(F4:F10;ПОИСКПОЗ($B$3;E$3:E$10;))

И можно делать не два варианта, а сколько нужно.
К сообщению приложен файл: 8365891.xls (30.5 Kb)


Сообщение отредактировал DrMini - Четверг, 14.03.2024, 05:33
 
Ответить
СообщениеЗдравствуйте BBC,
Для двух комбинаций на Лист1
вариант в ячейку C3:
Код
=ЕСЛИ(СЧЁТЕСЛИ(B$3;E$3);$F3;$F5)

в ячейку C4:
Код
=ЕСЛИ(СЧЁТЕСЛИ(B$3;E$3);$F4;$F6)

Получше вариант на Лист2
в ячейку C3:
Код
=ИНДЕКС(F3:F10;ПОИСКПОЗ(B$3;E$3:E$10;))

в ячейку C4:
Код
=ИНДЕКС(F4:F10;ПОИСКПОЗ($B$3;E$3:E$10;))

И можно делать не два варианта, а сколько нужно.

Автор - DrMini
Дата добавления - 14.03.2024 в 05:32
DrMini Дата: Четверг, 14.03.2024, 06:14 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1759
Репутация: 244 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Только сейчас увидел:
КРОСС
 
Ответить
СообщениеТолько сейчас увидел:
КРОСС

Автор - DrMini
Дата добавления - 14.03.2024 в 06:14
BBC Дата: Четверг, 14.03.2024, 18:12 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 0% ±

Excel LTSC
Спасибо. Для Вас это просто, а у меня мозг кипел )))
 
Ответить
СообщениеСпасибо. Для Вас это просто, а у меня мозг кипел )))

Автор - BBC
Дата добавления - 14.03.2024 в 18:12
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!