Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Определение координат в таблице, согласно условию. - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определение координат в таблице, согласно условию. (Формулы/Formulas)
Определение координат в таблице, согласно условию.
Chelovekov Дата: Пятница, 15.03.2024, 14:45 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 310
Репутация: 0 ±
Замечаний: 80% ±

Excel 2016
Здравствуйте, Уважаемые Форумчане. Прошу, Вас, помочь решить проблему, нужно определить координаты в таблице согласно условию.

1. Начальная позиция в данном случае "I2"
2. Если Результат 1 значить, на одну ячейку влево от текущей
3. Если Результат 2 значить, на одну ячейки вниз от текущей
4. Если за Рамки таблицы значит начинаем с I2

Пример прилагаю.
Заранее благодарен.
К сообщению приложен файл: primer2.xlsx (9.8 Kb)
 
Ответить
СообщениеЗдравствуйте, Уважаемые Форумчане. Прошу, Вас, помочь решить проблему, нужно определить координаты в таблице согласно условию.

1. Начальная позиция в данном случае "I2"
2. Если Результат 1 значить, на одну ячейку влево от текущей
3. Если Результат 2 значить, на одну ячейки вниз от текущей
4. Если за Рамки таблицы значит начинаем с I2

Пример прилагаю.
Заранее благодарен.

Автор - Chelovekov
Дата добавления - 15.03.2024 в 14:45
Nic70y Дата: Пятница, 15.03.2024, 15:00 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8759
Репутация: 2273 ±
Замечаний: 0% ±

Excel 2010
1. Начальная позиция в данном случае "I2"
2. Если Результат 1 значить, на одну ячейку влево от текущей
влево некуда, пойдем вправо
Код
=ЕСЛИ(ИЛИ(ЛЕВБ(C1)="M";ПРАВБ(C1)="6");C$1;АДРЕС(СТРОКА(ДВССЫЛ(C1))+(B2=2);СТОЛБЕЦ(ДВССЫЛ(C1))+(B2=1);4))


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Пятница, 15.03.2024, 16:02
 
Ответить
Сообщение
1. Начальная позиция в данном случае "I2"
2. Если Результат 1 значить, на одну ячейку влево от текущей
влево некуда, пойдем вправо
Код
=ЕСЛИ(ИЛИ(ЛЕВБ(C1)="M";ПРАВБ(C1)="6");C$1;АДРЕС(СТРОКА(ДВССЫЛ(C1))+(B2=2);СТОЛБЕЦ(ДВССЫЛ(C1))+(B2=1);4))

Автор - Nic70y
Дата добавления - 15.03.2024 в 15:00
Chelovekov Дата: Пятница, 15.03.2024, 15:07 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 310
Репутация: 0 ±
Замечаний: 80% ±

Excel 2016
Да спасибо, все правильно, ошибся :)

Огромное спасибо, все работает.
 
Ответить
СообщениеДа спасибо, все правильно, ошибся :)

Огромное спасибо, все работает.

Автор - Chelovekov
Дата добавления - 15.03.2024 в 15:07
Chelovekov Дата: Пятница, 15.03.2024, 15:47 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 310
Репутация: 0 ±
Замечаний: 80% ±

Excel 2016
Я немного еще потестировал, если поменять значение ПРАВБ на двухзначное число, ну например на 12, формула работает не корректно. Скорее всего нужно поменять на функцию ПРАВСИМВ(C1;2)


Сообщение отредактировал Chelovekov - Пятница, 15.03.2024, 15:49
 
Ответить
СообщениеЯ немного еще потестировал, если поменять значение ПРАВБ на двухзначное число, ну например на 12, формула работает не корректно. Скорее всего нужно поменять на функцию ПРАВСИМВ(C1;2)

Автор - Chelovekov
Дата добавления - 15.03.2024 в 15:47
Nic70y Дата: Пятница, 15.03.2024, 15:58 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 8759
Репутация: 2273 ±
Замечаний: 0% ±

Excel 2010
тоже потестировал - пред.формула неверна (недоработана) так правильно:
Код
=ЕСЛИ(ИЛИ(И(B2=2;СТРОКА(ДВССЫЛ(C1))=6);И(B2=1;СТОЛБЕЦ(ДВССЫЛ(C1))=13));C$1;АДРЕС(СТРОКА(ДВССЫЛ(C1))+(B2=2);СТОЛБЕЦ(ДВССЫЛ(C1))+(B2=1);4))
6 - максимальная строка, 13 - максимальный столбец
К сообщению приложен файл: 115_1.xlsx (10.0 Kb)


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Пятница, 15.03.2024, 16:02
 
Ответить
Сообщениетоже потестировал - пред.формула неверна (недоработана) так правильно:
Код
=ЕСЛИ(ИЛИ(И(B2=2;СТРОКА(ДВССЫЛ(C1))=6);И(B2=1;СТОЛБЕЦ(ДВССЫЛ(C1))=13));C$1;АДРЕС(СТРОКА(ДВССЫЛ(C1))+(B2=2);СТОЛБЕЦ(ДВССЫЛ(C1))+(B2=1);4))
6 - максимальная строка, 13 - максимальный столбец

Автор - Nic70y
Дата добавления - 15.03.2024 в 15:58
Chelovekov Дата: Суббота, 16.03.2024, 04:12 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 310
Репутация: 0 ±
Замечаний: 80% ±

Excel 2016
Огромное спасибо !!!
 
Ответить
СообщениеОгромное спасибо !!!

Автор - Chelovekov
Дата добавления - 16.03.2024 в 04:12
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определение координат в таблице, согласно условию. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!