Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Убрать лишний текст из ячеек - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Убрать лишний текст из ячеек
nemez0607 Дата: Пятница, 15.03.2024, 19:13 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

2007
Добрый день. Помогите пожалуйста с формулой. Есть список используемый цветов (А:А), есть названия деталей начинающиеся с цвета (В:В). Нужно в столбце С оставить только цвета этих деталей.
Нарыл в интернете такую формулу =ЕСЛИ(СУММПРОИЗВ(-ЕЧИСЛО(ПОИСК(A$2:A$18;B6)));ПРОСМОТР(2;1/ПОИСК(A$2:A$18;B6);A$2:A$18);B6)
Но она вытягивает из текста первый с права цвет, а мне надо слева. Ячейки С12 и С17
К сообщению приложен файл: primer.xls (290.5 Kb)
 
Ответить
СообщениеДобрый день. Помогите пожалуйста с формулой. Есть список используемый цветов (А:А), есть названия деталей начинающиеся с цвета (В:В). Нужно в столбце С оставить только цвета этих деталей.
Нарыл в интернете такую формулу =ЕСЛИ(СУММПРОИЗВ(-ЕЧИСЛО(ПОИСК(A$2:A$18;B6)));ПРОСМОТР(2;1/ПОИСК(A$2:A$18;B6);A$2:A$18);B6)
Но она вытягивает из текста первый с права цвет, а мне надо слева. Ячейки С12 и С17

Автор - nemez0607
Дата добавления - 15.03.2024 в 19:13
nemez0607 Дата: Пятница, 15.03.2024, 19:35 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

2007
Обновил
В ячейке С2 должно отображаться "Dark Blue"
К сообщению приложен файл: primer_2.xls (291.0 Kb)
 
Ответить
СообщениеОбновил
В ячейке С2 должно отображаться "Dark Blue"

Автор - nemez0607
Дата добавления - 15.03.2024 в 19:35
bigor Дата: Пятница, 15.03.2024, 19:48 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1157
Репутация: 221 ±
Замечаний: 0% ±

нет
Немного переставил цвета
Код
=INDEX($A$2:$A$18;MIN(IF(ISNUMBER(SEARCH($A$2:$A$18;B18));ROW($A$2:$A$18)-1;"")))
массивная
К сообщению приложен файл: primer_3.xls (67.0 Kb)
 
Ответить
СообщениеНемного переставил цвета
Код
=INDEX($A$2:$A$18;MIN(IF(ISNUMBER(SEARCH($A$2:$A$18;B18));ROW($A$2:$A$18)-1;"")))
массивная

Автор - bigor
Дата добавления - 15.03.2024 в 19:48
nemez0607 Дата: Пятница, 15.03.2024, 19:54 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

2007
bigor, с перестановкой цветов старая формула вроде так-же работала, ладно это решаемо.
Еще в ячейках С12 и С17 должно быть "White"


Сообщение отредактировал nemez0607 - Пятница, 15.03.2024, 19:57
 
Ответить
Сообщениеbigor, с перестановкой цветов старая формула вроде так-же работала, ладно это решаемо.
Еще в ячейках С12 и С17 должно быть "White"

Автор - nemez0607
Дата добавления - 15.03.2024 в 19:54
Karataev Дата: Суббота, 16.03.2024, 11:05 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1334
Репутация: 533 ±
Замечаний: 0% ±

Excel
Код
=ИНДЕКС($A$2:$A$18;ПОИСКПОЗ(1;ПОИСК($A$2:$A$18;B2);0);1)
 
Ответить
Сообщение
Код
=ИНДЕКС($A$2:$A$18;ПОИСКПОЗ(1;ПОИСК($A$2:$A$18;B2);0);1)

Автор - Karataev
Дата добавления - 16.03.2024 в 11:05
nemez0607 Дата: Суббота, 16.03.2024, 20:34 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

2007
Karataev, Похоже что работает. Спасибо большое) Только если добавить в список цветов "Reddish Brown" то деталь "Reddish Brown Brick 1 x 8" определяется как "Red"
"
К сообщению приложен файл: primer_4.xls (80.0 Kb)


Сообщение отредактировал nemez0607 - Суббота, 16.03.2024, 20:35
 
Ответить
СообщениеKarataev, Похоже что работает. Спасибо большое) Только если добавить в список цветов "Reddish Brown" то деталь "Reddish Brown Brick 1 x 8" определяется как "Red"
"

Автор - nemez0607
Дата добавления - 16.03.2024 в 20:34
DrMini Дата: Воскресенье, 17.03.2024, 06:02 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1754
Репутация: 243 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
del


Сообщение отредактировал DrMini - Воскресенье, 17.03.2024, 06:05
 
Ответить
Сообщениеdel

Автор - DrMini
Дата добавления - 17.03.2024 в 06:02
bigor Дата: Воскресенье, 17.03.2024, 21:47 | Сообщение № 8
Группа: Проверенные
Ранг: Старожил
Сообщений: 1157
Репутация: 221 ±
Замечаний: 0% ±

нет
определяется как "Red"
принцип формирования столбца А, вверху идут цвета содержащие наибольшее количество слов, "Reddish Brown" должна быть в списке перед цветами заданными одним словом
 
Ответить
Сообщение
определяется как "Red"
принцип формирования столбца А, вверху идут цвета содержащие наибольшее количество слов, "Reddish Brown" должна быть в списке перед цветами заданными одним словом

Автор - bigor
Дата добавления - 17.03.2024 в 21:47
_Boroda_ Дата: Понедельник, 18.03.2024, 09:53 | Сообщение № 9
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16675
Репутация: 6481 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант. Расположение слов произвольно
Код
=ИНДЕКС(A$1:A$19;ОСТАТ(МАКС((ПОИСК(A$2:A$19;B2&A$2:A$19)=1)*ДЛСТР(A$2:A$19)+СТРОКА(A$2:A$19)%%);1)/1%%+0,1)

Файл у меня почему-то не прикладывается


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант. Расположение слов произвольно
Код
=ИНДЕКС(A$1:A$19;ОСТАТ(МАКС((ПОИСК(A$2:A$19;B2&A$2:A$19)=1)*ДЛСТР(A$2:A$19)+СТРОКА(A$2:A$19)%%);1)/1%%+0,1)

Файл у меня почему-то не прикладывается

Автор - _Boroda_
Дата добавления - 18.03.2024 в 09:53
nemez0607 Дата: Понедельник, 18.03.2024, 19:59 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

2007
bigor, Всем спасибо. Цель достигнута)
 
Ответить
Сообщениеbigor, Всем спасибо. Цель достигнута)

Автор - nemez0607
Дата добавления - 18.03.2024 в 19:59
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!