Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск по первому слову и при совпадении подставить данные. - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск по первому слову и при совпадении подставить данные. (Формулы/Formulas)
Поиск по первому слову и при совпадении подставить данные.
Mark1976 Дата: Понедельник, 18.03.2024, 12:20 | Сообщение № 1
Группа: Проверенные
Ранг: Ветеран
Сообщений: 738
Репутация: 3 ±
Замечаний: 0% ±

Excel 2010, 2013
Здравствуйте. Помогите с решением. Есть файл, в нем 2 листа (лист1, список). Необходимо сделать поиск по первому слову, так чтобы при совпадении подставить в колонку N данные из колонки Е листа список. Пример на листе "как надо".
К сообщению приложен файл: otchet_kopija.xlsx (359.8 Kb)
 
Ответить
СообщениеЗдравствуйте. Помогите с решением. Есть файл, в нем 2 листа (лист1, список). Необходимо сделать поиск по первому слову, так чтобы при совпадении подставить в колонку N данные из колонки Е листа список. Пример на листе "как надо".

Автор - Mark1976
Дата добавления - 18.03.2024 в 12:20
_Boroda_ Дата: Понедельник, 18.03.2024, 12:38 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16675
Репутация: 6481 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
=ЕСЛИ(СЧЁТЕСЛИ(список!A$2:E$99;ЛЕВБ(B2;ПОИСК(" ";B2&" ")-1)&"*");"Да";"Нет")

Код
=ЕСЛИ(ЕНД(ВПР(ЛЕВБ(B2;ПОИСК(" ";B2&" ")-1)&"*";список!A$2:E$99;1;));"Нет";"Да")


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Код
=ЕСЛИ(СЧЁТЕСЛИ(список!A$2:E$99;ЛЕВБ(B2;ПОИСК(" ";B2&" ")-1)&"*");"Да";"Нет")

Код
=ЕСЛИ(ЕНД(ВПР(ЛЕВБ(B2;ПОИСК(" ";B2&" ")-1)&"*";список!A$2:E$99;1;));"Нет";"Да")

Автор - _Boroda_
Дата добавления - 18.03.2024 в 12:38
Mark1976 Дата: Понедельник, 18.03.2024, 13:08 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 738
Репутация: 3 ±
Замечаний: 0% ±

Excel 2010, 2013
_Boroda_, спасибо.
 
Ответить
Сообщение_Boroda_, спасибо.

Автор - Mark1976
Дата добавления - 18.03.2024 в 13:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск по первому слову и при совпадении подставить данные. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!