Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбор нескольких последних значений из столбца - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор нескольких последних значений из столбца (Формулы/Formulas)
Выбор нескольких последних значений из столбца
KyDecHuk_83 Дата: Четверг, 21.03.2024, 15:15 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

2007
Здравствуйте,

Подскажите пожалуйста, существует ли возможность каким-либо образом СЦЕПИТЬ некоторое количество последних значений из столбца, соответствующих заданному критерию?
Например, в столбце D чередуются повторяющиеся наименования "Team A", "Team B", "Team C".
Каждому из этих наименований в соседнем столбце E соответствуют разные буквенные значения.
Можно ли в целевой ячейке получить (сцепить) три последних значения, соответствующих наименованию "Team A"?

Спасибо.
К сообщению приложен файл: 7405779.xlsx (14.8 Kb)
 
Ответить
СообщениеЗдравствуйте,

Подскажите пожалуйста, существует ли возможность каким-либо образом СЦЕПИТЬ некоторое количество последних значений из столбца, соответствующих заданному критерию?
Например, в столбце D чередуются повторяющиеся наименования "Team A", "Team B", "Team C".
Каждому из этих наименований в соседнем столбце E соответствуют разные буквенные значения.
Можно ли в целевой ячейке получить (сцепить) три последних значения, соответствующих наименованию "Team A"?

Спасибо.

Автор - KyDecHuk_83
Дата добавления - 21.03.2024 в 15:15
Nic70y Дата: Четверг, 21.03.2024, 15:20 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8759
Репутация: 2273 ±
Замечаний: 0% ±

Excel 2010
Код
=ИНДЕКС(E1:E21;СУММПРОИЗВ(МАКС((D3:D21=G21)*СТРОКА(D3:D21))))&ИНДЕКС(E1:E21;СУММПРОИЗВ(НАИБОЛЬШИЙ((D3:D21=G21)*СТРОКА(D3:D21);2)))&ИНДЕКС(E1:E21;СУММПРОИЗВ(НАИБОЛЬШИЙ((D3:D21=G21)*СТРОКА(D3:D21);3)))
где G21 критерий
К сообщению приложен файл: 293.xlsx (11.5 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=ИНДЕКС(E1:E21;СУММПРОИЗВ(МАКС((D3:D21=G21)*СТРОКА(D3:D21))))&ИНДЕКС(E1:E21;СУММПРОИЗВ(НАИБОЛЬШИЙ((D3:D21=G21)*СТРОКА(D3:D21);2)))&ИНДЕКС(E1:E21;СУММПРОИЗВ(НАИБОЛЬШИЙ((D3:D21=G21)*СТРОКА(D3:D21);3)))
где G21 критерий

Автор - Nic70y
Дата добавления - 21.03.2024 в 15:20
KyDecHuk_83 Дата: Четверг, 21.03.2024, 15:41 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

2007
Спасибо. Поработаю с предложенной формулой.
 
Ответить
СообщениеСпасибо. Поработаю с предложенной формулой.

Автор - KyDecHuk_83
Дата добавления - 21.03.2024 в 15:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор нескольких последних значений из столбца (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!