Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/подсчет букв и слогов в слове - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » подсчет букв и слогов в слове (Формулы/Formulas)
подсчет букв и слогов в слове
GGR Дата: Воскресенье, 24.03.2024, 07:43 | Сообщение № 1
Группа: Пользователи
Ранг: Форумчанин
Сообщений: 101
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007
Доброе утро.Прошу помочь в решении задачи. В столбце С нужно выделить только слово. В столбце G количество букв в этом слове. В столбце H количество слогов. Как должно получится отражено в стоках 25 и 26. Количество обрабатываемых данных очень большое,поэтому высчитывать вручную не удобно.
К сообщению приложен файл: lrwr_dlja_foruma.xlsx (10.7 Kb)
 
Ответить
СообщениеДоброе утро.Прошу помочь в решении задачи. В столбце С нужно выделить только слово. В столбце G количество букв в этом слове. В столбце H количество слогов. Как должно получится отражено в стоках 25 и 26. Количество обрабатываемых данных очень большое,поэтому высчитывать вручную не удобно.

Автор - GGR
Дата добавления - 24.03.2024 в 07:43
DrMini Дата: Воскресенье, 24.03.2024, 08:24 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1647
Репутация: 208 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Здравствуйте GGR,
В столбце С нужно выделить только слово.

Код
=ЛЕВСИМВ(B25;ПОИСК("_";B25;1)-1)

В столбце G количество букв в этом слове.

Код
=ДЛСТР(C25)

В столбце H количество слогов.

Тут я пас.
К сообщению приложен файл: 0106317.xlsx (12.1 Kb)
 
Ответить
СообщениеЗдравствуйте GGR,
В столбце С нужно выделить только слово.

Код
=ЛЕВСИМВ(B25;ПОИСК("_";B25;1)-1)

В столбце G количество букв в этом слове.

Код
=ДЛСТР(C25)

В столбце H количество слогов.

Тут я пас.

Автор - DrMini
Дата добавления - 24.03.2024 в 08:24
GGR Дата: Воскресенье, 24.03.2024, 08:53 | Сообщение № 3
Группа: Пользователи
Ранг: Форумчанин
Сообщений: 101
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007
Добавила дополнительный столбец Р,чтобы рассчитать количество слогов в столбце Н.
К сообщению приложен файл: 8333297.xlsx (11.0 Kb)


Сообщение отредактировал GGR - Воскресенье, 24.03.2024, 09:17
 
Ответить
СообщениеДобавила дополнительный столбец Р,чтобы рассчитать количество слогов в столбце Н.

Автор - GGR
Дата добавления - 24.03.2024 в 08:53
AlexM Дата: Воскресенье, 24.03.2024, 09:24 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4490
Репутация: 1115 ±
Замечаний: 0% ±

Excel 2003
для слогов
Код
=СУММПРОИЗВ(--(ПСТР(C25;СТРОКА($1:$40);1)={"а";"у";"о";"и";"э";"ы";"я";"ю";"е";"ё"}))

И формула массива
Код
=СЧЁТ(ПОИСК(ПСТР(C25;СТРОКА(A$1:ИНДЕКС(A:A;ДЛСТР(C25)));1);"ауоиэыяюеё"))



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Воскресенье, 24.03.2024, 09:47
 
Ответить
Сообщениедля слогов
Код
=СУММПРОИЗВ(--(ПСТР(C25;СТРОКА($1:$40);1)={"а";"у";"о";"и";"э";"ы";"я";"ю";"е";"ё"}))

И формула массива
Код
=СЧЁТ(ПОИСК(ПСТР(C25;СТРОКА(A$1:ИНДЕКС(A:A;ДЛСТР(C25)));1);"ауоиэыяюеё"))

Автор - AlexM
Дата добавления - 24.03.2024 в 09:24
GGR Дата: Воскресенье, 24.03.2024, 12:59 | Сообщение № 5
Группа: Пользователи
Ранг: Форумчанин
Сообщений: 101
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007
DrMini, AlexM все отлично работает .Сердечно благодарю!
 
Ответить
СообщениеDrMini, AlexM все отлично работает .Сердечно благодарю!

Автор - GGR
Дата добавления - 24.03.2024 в 12:59
GGR Дата: Воскресенье, 24.03.2024, 13:09 | Сообщение № 6
Группа: Пользователи
Ранг: Форумчанин
Сообщений: 101
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007
DrMini, AlexM все отлично работает .Сердечно благодарю!
 
Ответить
СообщениеDrMini, AlexM все отлично работает .Сердечно благодарю!

Автор - GGR
Дата добавления - 24.03.2024 в 13:09
Юрий_Ф Дата: Пятница, 29.03.2024, 14:33 | Сообщение № 7
Группа: Проверенные
Ранг: Ветеран
Сообщений: 777
Репутация: 1 ±
Замечаний: 60% ±

Excel 2010
AlexM,

А русскими буквами как будет формула?


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!
 
Ответить
СообщениеAlexM,

А русскими буквами как будет формула?

Автор - Юрий_Ф
Дата добавления - 29.03.2024 в 14:33
AlexM Дата: Пятница, 29.03.2024, 15:17 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4490
Репутация: 1115 ±
Замечаний: 0% ±

Excel 2003
А русскими буквами как будет формула?

Левее формулы в сообщении №4 есть кнопочка кликните по ней и будет перевод.



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
А русскими буквами как будет формула?

Левее формулы в сообщении №4 есть кнопочка кликните по ней и будет перевод.

Автор - AlexM
Дата добавления - 29.03.2024 в 15:17
Юрий_Ф Дата: Пятница, 29.03.2024, 21:41 | Сообщение № 9
Группа: Проверенные
Ранг: Ветеран
Сообщений: 777
Репутация: 1 ±
Замечаний: 60% ±

Excel 2010
AlexM,

Спасибо. Об этой функции сайта я не знал!


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!
 
Ответить
СообщениеAlexM,

Спасибо. Об этой функции сайта я не знал!

Автор - Юрий_Ф
Дата добавления - 29.03.2024 в 21:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » подсчет букв и слогов в слове (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!