Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Посчитать количества статусов если даты совпадают - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Посчитать количества статусов если даты совпадают
move52 Дата: Среда, 27.03.2024, 11:00 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

2016
Добрый день!

Есть таблица с данными Лист 1 в которой отражены статусы и дата создания. Необходимо в таблице 2 (Лист 2) посчитать количество ячеек из таблицы Лист 1 в статусах : В работе, Назаначен, Назначено, Ожидание при условии, если дата из листа 2 = дате создания на лисле 1.

Пробовал счёт если, Если, Индекс. HELP PLZ!!!
К сообщению приложен файл: kejs_1.xlsx (12.0 Kb)
 
Ответить
СообщениеДобрый день!

Есть таблица с данными Лист 1 в которой отражены статусы и дата создания. Необходимо в таблице 2 (Лист 2) посчитать количество ячеек из таблицы Лист 1 в статусах : В работе, Назаначен, Назначено, Ожидание при условии, если дата из листа 2 = дате создания на лисле 1.

Пробовал счёт если, Если, Индекс. HELP PLZ!!!

Автор - move52
Дата добавления - 27.03.2024 в 11:00
_Boroda_ Дата: Среда, 27.03.2024, 11:18 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16675
Репутация: 6481 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Попробуйте
Код
=СЧЁТЕСЛИМН('Лист 1'!$C$2:$C$99;$A2;'Лист 1'!$B$2:$B$99;"В работе")

Нули можно скрыть форматом ячеек
Вот таким
0;;
К сообщению приложен файл: kejs_2.xlsx (14.1 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПопробуйте
Код
=СЧЁТЕСЛИМН('Лист 1'!$C$2:$C$99;$A2;'Лист 1'!$B$2:$B$99;"В работе")

Нули можно скрыть форматом ячеек
Вот таким
0;;

Автор - _Boroda_
Дата добавления - 27.03.2024 в 11:18
DrMini Дата: Среда, 27.03.2024, 11:34 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1759
Репутация: 244 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Как вариант без нулей и в 4 столбца:
Код
=ЕСЛИ(СЧЁТЕСЛИМН('Лист 1'!$B$2:$B$38;C$1;'Лист 1'!$C$2:$C$38;$A2);СЧЁТЕСЛИМН('Лист 1'!$B$2:$B$38;C$1;'Лист 1'!$C$2:$C$38;$A2);"")

После обеда подумал про ещё один вариант в один столбец.
Код
=СУММПРОИЗВ(('Лист 1'!$C$2:$C$38=A2)*('Лист 1'!$B$2:$B$38=$B$1))

может так даже и удобнее?
К сообщению приложен файл: 3227880.xlsx (16.4 Kb)


Сообщение отредактировал DrMini - Среда, 27.03.2024, 13:21
 
Ответить
СообщениеКак вариант без нулей и в 4 столбца:
Код
=ЕСЛИ(СЧЁТЕСЛИМН('Лист 1'!$B$2:$B$38;C$1;'Лист 1'!$C$2:$C$38;$A2);СЧЁТЕСЛИМН('Лист 1'!$B$2:$B$38;C$1;'Лист 1'!$C$2:$C$38;$A2);"")

После обеда подумал про ещё один вариант в один столбец.
Код
=СУММПРОИЗВ(('Лист 1'!$C$2:$C$38=A2)*('Лист 1'!$B$2:$B$38=$B$1))

может так даже и удобнее?

Автор - DrMini
Дата добавления - 27.03.2024 в 11:34
move52 Дата: Четверг, 28.03.2024, 14:41 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

2016
Спасибо всем за помощь!!!
 
Ответить
СообщениеСпасибо всем за помощь!!!

Автор - move52
Дата добавления - 28.03.2024 в 14:41
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!