Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Среднее значение по выборочному масиву - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Среднее значение по выборочному масиву (Формулы/Formulas)
Среднее значение по выборочному масиву
ssserzh Дата: Четверг, 04.04.2024, 16:56 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 20% ±

Здравствуйте, о, мудрейшие)
Не могу никак понять и сообразить, как вычислить среднее значение из выборочных данных в столбце, уже всё перепробовал (кроме макросов), и гпт тоже мучал, не соображу
Пример привёл в вложении
Нужно из столбца вычленить определенного человека, с условием Да в другом столбце, и вот из этих цифр узнать среднее значение

Помогите, пожалуйста, великие!))
К сообщению приложен файл: pomoshh.xlsx (9.2 Kb)
 
Ответить
СообщениеЗдравствуйте, о, мудрейшие)
Не могу никак понять и сообразить, как вычислить среднее значение из выборочных данных в столбце, уже всё перепробовал (кроме макросов), и гпт тоже мучал, не соображу
Пример привёл в вложении
Нужно из столбца вычленить определенного человека, с условием Да в другом столбце, и вот из этих цифр узнать среднее значение

Помогите, пожалуйста, великие!))

Автор - ssserzh
Дата добавления - 04.04.2024 в 16:56
Nic70y Дата: Четверг, 04.04.2024, 17:05 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8791
Репутация: 2293 ±
Замечаний: 0% ±

Excel 2010
почему 3, а не 2,5?
формула массива
Код
=СРЗНАЧ(ЕСЛИ((E$7:E$18=B11)*(G$7:G$18="Да")*($F$7:$F$18<C11);F$7:F$18))
К сообщению приложен файл: 2558232.xlsx (9.5 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениепочему 3, а не 2,5?
формула массива
Код
=СРЗНАЧ(ЕСЛИ((E$7:E$18=B11)*(G$7:G$18="Да")*($F$7:$F$18<C11);F$7:F$18))

Автор - Nic70y
Дата добавления - 04.04.2024 в 17:05
DrMini Дата: Четверг, 04.04.2024, 18:50 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1678
Репутация: 226 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Как вариант (практически тоже самое):
Код
=СРЗНАЧЕСЛИМН($F$7:$F$18;$E$7:$E$18;B11;$G$7:$G$18;"Да";$F$7:$F$18;"<4")

Ячейки C12 и C14 округлил до целого.
Если ТС ошибся то изменяется форматом ячейки.
К сообщению приложен файл: 1960627.xlsx (10.0 Kb)
 
Ответить
СообщениеКак вариант (практически тоже самое):
Код
=СРЗНАЧЕСЛИМН($F$7:$F$18;$E$7:$E$18;B11;$G$7:$G$18;"Да";$F$7:$F$18;"<4")

Ячейки C12 и C14 округлил до целого.
Если ТС ошибся то изменяется форматом ячейки.

Автор - DrMini
Дата добавления - 04.04.2024 в 18:50
Nic70y Дата: Пятница, 05.04.2024, 07:51 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 8791
Репутация: 2293 ±
Замечаний: 0% ±

Excel 2010
СРЗНАЧЕСЛИМН
совсем я стал забывать формулы(
скорей всего "<"&C11
Если ТС ошибся
возможно имелось в виду "<="&C11


ЮMoney 41001841029809
 
Ответить
Сообщение
СРЗНАЧЕСЛИМН
совсем я стал забывать формулы(
скорей всего "<"&C11
Если ТС ошибся
возможно имелось в виду "<="&C11

Автор - Nic70y
Дата добавления - 05.04.2024 в 07:51
DrMini Дата: Пятница, 05.04.2024, 08:30 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1678
Репутация: 226 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
скорей всего "<"&C11

Я только сейчас понял, что за цифра в ячейке C11 и ячейке C13.
возможно имелось в виду "<="&C11


написано так. Возможно ошибочка вышла.
К сообщению приложен файл: 5182743.jpg (11.8 Kb)


Сообщение отредактировал DrMini - Пятница, 05.04.2024, 08:39
 
Ответить
Сообщение
скорей всего "<"&C11

Я только сейчас понял, что за цифра в ячейке C11 и ячейке C13.
возможно имелось в виду "<="&C11


написано так. Возможно ошибочка вышла.

Автор - DrMini
Дата добавления - 05.04.2024 в 08:30
ssserzh Дата: Пятница, 05.04.2024, 09:09 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 20% ±

=СРЗНАЧЕСЛИМН($F$7:$F$18;$E$7:$E$18;B11;$G$7:$G$18;"Да";$F$7:$F$18;"<4")

Да, спасибо) именно оно)
никак не мог эту формулу полностью доделать((

А вопрос не дописал ещё, а если нужно найти среднее в диапазоне? То есть не <=4, а "от 2 до 4"?
Попробовал через сложение формул (т.е. срзначеалимн...=2) + срзначеалимн....=3) + срзначеслмн...=4)) то выходит ошибка, что делю на ноль.. (
 
Ответить
Сообщение
=СРЗНАЧЕСЛИМН($F$7:$F$18;$E$7:$E$18;B11;$G$7:$G$18;"Да";$F$7:$F$18;"<4")

Да, спасибо) именно оно)
никак не мог эту формулу полностью доделать((

А вопрос не дописал ещё, а если нужно найти среднее в диапазоне? То есть не <=4, а "от 2 до 4"?
Попробовал через сложение формул (т.е. срзначеалимн...=2) + срзначеалимн....=3) + срзначеслмн...=4)) то выходит ошибка, что делю на ноль.. (

Автор - ssserzh
Дата добавления - 05.04.2024 в 09:09
Nic70y Дата: Пятница, 05.04.2024, 09:22 | Сообщение № 7
Группа: Друзья
Ранг: Экселист
Сообщений: 8791
Репутация: 2293 ±
Замечаний: 0% ±

Excel 2010
Код
=СРЗНАЧЕСЛИМН($F$7:$F$18;$E$7:$E$18;B11;$G$7:$G$18;"Да";$F$7:$F$18;">=2";$F$7:$F$18;"<=4")


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=СРЗНАЧЕСЛИМН($F$7:$F$18;$E$7:$E$18;B11;$G$7:$G$18;"Да";$F$7:$F$18;">=2";$F$7:$F$18;"<=4")

Автор - Nic70y
Дата добавления - 05.04.2024 в 09:22
ssserzh Дата: Пятница, 05.04.2024, 09:28 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 20% ±

Вы все потрясающие!) спасибо)
 
Ответить
СообщениеВы все потрясающие!) спасибо)

Автор - ssserzh
Дата добавления - 05.04.2024 в 09:28
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Среднее значение по выборочному масиву (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!