Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Смещение данных по столбцу - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Смещение данных по столбцу (Формулы/Formulas)
Смещение данных по столбцу
astashovmichail Дата: Четверг, 18.04.2024, 13:18 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Добрый всем день. такая вот загвоздка. В ячейку А1 введена формула, при её протягивании вниз, переменные смещаются вниз по первому столбцу "С", а необходимо, что они брались со столбцов справа, через 4 столбца каждый.
К сообщению приложен файл: vopros_1.xlsx (14.6 Kb)
 
Ответить
СообщениеДобрый всем день. такая вот загвоздка. В ячейку А1 введена формула, при её протягивании вниз, переменные смещаются вниз по первому столбцу "С", а необходимо, что они брались со столбцов справа, через 4 столбца каждый.

Автор - astashovmichail
Дата добавления - 18.04.2024 в 13:18
bigor Дата: Четверг, 18.04.2024, 13:30 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1116
Репутация: 212 ±
Замечаний: 0% ±

нет
Добрый. Вы лучше словами опишите и в файле покажите что нужно получить в итоге. А то пока ищем второй столбец "С" работа стоит
Кажется понял, вы ниже формулу написали как должно меняться. А вправо тащить не вариант?


Сообщение отредактировал bigor - Четверг, 18.04.2024, 13:32
 
Ответить
СообщениеДобрый. Вы лучше словами опишите и в файле покажите что нужно получить в итоге. А то пока ищем второй столбец "С" работа стоит
Кажется понял, вы ниже формулу написали как должно меняться. А вправо тащить не вариант?

Автор - bigor
Дата добавления - 18.04.2024 в 13:30
astashovmichail Дата: Четверг, 18.04.2024, 13:49 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

bigor, в том документе где это необходимо, справа от формулы имеются другие столбцы с информацией, и что б так делать пришлось бы заводить новую пустую вкладку, затем как то ТРАНСПОРТИРОВАТЬ в нужную вкладку + данные былиб через 4 пустые строки. А хотелось бы просто протягиванием вниз.
К сообщению приложен файл: vopros_2.xlsx (15.7 Kb)
 
Ответить
Сообщениеbigor, в том документе где это необходимо, справа от формулы имеются другие столбцы с информацией, и что б так делать пришлось бы заводить новую пустую вкладку, затем как то ТРАНСПОРТИРОВАТЬ в нужную вкладку + данные былиб через 4 пустые строки. А хотелось бы просто протягиванием вниз.

Автор - astashovmichail
Дата добавления - 18.04.2024 в 13:49
Nic70y Дата: Четверг, 18.04.2024, 13:49 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 8792
Репутация: 2293 ±
Замечаний: 0% ±

Excel 2010
Код
=СУММ(ЕСЛИ(ИНДЕКС($C$1:$AB$36;;(СТРОКА(A1)-1)*5+1)>=1000;ОКРУГЛ(ИНДЕКС($C$1:$AB$36;;(СТРОКА(A1)-1)*5+1)/999;0);ЕСЛИ(ИНДЕКС($C$1:$AB$36;;(СТРОКА(A1)-1)*5+1)>=500;1;0)))
К сообщению приложен файл: 4321988.xlsx (14.9 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=СУММ(ЕСЛИ(ИНДЕКС($C$1:$AB$36;;(СТРОКА(A1)-1)*5+1)>=1000;ОКРУГЛ(ИНДЕКС($C$1:$AB$36;;(СТРОКА(A1)-1)*5+1)/999;0);ЕСЛИ(ИНДЕКС($C$1:$AB$36;;(СТРОКА(A1)-1)*5+1)>=500;1;0)))

Автор - Nic70y
Дата добавления - 18.04.2024 в 13:49
astashovmichail Дата: Четверг, 18.04.2024, 13:55 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, спасибо большое
 
Ответить
СообщениеNic70y, спасибо большое

Автор - astashovmichail
Дата добавления - 18.04.2024 в 13:55
Gustav Дата: Четверг, 18.04.2024, 19:48 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2758
Репутация: 1139 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Если же хочется формулы иметь более традиционные и понятные, то надо сначала сгенерировать их в том месте, где они хорошо протягиваются. В данном случае это можно сделать в любой свободной строке, т.е. "по горизонтали", допустим в строке 100 (ниже основного массива данных).

Последовательность действий такова:

1. Ввести в ячейку C100 исходную формулу, предназначенную для ячейки A1 (формула - массива! c Ctrl+Shift+Enter):
Код
=СУММПРОИЗВ(ЕСЛИ(C$1:C$36>=1000;ОКРУГЛ(C$1:C$36/999;0);ЕСЛИ(C$1:C$36>=500;1;0)))

2. Скопировать эту формулу в ячейку H100 - получится такая (которая впоследствии окажется в ячейке A2):
Код
=СУММПРОИЗВ(ЕСЛИ(H$1:H$36>=1000;ОКРУГЛ(H$1:H$36/999;0);ЕСЛИ(H$1:H$36>=500;1;0)))

3. Далее выделить горизонтальный диапазон D100:H100 (т.е. формула в H100 и четыре предыдущие пустые ячейки) и протянуть его по строке до ячейки AB100 включительно. Убедиться, что в ячейках M100, R100, W100 и AB100 появились аналогичные формулы.

4. Далее выделить весь текущий рабочий диапазон C100:AB100, нажать Ctrl+G и далее кнопку "Выделить". В открывшемся диалоге "Выделить группу ячеек" выбрать опцию "Пустые ячейки" и нажать "ОК".

5. Не снимая выделения, нажать Ctrl+Минус (или выполнить команду "Удалить..." в контекстном меню). В открывшемся диалоге "Удаление ячеек" выбрать опцию "ячейки, со сдвигом влево" и нажать "ОК" - произойдет "сжатие" ячеек с формулами внутри строки 100.

6. Выделить получившуюся группу идущих подряд непустых ячеек в строке 100 - диапазон C100:H100. И скопировать их. Далее встать на строку ниже - в ячейку C101 и в контекстном меню выполнить команду "Специальная вставка". Отметив "галочкой" опцию "транспонировать", нажать "ОК".

7. Выделить получившийся вертикальный диапазон C101:C106, зацепить его мышкой и отбуксировать в начало таблицы в диапазон A1:A6. Готово! (Не забудьте подчистить вспомогательный "материал" в строке 100)

Получается несколько утомительно, зато формулы остаются простыми, в том виде, в каком их хотелось видеть изначально. А после пары раз выполнения этого алгоритма навык доводится до автоматизма.


МОИ: Ник, Tip box: 41001663842605

Сообщение отредактировал Gustav - Четверг, 18.04.2024, 19:58
 
Ответить
СообщениеЕсли же хочется формулы иметь более традиционные и понятные, то надо сначала сгенерировать их в том месте, где они хорошо протягиваются. В данном случае это можно сделать в любой свободной строке, т.е. "по горизонтали", допустим в строке 100 (ниже основного массива данных).

Последовательность действий такова:

1. Ввести в ячейку C100 исходную формулу, предназначенную для ячейки A1 (формула - массива! c Ctrl+Shift+Enter):
Код
=СУММПРОИЗВ(ЕСЛИ(C$1:C$36>=1000;ОКРУГЛ(C$1:C$36/999;0);ЕСЛИ(C$1:C$36>=500;1;0)))

2. Скопировать эту формулу в ячейку H100 - получится такая (которая впоследствии окажется в ячейке A2):
Код
=СУММПРОИЗВ(ЕСЛИ(H$1:H$36>=1000;ОКРУГЛ(H$1:H$36/999;0);ЕСЛИ(H$1:H$36>=500;1;0)))

3. Далее выделить горизонтальный диапазон D100:H100 (т.е. формула в H100 и четыре предыдущие пустые ячейки) и протянуть его по строке до ячейки AB100 включительно. Убедиться, что в ячейках M100, R100, W100 и AB100 появились аналогичные формулы.

4. Далее выделить весь текущий рабочий диапазон C100:AB100, нажать Ctrl+G и далее кнопку "Выделить". В открывшемся диалоге "Выделить группу ячеек" выбрать опцию "Пустые ячейки" и нажать "ОК".

5. Не снимая выделения, нажать Ctrl+Минус (или выполнить команду "Удалить..." в контекстном меню). В открывшемся диалоге "Удаление ячеек" выбрать опцию "ячейки, со сдвигом влево" и нажать "ОК" - произойдет "сжатие" ячеек с формулами внутри строки 100.

6. Выделить получившуюся группу идущих подряд непустых ячеек в строке 100 - диапазон C100:H100. И скопировать их. Далее встать на строку ниже - в ячейку C101 и в контекстном меню выполнить команду "Специальная вставка". Отметив "галочкой" опцию "транспонировать", нажать "ОК".

7. Выделить получившийся вертикальный диапазон C101:C106, зацепить его мышкой и отбуксировать в начало таблицы в диапазон A1:A6. Готово! (Не забудьте подчистить вспомогательный "материал" в строке 100)

Получается несколько утомительно, зато формулы остаются простыми, в том виде, в каком их хотелось видеть изначально. А после пары раз выполнения этого алгоритма навык доводится до автоматизма.

Автор - Gustav
Дата добавления - 18.04.2024 в 19:48
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Смещение данных по столбцу (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!