Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула с итоговым значением в виде текста - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула с итоговым значением в виде текста (Формулы/Formulas)
Формула с итоговым значением в виде текста
tonechkazvereva Дата: Суббота, 20.04.2024, 11:23 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

2016
Добрый день!

По учебе задали написать формулу по следующему условию: формула должна выдавать при совпадении артикулов надпись "ДУБЛЬ", если артикула не совпадают - надпись "НЕТ ДУБЛЯ" при сравнении двух таблиц на одном листе. Также присутствует условие, что, если в "Доступно, шт" значение 0, то должна появиться надпись "НЕТ ПРОДАЖ".

Я понимаю, что нужно сделать через ВПР и логическую функцию. Но как их объединить и сделать так, чтобы в итоговой ячейке прописывались текстовые значения - не знаю :(

К сообщению приложен файл: zadanie.xlsx (58.2 Kb)
 
Ответить
СообщениеДобрый день!

По учебе задали написать формулу по следующему условию: формула должна выдавать при совпадении артикулов надпись "ДУБЛЬ", если артикула не совпадают - надпись "НЕТ ДУБЛЯ" при сравнении двух таблиц на одном листе. Также присутствует условие, что, если в "Доступно, шт" значение 0, то должна появиться надпись "НЕТ ПРОДАЖ".

Я понимаю, что нужно сделать через ВПР и логическую функцию. Но как их объединить и сделать так, чтобы в итоговой ячейке прописывались текстовые значения - не знаю :(


Автор - tonechkazvereva
Дата добавления - 20.04.2024 в 11:23
AlexM Дата: Суббота, 20.04.2024, 11:47 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4512
Репутация: 1128 ±
Замечаний: 0% ±

Excel 2003
Нет ни одного совпадения.
Поясните. Совпадение артикула в А2 ищем в столбце F или в F b A
В примере хорошо бы показывать ожидаемый результат.



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеНет ни одного совпадения.
Поясните. Совпадение артикула в А2 ищем в столбце F или в F b A
В примере хорошо бы показывать ожидаемый результат.

Автор - AlexM
Дата добавления - 20.04.2024 в 11:47
DrMini Дата: Суббота, 20.04.2024, 12:07 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1678
Репутация: 226 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Здравствуйте tonechkazvereva,
Так должно быть?
Код
=ЕСЛИМН(H2=0;"нет продаж";ИЛИ(СОВПАД(F2;$A$2:$A$499));"дубль";1;"нет дубля")

Формула массивная. Ctrl+Shift+Enter
смотрите столбец J
К сообщению приложен файл: 7288629.xlsx (82.4 Kb)


Сообщение отредактировал DrMini - Суббота, 20.04.2024, 12:07
 
Ответить
СообщениеЗдравствуйте tonechkazvereva,
Так должно быть?
Код
=ЕСЛИМН(H2=0;"нет продаж";ИЛИ(СОВПАД(F2;$A$2:$A$499));"дубль";1;"нет дубля")

Формула массивная. Ctrl+Shift+Enter
смотрите столбец J

Автор - DrMini
Дата добавления - 20.04.2024 в 12:07
AlexM Дата: Суббота, 20.04.2024, 12:56 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4512
Репутация: 1128 ±
Замечаний: 0% ±

Excel 2003
для D2
Код
=ЕСЛИ(СЧЁТЕСЛИ(F:F;A2);"дубль";"нет дубля")

Для I2
Код
=ЕСЛИ(H2=0;"нет продаж";ЕСЛИ(СЧЁТЕСЛИ(A:A;F2);"дубль";"нет дубля"))



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщениедля D2
Код
=ЕСЛИ(СЧЁТЕСЛИ(F:F;A2);"дубль";"нет дубля")

Для I2
Код
=ЕСЛИ(H2=0;"нет продаж";ЕСЛИ(СЧЁТЕСЛИ(A:A;F2);"дубль";"нет дубля"))

Автор - AlexM
Дата добавления - 20.04.2024 в 12:56
DrMini Дата: Суббота, 20.04.2024, 13:07 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1678
Репутация: 226 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Вот ведь бывает в субботу после пятницы... СЧЁТЕСЛИ даже в голову не "постучалась".
booze
 
Ответить
СообщениеВот ведь бывает в субботу после пятницы... СЧЁТЕСЛИ даже в голову не "постучалась".
booze

Автор - DrMini
Дата добавления - 20.04.2024 в 13:07
AlexM Дата: Суббота, 20.04.2024, 13:15 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4512
Репутация: 1128 ±
Замечаний: 0% ±

Excel 2003
Вариант для I2
Код
=ТЕКСТ((H2=0)-(СЧЁТЕСЛИ(A:A;F2)>0);"нет про\даж;\дубль;нет \дубля")



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеВариант для I2
Код
=ТЕКСТ((H2=0)-(СЧЁТЕСЛИ(A:A;F2)>0);"нет про\даж;\дубль;нет \дубля")

Автор - AlexM
Дата добавления - 20.04.2024 в 13:15
i691198 Дата: Суббота, 20.04.2024, 13:27 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 223
Репутация: 85 ±
Замечаний: 0% ±

Здравствуйте. Я так понял, что это одна таблица, которую разделили на две колонки. Значит и формулы должны быть одинаковыми, только с разными ссылками. Например так.
Для D2
Код
=ЕСЛИ(C2=0;"НЕТ ПРОДАЖ";ЕСЛИ((СЧЁТЕСЛИ($A$2:$A$4994;A2)+СЧЁТЕСЛИ($F$2:$F$499;A2))>1;"ДУБЛЬ";"НЕТ ДУБЛЯ"))

для I2
Код
=ЕСЛИ(H2=0;"НЕТ ПРОДАЖ";ЕСЛИ((СЧЁТЕСЛИ($A$2:$A$4994;F2)+СЧЁТЕСЛИ($F$2:$F$499;F2))>1;"ДУБЛЬ";"НЕТ ДУБЛЯ"))

P.S. В своем профиле ТС указал версию эксель 2016, функции ЕСЛИМН в нем нет.


Сообщение отредактировал i691198 - Суббота, 20.04.2024, 13:31
 
Ответить
СообщениеЗдравствуйте. Я так понял, что это одна таблица, которую разделили на две колонки. Значит и формулы должны быть одинаковыми, только с разными ссылками. Например так.
Для D2
Код
=ЕСЛИ(C2=0;"НЕТ ПРОДАЖ";ЕСЛИ((СЧЁТЕСЛИ($A$2:$A$4994;A2)+СЧЁТЕСЛИ($F$2:$F$499;A2))>1;"ДУБЛЬ";"НЕТ ДУБЛЯ"))

для I2
Код
=ЕСЛИ(H2=0;"НЕТ ПРОДАЖ";ЕСЛИ((СЧЁТЕСЛИ($A$2:$A$4994;F2)+СЧЁТЕСЛИ($F$2:$F$499;F2))>1;"ДУБЛЬ";"НЕТ ДУБЛЯ"))

P.S. В своем профиле ТС указал версию эксель 2016, функции ЕСЛИМН в нем нет.

Автор - i691198
Дата добавления - 20.04.2024 в 13:27
AlexM Дата: Суббота, 20.04.2024, 17:13 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4512
Репутация: 1128 ±
Замечаний: 0% ±

Excel 2003
В своем профиле ТС указал версию эксель 2016

У меня в профиле Excel 2003, а использую 2016. Не могу поменять профиль. Ругается на превышение длины.



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
В своем профиле ТС указал версию эксель 2016

У меня в профиле Excel 2003, а использую 2016. Не могу поменять профиль. Ругается на превышение длины.

Автор - AlexM
Дата добавления - 20.04.2024 в 17:13
DrMini Дата: Суббота, 20.04.2024, 18:47 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 1678
Репутация: 226 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Цитата tonechkazvereva, 20.04.2024 в 11:23, в сообщении № 1 ()
Я понимаю, что нужно сделать через ВПР и логическую функцию.

просто вариант "до кучи":
Код
=ЕСЛИ(H2=0;"нет продаж";ЕСЛИ(ЕСЛИОШИБКА(ВПР(F2;$A$2:$A$499;1;););"дубль";"нет дубля"))
 
Ответить
Сообщение
Цитата tonechkazvereva, 20.04.2024 в 11:23, в сообщении № 1 ()
Я понимаю, что нужно сделать через ВПР и логическую функцию.

просто вариант "до кучи":
Код
=ЕСЛИ(H2=0;"нет продаж";ЕСЛИ(ЕСЛИОШИБКА(ВПР(F2;$A$2:$A$499;1;););"дубль";"нет дубля"))

Автор - DrMini
Дата добавления - 20.04.2024 в 18:47
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула с итоговым значением в виде текста (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!