Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Нахождение определенного текста в огромном массиве - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Нахождение определенного текста в огромном массиве (Формулы/Formulas)
Нахождение определенного текста в огромном массиве
ПАМ Дата: Понедельник, 22.04.2024, 14:33 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 286
Репутация: 11 ±
Замечаний: 20% ±

Excel 2010, Excel 2016
Здравствуйте уважаемые форумчане и гости форума! Помогите мне пожалуйста разобраться в моей проблеме

Мне нужно, что бы из массива на листе Исх. на лист Почасовые показания находились значения
<OBJ_ID>
<TU_ID>
<PARAM_ID>
<дата>

Сложность для меня в том, что во первых на листе Исх все в текстовом формате (как я понимаю), а во вторых данных целый массив, который очищен только для примера и чтобы не потерять целостность файла. Поиск можно задать и по строчке ПУ и по строчке номер ПУ (5и 6) листа Показания.

Проще говоря, ячейки X1:X4 и Y1:Y4 из листа Исх перенести на лист показания только сложными массивными формулами поиска.
Помогите мне пожалуйста в этом разобраться.

Надеюсь пояснил правильно. Спасибо всем заранее! Всех благ!
К сообщению приложен файл: 6185648.xlsx (49.0 Kb)
 
Ответить
СообщениеЗдравствуйте уважаемые форумчане и гости форума! Помогите мне пожалуйста разобраться в моей проблеме

Мне нужно, что бы из массива на листе Исх. на лист Почасовые показания находились значения
<OBJ_ID>
<TU_ID>
<PARAM_ID>
<дата>

Сложность для меня в том, что во первых на листе Исх все в текстовом формате (как я понимаю), а во вторых данных целый массив, который очищен только для примера и чтобы не потерять целостность файла. Поиск можно задать и по строчке ПУ и по строчке номер ПУ (5и 6) листа Показания.

Проще говоря, ячейки X1:X4 и Y1:Y4 из листа Исх перенести на лист показания только сложными массивными формулами поиска.
Помогите мне пожалуйста в этом разобраться.

Надеюсь пояснил правильно. Спасибо всем заранее! Всех благ!

Автор - ПАМ
Дата добавления - 22.04.2024 в 14:33
N-dmitriy Дата: Понедельник, 22.04.2024, 16:28 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 2 ±
Замечаний: 0% ±

2021
Так?
К сообщению приложен файл: 4904058.xlsx (49.5 Kb)


Шлюхогон42
 
Ответить
СообщениеТак?

Автор - N-dmitriy
Дата добавления - 22.04.2024 в 16:28
gling Дата: Понедельник, 22.04.2024, 19:59 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2525
Репутация: 678 ±
Замечаний: 0% ±

2010
перенести на лист показания только сложными массивными формулами.

А почему обязательно сложными и массивными, простыми нельзя? Номер ПУ уникален, по этому сцепка двух ячеек не нужна и массивный ввод формулы тоже не нужен. Для В1 можно так
Код
=ИНДЕКС(Исх!$1:$4;СТРОКА();ПОИСКПОЗ(E$6;Исх!$6:$6;))
и тянуть вниз и вправо.


ЯД-41001506838083
 
Ответить
Сообщение
перенести на лист показания только сложными массивными формулами.

А почему обязательно сложными и массивными, простыми нельзя? Номер ПУ уникален, по этому сцепка двух ячеек не нужна и массивный ввод формулы тоже не нужен. Для В1 можно так
Код
=ИНДЕКС(Исх!$1:$4;СТРОКА();ПОИСКПОЗ(E$6;Исх!$6:$6;))
и тянуть вниз и вправо.

Автор - gling
Дата добавления - 22.04.2024 в 19:59
ПАМ Дата: Вторник, 23.04.2024, 07:44 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 286
Репутация: 11 ±
Замечаний: 20% ±

Excel 2010, Excel 2016
N-dmitriy, Спасибо Вам!! Очень похоже!
 
Ответить
СообщениеN-dmitriy, Спасибо Вам!! Очень похоже!

Автор - ПАМ
Дата добавления - 23.04.2024 в 07:44
ПАМ Дата: Вторник, 23.04.2024, 07:48 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 286
Репутация: 11 ±
Замечаний: 20% ±

Excel 2010, Excel 2016
gling, Спасибо Вам! Очень похоже!

[offtop]Просто я пока усвоил похоже только одну массивную формулу - транспортировка :) А формулы ИНДЕКС и ПОИСКПОЗ для меня почему-то очень сложные. Спасибо еще раз
 
Ответить
Сообщениеgling, Спасибо Вам! Очень похоже!

[offtop]Просто я пока усвоил похоже только одну массивную формулу - транспортировка :) А формулы ИНДЕКС и ПОИСКПОЗ для меня почему-то очень сложные. Спасибо еще раз

Автор - ПАМ
Дата добавления - 23.04.2024 в 07:48
DrMini Дата: Вторник, 23.04.2024, 08:55 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1678
Репутация: 226 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Здравствуйте ПАМ,
После первого прочтения ничего не понял из того, что Вам нужно.
Теперь стало понятно.
как вариант:
Код
=СУММПРОИЗВ((Исх!$B$6:$AF$6=B$6)*Исх!$B1:$AF1)
К сообщению приложен файл: 7570849.xlsx (49.6 Kb)
 
Ответить
СообщениеЗдравствуйте ПАМ,
После первого прочтения ничего не понял из того, что Вам нужно.
Теперь стало понятно.
как вариант:
Код
=СУММПРОИЗВ((Исх!$B$6:$AF$6=B$6)*Исх!$B1:$AF1)

Автор - DrMini
Дата добавления - 23.04.2024 в 08:55
ПАМ Дата: Вторник, 23.04.2024, 09:16 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 286
Репутация: 11 ±
Замечаний: 20% ±

Excel 2010, Excel 2016
DrMini, Вам тоже спасибо!
 
Ответить
СообщениеDrMini, Вам тоже спасибо!

Автор - ПАМ
Дата добавления - 23.04.2024 в 09:16
_Boroda_ Дата: Вторник, 23.04.2024, 10:02 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16675
Репутация: 6481 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
И до кучи
Код
=ПРОСМОТР(;-1/(B$6=Исх!$6:$6);Исх!1:1)

Код
=ИНДЕКС(Исх!1:1;ПОИСКПОЗ(B$6;Исх!$6:$6;))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеИ до кучи
Код
=ПРОСМОТР(;-1/(B$6=Исх!$6:$6);Исх!1:1)

Код
=ИНДЕКС(Исх!1:1;ПОИСКПОЗ(B$6;Исх!$6:$6;))

Автор - _Boroda_
Дата добавления - 23.04.2024 в 10:02
ПАМ Дата: Вторник, 23.04.2024, 15:21 | Сообщение № 9
Группа: Проверенные
Ранг: Обитатель
Сообщений: 286
Репутация: 11 ±
Замечаний: 20% ±

Excel 2010, Excel 2016
_Boroda_, Александр и Вам спасибо!
 
Ответить
Сообщение_Boroda_, Александр и Вам спасибо!

Автор - ПАМ
Дата добавления - 23.04.2024 в 15:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Нахождение определенного текста в огромном массиве (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!