Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Округление при использовании знака & - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Округление при использовании знака &
Бида Дата: Четверг, 16.05.2024, 12:47 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

2019
Здраствуйте. При объединении текста и значения по формуле с помощью знака & происходит округление числа. Мне нужно 2 знака после запятой, но если в результате получается ноль, то округление происходит неправильно. Мне нужно получить текст "1,06-1,10" в ячейке. Получаю "1,06-1,1". Уже использовала =ОКРУГЛ, меняла форматы ячейки. НИЧЕГО. Гугл мне ничего не дал, в Exel разбираюсь не так хорошо, как хотелось бы :(
 
Ответить
СообщениеЗдраствуйте. При объединении текста и значения по формуле с помощью знака & происходит округление числа. Мне нужно 2 знака после запятой, но если в результате получается ноль, то округление происходит неправильно. Мне нужно получить текст "1,06-1,10" в ячейке. Получаю "1,06-1,1". Уже использовала =ОКРУГЛ, меняла форматы ячейки. НИЧЕГО. Гугл мне ничего не дал, в Exel разбираюсь не так хорошо, как хотелось бы :(

Автор - Бида
Дата добавления - 16.05.2024 в 12:47
Nic70y Дата: Четверг, 16.05.2024, 12:49 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8832
Репутация: 2301 ±
Замечаний: 0% ±

Excel 2010
вместо
=ОКРУГЛ
попробуйте это
Код
=ТЕКСТ(A1;"0"&ПСТР(1/7;2;1)&"00")


ЮMoney 41001841029809
 
Ответить
Сообщениевместо
=ОКРУГЛ
попробуйте это
Код
=ТЕКСТ(A1;"0"&ПСТР(1/7;2;1)&"00")

Автор - Nic70y
Дата добавления - 16.05.2024 в 12:49
Бида Дата: Четверг, 16.05.2024, 13:05 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

2019
Nic70y, не знаю, как вы это сделали, НО СРАБОТАЛО!!! Пошла разбираться pray
 
Ответить
СообщениеNic70y, не знаю, как вы это сделали, НО СРАБОТАЛО!!! Пошла разбираться pray

Автор - Бида
Дата добавления - 16.05.2024 в 13:05
elovkov Дата: Четверг, 16.05.2024, 13:22 | Сообщение № 4
Группа: Друзья
Ранг: Обитатель
Сообщений: 386
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
ПСТР(1/7;2;1)

Опять за разъяснением, зачем так сложно? Вроде просто формат "0,00" тоже работает, уже ведь как текст воспринимает


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
Сообщение
ПСТР(1/7;2;1)

Опять за разъяснением, зачем так сложно? Вроде просто формат "0,00" тоже работает, уже ведь как текст воспринимает

Автор - elovkov
Дата добавления - 16.05.2024 в 13:22
Nic70y Дата: Четверг, 16.05.2024, 13:27 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 8832
Репутация: 2301 ±
Замечаний: 0% ±

Excel 2010
elovkov, чтоб не париться с версией эксель


ЮMoney 41001841029809
 
Ответить
Сообщениеelovkov, чтоб не париться с версией эксель

Автор - Nic70y
Дата добавления - 16.05.2024 в 13:27
Бида Дата: Четверг, 16.05.2024, 13:33 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

2019
elovkov, всё получилось! Попробовала и так и так. Но первый способ так и не поняла, но всё равно смогла применить
 
Ответить
Сообщениеelovkov, всё получилось! Попробовала и так и так. Но первый способ так и не поняла, но всё равно смогла применить

Автор - Бида
Дата добавления - 16.05.2024 в 13:33
elovkov Дата: Четверг, 16.05.2024, 13:45 | Сообщение № 7
Группа: Друзья
Ранг: Обитатель
Сообщений: 386
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
Но первый способ так и не поняла

ну по сути функция ПСТР вытаскивает из 1/7 (т.е. 0,1428...) запятую и получается тот же 0,00)))


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
Сообщение
Но первый способ так и не поняла

ну по сути функция ПСТР вытаскивает из 1/7 (т.е. 0,1428...) запятую и получается тот же 0,00)))

Автор - elovkov
Дата добавления - 16.05.2024 в 13:45
Nic70y Дата: Четверг, 16.05.2024, 13:50 | Сообщение № 8
Группа: Друзья
Ранг: Экселист
Сообщений: 8832
Репутация: 2301 ±
Замечаний: 0% ±

Excel 2010
Бида, если дробный разделитель у кого-то в эксель (en-версия) будет точка, формула с "0,00" выдаст ошибку, а с ПСТР
будет работать в любой


ЮMoney 41001841029809
 
Ответить
СообщениеБида, если дробный разделитель у кого-то в эксель (en-версия) будет точка, формула с "0,00" выдаст ошибку, а с ПСТР
будет работать в любой

Автор - Nic70y
Дата добавления - 16.05.2024 в 13:50
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!