Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Установка значения в ячейки с условием - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Установка значения в ячейки с условием
rridick2232 Дата: Суббота, 25.05.2024, 23:04 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

2021
Подскажите....
Мне нужно: если в столбце А есть слово "мама" с любым количеством лишних символов, то в столбец С скопировать значение из столбца В. Если слова мама нет в столбце А, то значение в столбце С должно быть 0. Но почему-то не работает логическое выражение "*мама*".... Что я делаю неправильно????
К сообщению приложен файл: primer1.xlsx (9.8 Kb)


ChesTor
 
Ответить
СообщениеПодскажите....
Мне нужно: если в столбце А есть слово "мама" с любым количеством лишних символов, то в столбец С скопировать значение из столбца В. Если слова мама нет в столбце А, то значение в столбце С должно быть 0. Но почему-то не работает логическое выражение "*мама*".... Что я делаю неправильно????

Автор - rridick2232
Дата добавления - 25.05.2024 в 23:04
Pelena Дата: Суббота, 25.05.2024, 23:37 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 19242
Репутация: 4433 ±
Замечаний: ±

Excel 365 & Mac Excel
Несколько вариантов
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК("мама";A2));B2;0)

Код
=ЕСЛИОШИБКА(ВПР("*мама*";A2:B2;2;0);0)

Код
=ЕСЛИ(СЧЁТЕСЛИ(A2;"*мама*");B2;0)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеНесколько вариантов
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК("мама";A2));B2;0)

Код
=ЕСЛИОШИБКА(ВПР("*мама*";A2:B2;2;0);0)

Код
=ЕСЛИ(СЧЁТЕСЛИ(A2;"*мама*");B2;0)

Автор - Pelena
Дата добавления - 25.05.2024 в 23:37
rridick2232 Дата: Суббота, 25.05.2024, 23:49 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

2021
=ЕСЛИ(СЧЁТЕСЛИ(A2;"*мама*");B2;0)


Спасибо друг... помог мне дураку. + тебе в карму.


ChesTor
 
Ответить
Сообщение
=ЕСЛИ(СЧЁТЕСЛИ(A2;"*мама*");B2;0)


Спасибо друг... помог мне дураку. + тебе в карму.

Автор - rridick2232
Дата добавления - 25.05.2024 в 23:49
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!