Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула переноса из строки в столбец - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Формула переноса из строки в столбец
l6041383 Дата: Воскресенье, 26.05.2024, 17:20 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

10
Здравствуйте! Помогите разобраться. Я обычный пользователь, искала ответ или формулу в и-нете, но нужного не смогла найти. Обращаюсь к асам за помощью. Файл прилагаю. Мне необходимо из листа 2 перенести значения в лист1. При чем значения в лист 2 расположены в строку, а переносятся в столбик (транспортирование не подходит, т.к. значения (цифры) в лист 1,не отражаются при изменении цифры в листе 2). Мне нужна привязка и упрощенный способ переноса формулы. А то приходится изменять вручную.
Формула подойдёт в стиле R1C1 или в обычном. Необходимо оставить столбец R3, заставить меняться строку С3 на С4 С5 в столбце.
Или наоборот, как заставить изменяться значение С3 на D3, E3, F3.

Если не обойтись без макросов, помогите с написанием (я совсем не понимаю что это)
К сообщению приложен файл: 5853892.xlsx (24.4 Kb)


Сообщение отредактировал l6041383 - Воскресенье, 26.05.2024, 17:28
 
Ответить
СообщениеЗдравствуйте! Помогите разобраться. Я обычный пользователь, искала ответ или формулу в и-нете, но нужного не смогла найти. Обращаюсь к асам за помощью. Файл прилагаю. Мне необходимо из листа 2 перенести значения в лист1. При чем значения в лист 2 расположены в строку, а переносятся в столбик (транспортирование не подходит, т.к. значения (цифры) в лист 1,не отражаются при изменении цифры в листе 2). Мне нужна привязка и упрощенный способ переноса формулы. А то приходится изменять вручную.
Формула подойдёт в стиле R1C1 или в обычном. Необходимо оставить столбец R3, заставить меняться строку С3 на С4 С5 в столбце.
Или наоборот, как заставить изменяться значение С3 на D3, E3, F3.

Если не обойтись без макросов, помогите с написанием (я совсем не понимаю что это)

Автор - l6041383
Дата добавления - 26.05.2024 в 17:20
Pelena Дата: Воскресенье, 26.05.2024, 18:49 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 19242
Репутация: 4433 ±
Замечаний: ±

Excel 365 & Mac Excel
Здравствуйте.
В файле два варианта.
Для Русского языка обычная формула ИНДЕКС+ПОИСКПОЗ
[vba]
Код
=ИНДЕКС('Русский язык'!$C$3:$G$6;ПОИСКПОЗ(ПРОСМОТР("яяя";$B$5:$B5);'Русский язык'!_4_1;0);ПОИСКПОЗ($F5;'Русский язык'!$C$2:$G$2;0))
[/vba]
Для литературы формула массива ТРАНСП. Вводится Ctrl+Shift+Enter сразу в диапазон D5:D9 и потом копируется на других зверей
[vba]
Код
=ТРАНСП(ИНДЕКС(Литература!$C$3:$G$6;ПОИСКПОЗ(B5;Литература!$B$3:$B$6;0);0))
[/vba]
Ну и для среднего значения есть функция СРЗНАЧ
К сообщению приложен файл: 7425300.xlsx (24.7 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЗдравствуйте.
В файле два варианта.
Для Русского языка обычная формула ИНДЕКС+ПОИСКПОЗ
[vba]
Код
=ИНДЕКС('Русский язык'!$C$3:$G$6;ПОИСКПОЗ(ПРОСМОТР("яяя";$B$5:$B5);'Русский язык'!_4_1;0);ПОИСКПОЗ($F5;'Русский язык'!$C$2:$G$2;0))
[/vba]
Для литературы формула массива ТРАНСП. Вводится Ctrl+Shift+Enter сразу в диапазон D5:D9 и потом копируется на других зверей
[vba]
Код
=ТРАНСП(ИНДЕКС(Литература!$C$3:$G$6;ПОИСКПОЗ(B5;Литература!$B$3:$B$6;0);0))
[/vba]
Ну и для среднего значения есть функция СРЗНАЧ

Автор - Pelena
Дата добавления - 26.05.2024 в 18:49
l6041383 Дата: Воскресенье, 26.05.2024, 20:13 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

10
Pelena, спасибо! Только ничего не поняла в этих формулах. Вы задавали дополнительно ИМЯ?

И вот эта часть формулы к чему привязана, для чего она служит?

Русский язык'!$C$2:$G$2_4_1;0)

Я попыталась подставить формулу "Русский язык" в свою таблицу, но что-то не получается. Что-то я недопонимаю.
С формулой по литературе тоже проблема. Копирую формулу, подставляю, а значения остаются 55555 (хотя в листе "Литература" на этой позиции должны быть 44444)

.
 
Ответить
СообщениеPelena, спасибо! Только ничего не поняла в этих формулах. Вы задавали дополнительно ИМЯ?

И вот эта часть формулы к чему привязана, для чего она служит?

Русский язык'!$C$2:$G$2_4_1;0)

Я попыталась подставить формулу "Русский язык" в свою таблицу, но что-то не получается. Что-то я недопонимаю.
С формулой по литературе тоже проблема. Копирую формулу, подставляю, а значения остаются 55555 (хотя в листе "Литература" на этой позиции должны быть 44444)

.

Автор - l6041383
Дата добавления - 26.05.2024 в 20:13
Pelena Дата: Воскресенье, 26.05.2024, 21:43 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 19242
Репутация: 4433 ±
Замечаний: ±

Excel 365 & Mac Excel
Тег формул исковеркал немного формулы.
Посмотрите в файле, там понятнее.
Нет, никаких дополнительных имён не создавала.
И забыла ещё написать, что слова 1 четверть, 2 четверть и т.д. должны быть одинаково написаны на листах

подставляю, а значения остаются 55555 (хотя в листе "Литература" на этой позиции должны быть 44444)

я не вижу, что вы подставляете. Имя листа поменяли на Литература?


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеТег формул исковеркал немного формулы.
Посмотрите в файле, там понятнее.
Нет, никаких дополнительных имён не создавала.
И забыла ещё написать, что слова 1 четверть, 2 четверть и т.д. должны быть одинаково написаны на листах

подставляю, а значения остаются 55555 (хотя в листе "Литература" на этой позиции должны быть 44444)

я не вижу, что вы подставляете. Имя листа поменяли на Литература?

Автор - Pelena
Дата добавления - 26.05.2024 в 21:43
l6041383 Дата: Воскресенье, 26.05.2024, 22:25 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

10
Pelena, :)
 
Ответить
СообщениеPelena, :)

Автор - l6041383
Дата добавления - 26.05.2024 в 22:25
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!