Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Преобразование восьмерок в смены - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Преобразование восьмерок в смены
romanermulin Дата: Среда, 12.06.2024, 10:50 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

16.66.1
Нужна помощь самых продвинутых, я уже как только не пробовал, все равно не выходит то, что нужно.
Есть таблица, где отмечены восьмерки и выходы в течение месяца по другим бригадам (от 1 до 5) но нужно преобразовать ее в таблицу, где будет написано вместо восьмерок и номеров бригад сами смены, д(день), в(вечер) или н(ночь).
Прошу помощи, т.к. мне самому это не вывезти просто, приложил таблицу с исходной формой и той, что в итоге должна получиться.
К сообщению приложен файл: 5480494.xlsx (14.7 Kb)


Роман
 
Ответить
СообщениеНужна помощь самых продвинутых, я уже как только не пробовал, все равно не выходит то, что нужно.
Есть таблица, где отмечены восьмерки и выходы в течение месяца по другим бригадам (от 1 до 5) но нужно преобразовать ее в таблицу, где будет написано вместо восьмерок и номеров бригад сами смены, д(день), в(вечер) или н(ночь).
Прошу помощи, т.к. мне самому это не вывезти просто, приложил таблицу с исходной формой и той, что в итоге должна получиться.

Автор - romanermulin
Дата добавления - 12.06.2024 в 10:50
i691198 Дата: Среда, 12.06.2024, 13:03 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 239
Репутация: 88 ±
Замечаний: 0% ±

Добрый день. Для вашего примера с одной сменой можно применить формулу
Код
=ЕСЛИ(F3=8;F$11;"")
вставить ее в ячейку F22 и протянуть на всю таблицу. А вот с выходами работников вне графика ничего не понятно - какую букву нужно ставить? Какой то закономерности в вашем примере я не увидел.
 
Ответить
СообщениеДобрый день. Для вашего примера с одной сменой можно применить формулу
Код
=ЕСЛИ(F3=8;F$11;"")
вставить ее в ячейку F22 и протянуть на всю таблицу. А вот с выходами работников вне графика ничего не понятно - какую букву нужно ставить? Какой то закономерности в вашем примере я не увидел.

Автор - i691198
Дата добавления - 12.06.2024 в 13:03
romanermulin Дата: Среда, 12.06.2024, 13:08 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

16.66.1
Выход работника вне графика обозначается номером бригады, в которую он переводится в конкретный день и нужно, чтобы формула проверила, в какую именно смену человек выйдет в этот день, если взять Петрова, он 11 числа выходит по бригаде №1, бригада №1 в этот день работает в вечер, значит на месте "1" нужно получить "в".


Роман
 
Ответить
СообщениеВыход работника вне графика обозначается номером бригады, в которую он переводится в конкретный день и нужно, чтобы формула проверила, в какую именно смену человек выйдет в этот день, если взять Петрова, он 11 числа выходит по бригаде №1, бригада №1 в этот день работает в вечер, значит на месте "1" нужно получить "в".

Автор - romanermulin
Дата добавления - 12.06.2024 в 13:08
прохожий2019 Дата: Среда, 12.06.2024, 13:16 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1269
Репутация: 322 ±
Замечаний: 0% ±

365 Beta Channel
Код
=ЕСЛИ(ЕПУСТО(F3);"";ЕСЛИ(F3=8;F$11;ВПР(F3;$E$9:F$13;СТОЛБЕЦ(B1);)))
К сообщению приложен файл: 5480494_1.xlsx (22.8 Kb)
 
Ответить
Сообщение
Код
=ЕСЛИ(ЕПУСТО(F3);"";ЕСЛИ(F3=8;F$11;ВПР(F3;$E$9:F$13;СТОЛБЕЦ(B1);)))

Автор - прохожий2019
Дата добавления - 12.06.2024 в 13:16
romanermulin Дата: Среда, 12.06.2024, 13:23 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

16.66.1
Огромнейшее спасибо!!!! Проблема решена, сууупер!!


Роман
 
Ответить
СообщениеОгромнейшее спасибо!!!! Проблема решена, сууупер!!

Автор - romanermulin
Дата добавления - 12.06.2024 в 13:23
romanermulin Дата: Среда, 12.06.2024, 14:07 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

16.66.1
А сложно ли будет дополнить формулу так, что если, вместо восьмерок или номеров бригад стоит отпуск "о", то в финальной таблице прописывалась "о"?


Роман
 
Ответить
СообщениеА сложно ли будет дополнить формулу так, что если, вместо восьмерок или номеров бригад стоит отпуск "о", то в финальной таблице прописывалась "о"?

Автор - romanermulin
Дата добавления - 12.06.2024 в 14:07
i691198 Дата: Среда, 12.06.2024, 15:13 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 239
Репутация: 88 ±
Замечаний: 0% ±

Добавить еще одну проверку, например так?
Код
=ЕСЛИ(ЕПУСТО(F3);"";ЕСЛИ(F3=8;F$11;ЕСЛИ(F3="о";"о";ВПР(F3;$E$9:F$13;СТОЛБЕЦ(B1);))))


Сообщение отредактировал i691198 - Среда, 12.06.2024, 15:15
 
Ответить
СообщениеДобавить еще одну проверку, например так?
Код
=ЕСЛИ(ЕПУСТО(F3);"";ЕСЛИ(F3=8;F$11;ЕСЛИ(F3="о";"о";ВПР(F3;$E$9:F$13;СТОЛБЕЦ(B1);))))

Автор - i691198
Дата добавления - 12.06.2024 в 15:13
romanermulin Дата: Среда, 12.06.2024, 16:44 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

16.66.1
Да, супер! Спасибо!!


Роман
 
Ответить
СообщениеДа, супер! Спасибо!!

Автор - romanermulin
Дата добавления - 12.06.2024 в 16:44
i691198 Дата: Среда, 12.06.2024, 17:14 | Сообщение № 9
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 239
Репутация: 88 ±
Замечаний: 0% ±

romanermulin, Как то в вашем примере всё неестественно идеально. В реальном производстве всегда есть обстоятельства, когда работник вышел в свою смену, но, по разным причинам отработал меньше 8 часов. Или самая типичная обратная ситуация - переработка, опять же по разным причинам количество рабочих часов может быть больше 8. Ваш пример такие моменты не учитывает.
 
Ответить
Сообщениеromanermulin, Как то в вашем примере всё неестественно идеально. В реальном производстве всегда есть обстоятельства, когда работник вышел в свою смену, но, по разным причинам отработал меньше 8 часов. Или самая типичная обратная ситуация - переработка, опять же по разным причинам количество рабочих часов может быть больше 8. Ваш пример такие моменты не учитывает.

Автор - i691198
Дата добавления - 12.06.2024 в 17:14
romanermulin Дата: Четверг, 13.06.2024, 12:31 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

16.66.1
i691198, Да, в реальности все иначе, но мне нужно было решение на простом примере, дальше я уже эту формулу развил в своем направлении и усложнил, максимально приблизив к реальности. Помимо отпусков есть еще масса других моментов, больничные, обучения, замещения ИТР, медосмотры, доноры, сдвоенные смены и многое другое и в конечном итоге формула увеличилась в несколько раз, но без простого примера мне никак не разобраться было.)


Роман
 
Ответить
Сообщениеi691198, Да, в реальности все иначе, но мне нужно было решение на простом примере, дальше я уже эту формулу развил в своем направлении и усложнил, максимально приблизив к реальности. Помимо отпусков есть еще масса других моментов, больничные, обучения, замещения ИТР, медосмотры, доноры, сдвоенные смены и многое другое и в конечном итоге формула увеличилась в несколько раз, но без простого примера мне никак не разобраться было.)

Автор - romanermulin
Дата добавления - 13.06.2024 в 12:31
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!