Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Определить, если в столбце, повторяющие значения - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Определить, если в столбце, повторяющие значения
Chelovekov Дата: Суббота, 15.06.2024, 09:27 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 313
Репутация: 0 ±
Замечаний: 80% ±

Excel 2016
Здравствуйте, Уважаемые Форумчане. Прошу, Вас помочь, решить проблему. Нужно определить, если в столбце повторяющие значения.
Заранее благодарен.
Пример прилагаю.
К сообщению приложен файл: 9504292.xlsx (10.8 Kb)
 
Ответить
СообщениеЗдравствуйте, Уважаемые Форумчане. Прошу, Вас помочь, решить проблему. Нужно определить, если в столбце повторяющие значения.
Заранее благодарен.
Пример прилагаю.

Автор - Chelovekov
Дата добавления - 15.06.2024 в 09:27
Chelovekov Дата: Суббота, 15.06.2024, 09:51 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 313
Репутация: 0 ±
Замечаний: 80% ±

Excel 2016
Дополнение: Пустые ячейки не считаются, как повторяющие значения.


Сообщение отредактировал Chelovekov - Суббота, 15.06.2024, 09:51
 
Ответить
СообщениеДополнение: Пустые ячейки не считаются, как повторяющие значения.

Автор - Chelovekov
Дата добавления - 15.06.2024 в 09:51
i691198 Дата: Суббота, 15.06.2024, 10:50 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 239
Репутация: 88 ±
Замечаний: 0% ±

Добрый день. Попробуйте такую формулу. (Массивная, вводится Ctrl+Shift+Enter)
Код
=ЕСЛИ(СЧЁТЗ(B2:B15)-СУММ(ЕСЛИ(ЕТЕКСТ(B2:B15)*СЧЁТЕСЛИ(B2:B15;B2:B15)=1;1;0))>0;"Есть";"Нет")

Или другой вариант, не массивный
Код
=ЕСЛИ(СУММПРОИЗВ(НЕ(ЕНД(B2:B15))*СЧЁТЕСЛИ(B2:B15;B2:B15))-СЧЁТЗ(B2:B15)>0;"Есть";"Нет")


Сообщение отредактировал i691198 - Суббота, 15.06.2024, 11:15
 
Ответить
СообщениеДобрый день. Попробуйте такую формулу. (Массивная, вводится Ctrl+Shift+Enter)
Код
=ЕСЛИ(СЧЁТЗ(B2:B15)-СУММ(ЕСЛИ(ЕТЕКСТ(B2:B15)*СЧЁТЕСЛИ(B2:B15;B2:B15)=1;1;0))>0;"Есть";"Нет")

Или другой вариант, не массивный
Код
=ЕСЛИ(СУММПРОИЗВ(НЕ(ЕНД(B2:B15))*СЧЁТЕСЛИ(B2:B15;B2:B15))-СЧЁТЗ(B2:B15)>0;"Есть";"Нет")

Автор - i691198
Дата добавления - 15.06.2024 в 10:50
Chelovekov Дата: Суббота, 15.06.2024, 11:43 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 313
Репутация: 0 ±
Замечаний: 80% ±

Excel 2016
Спасибо, работает hands
 
Ответить
СообщениеСпасибо, работает hands

Автор - Chelovekov
Дата добавления - 15.06.2024 в 11:43
DrMini Дата: Воскресенье, 16.06.2024, 09:48 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1754
Репутация: 243 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Chelovekov, здравствуйте.
Как вариант:
Код
=ЕСЛИ(СУММПРОИЗВ(--(СЧЁТЕСЛИ(B2:B10;B2:B10)>1))=0;"Нет";"Есть")
 
Ответить
СообщениеChelovekov, здравствуйте.
Как вариант:
Код
=ЕСЛИ(СУММПРОИЗВ(--(СЧЁТЕСЛИ(B2:B10;B2:B10)>1))=0;"Нет";"Есть")

Автор - DrMini
Дата добавления - 16.06.2024 в 09:48
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!