Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/изменение ссылки в ячейках при смене значения в ячейке - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
изменение ссылки в ячейках при смене значения в ячейке
nespica2012 Дата: Воскресенье, 23.06.2024, 22:04 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 56
Репутация: 0 ±
Замечаний: 20% ±

2017
доброго вечера уважаемые !

верю что на форуме уже решалась подобная задача, но не смог верно сформулировать задачу и с поиском я не справился(

как решить задачу представленной на картинке?
при смене значения в "G2" на 1,2,3,..., ссылки в ячейках с "G3"..."G14" менялись на ячейки соответствующих столбцов "B", "C", "D" и тд
К сообщению приложен файл: 5646066.jpg (22.6 Kb)


Сообщение отредактировал nespica2012 - Воскресенье, 23.06.2024, 22:10
 
Ответить
Сообщениедоброго вечера уважаемые !

верю что на форуме уже решалась подобная задача, но не смог верно сформулировать задачу и с поиском я не справился(

как решить задачу представленной на картинке?
при смене значения в "G2" на 1,2,3,..., ссылки в ячейках с "G3"..."G14" менялись на ячейки соответствующих столбцов "B", "C", "D" и тд

Автор - nespica2012
Дата добавления - 23.06.2024 в 22:04
bigor Дата: Понедельник, 24.06.2024, 00:07 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1157
Репутация: 221 ±
Замечаний: 0% ±

нет
nespica2012,
Код
=index(b3:e14;;g2)
массивная
 
Ответить
Сообщениеnespica2012,
Код
=index(b3:e14;;g2)
массивная

Автор - bigor
Дата добавления - 24.06.2024 в 00:07
nespica2012 Дата: Понедельник, 24.06.2024, 06:22 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 56
Репутация: 0 ±
Замечаний: 20% ±

2017
bigor,
почему-то не получается
К сообщению приложен файл: 4405581.png (6.5 Kb)
 
Ответить
Сообщениеbigor,
почему-то не получается

Автор - nespica2012
Дата добавления - 24.06.2024 в 06:22
DrMini Дата: Понедельник, 24.06.2024, 07:07 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1754
Репутация: 243 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
почему-то не получается

А сделайте так:
Код
=ИНДЕКС($B$3:$E$14;;G$2)

К сообщению приложен файл: 5647622.png (14.8 Kb)
 
Ответить
Сообщение
почему-то не получается

А сделайте так:
Код
=ИНДЕКС($B$3:$E$14;;G$2)


Автор - DrMini
Дата добавления - 24.06.2024 в 07:07
bigor Дата: Понедельник, 24.06.2024, 12:26 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1157
Репутация: 221 ±
Замечаний: 0% ±

нет
не получается
во первых нужно перевести имя функции на русский, во вторых выделяете диапазон g3:g14 вставляете формулу жмете ctrl+shift+enter

К сообщению приложен файл: 8962646.png (51.4 Kb)


Сообщение отредактировал bigor - Понедельник, 24.06.2024, 12:37
 
Ответить
Сообщение
не получается
во первых нужно перевести имя функции на русский, во вторых выделяете диапазон g3:g14 вставляете формулу жмете ctrl+shift+enter


Автор - bigor
Дата добавления - 24.06.2024 в 12:26
Hugo Дата: Понедельник, 24.06.2024, 12:29 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3370
Репутация: 722 ±
Замечаний: 0% ±

2019
Можно использовать смещ()


excel@nxt.ru
webmoney: E265281470651 Z422237915069
 
Ответить
СообщениеМожно использовать смещ()

Автор - Hugo
Дата добавления - 24.06.2024 в 12:29
nespica2012 Дата: Понедельник, 24.06.2024, 14:19 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 56
Репутация: 0 ±
Замечаний: 20% ±

2017
bigor,
Урааааа, заработало )))
 
Ответить
Сообщениеbigor,
Урааааа, заработало )))

Автор - nespica2012
Дата добавления - 24.06.2024 в 14:19
DrMini Дата: Вторник, 25.06.2024, 05:36 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 1754
Репутация: 243 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
После картинки bigor, понял, что должно было получиться.
Вариант через ГПР (не массивная):
Код
=ГПР($G$2;$B$2:$E$14;СТРОКА(A2);)
К сообщению приложен файл: stolbec.xlsx (9.9 Kb)
 
Ответить
СообщениеПосле картинки bigor, понял, что должно было получиться.
Вариант через ГПР (не массивная):
Код
=ГПР($G$2;$B$2:$E$14;СТРОКА(A2);)

Автор - DrMini
Дата добавления - 25.06.2024 в 05:36
Nic70y Дата: Вторник, 25.06.2024, 07:38 | Сообщение № 9
Группа: Друзья
Ранг: Экселист
Сообщений: 8857
Репутация: 2308 ±
Замечаний: 0% ±

Excel 2010
После картинки
в этом и проблема)
правила не зря написаны.
был бы сразу файл
Код
=ИНДЕКС(B3:E3;G$2)
не массивная само собой


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Вторник, 25.06.2024, 07:47
 
Ответить
Сообщение
После картинки
в этом и проблема)
правила не зря написаны.
был бы сразу файл
Код
=ИНДЕКС(B3:E3;G$2)
не массивная само собой

Автор - Nic70y
Дата добавления - 25.06.2024 в 07:38
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!