Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Создание цикла формулы ЕСЛИ с временными значениями - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Создание цикла формулы ЕСЛИ с временными значениями
Даша4315 Дата: Среда, 26.06.2024, 22:05 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

2019
Добрый день. Проблема заключается в написании формулы такого типа=ЕСЛИ(K3>8;8;ЕСЛИ(K3=8;8;ЕСЛИ(K3=7;7;ЕСЛИ(K3=6;6;ЕСЛИ(K3=5;5;ЕСЛИ(K3=4;4;ЕСЛИ(K3=3;3;ЕСЛИ(K3=2;2;ЕСЛИ(K3=1;1;ЕСЛИ(K3<=1;0;0)))))))))), только вместо обычных цифр нужно временное значение то есть 8:00,9:00 и т.д. Так как считаться должно время работы сотрудника (уход-приход)
Перепробовали все,никак не можем найти верный путь. Есть кто может подсказать верное решение? :'( :'(


Сообщение отредактировал Даша4315 - Среда, 26.06.2024, 22:05
 
Ответить
СообщениеДобрый день. Проблема заключается в написании формулы такого типа=ЕСЛИ(K3>8;8;ЕСЛИ(K3=8;8;ЕСЛИ(K3=7;7;ЕСЛИ(K3=6;6;ЕСЛИ(K3=5;5;ЕСЛИ(K3=4;4;ЕСЛИ(K3=3;3;ЕСЛИ(K3=2;2;ЕСЛИ(K3=1;1;ЕСЛИ(K3<=1;0;0)))))))))), только вместо обычных цифр нужно временное значение то есть 8:00,9:00 и т.д. Так как считаться должно время работы сотрудника (уход-приход)
Перепробовали все,никак не можем найти верный путь. Есть кто может подсказать верное решение? :'( :'(

Автор - Даша4315
Дата добавления - 26.06.2024 в 22:05
прохожий2019 Дата: Среда, 26.06.2024, 22:16 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1269
Репутация: 322 ±
Замечаний: 0% ±

365 Beta Channel
самое простое 8/24, 9/24 и т.д.

ещё можно ВРЕМЯ(8;0;0), ВРЕМЯ(9;0;0) и т.д.

но лучше озвучить саму задачу и приложить файл - ибо пока не ясно на кой такая формула вообще нужна
 
Ответить
Сообщениесамое простое 8/24, 9/24 и т.д.

ещё можно ВРЕМЯ(8;0;0), ВРЕМЯ(9;0;0) и т.д.

но лучше озвучить саму задачу и приложить файл - ибо пока не ясно на кой такая формула вообще нужна

Автор - прохожий2019
Дата добавления - 26.06.2024 в 22:16
Даша4315 Дата: Среда, 26.06.2024, 22:35 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

2019
прохожий2019, Пример во влодении отправили. Суть в чем, что заполняется крайняя правая колонка сколько часов отработал человек. Если он отработал 8:00:00 часов, то в С2-отображается 8:00:00, а в D2-0:00:00, если менее 8 часов то, в С2-отображается например 7,6 или 4 часа, а в D2-0, если человек отработал свыше 8 часов. например 9, то в С2-в любом случае будет 8, а вот в D2 уже он должен просчитать, что будет час переработки. Изначально делалось все на целых числах. Формулу написали, все получается. Но поняли, что человек же может отработать и неполный час.... И вот тут у нас было 3 дня ступора, никак не можем понять как правильно написать формулу. То выдает ошибку, то выдает неверные значения. Голова вскипела.
К сообщению приложен файл: list_microsoft_excel.xlsx (11.3 Kb)
 
Ответить
Сообщениепрохожий2019, Пример во влодении отправили. Суть в чем, что заполняется крайняя правая колонка сколько часов отработал человек. Если он отработал 8:00:00 часов, то в С2-отображается 8:00:00, а в D2-0:00:00, если менее 8 часов то, в С2-отображается например 7,6 или 4 часа, а в D2-0, если человек отработал свыше 8 часов. например 9, то в С2-в любом случае будет 8, а вот в D2 уже он должен просчитать, что будет час переработки. Изначально делалось все на целых числах. Формулу написали, все получается. Но поняли, что человек же может отработать и неполный час.... И вот тут у нас было 3 дня ступора, никак не можем понять как правильно написать формулу. То выдает ошибку, то выдает неверные значения. Голова вскипела.

Автор - Даша4315
Дата добавления - 26.06.2024 в 22:35
прохожий2019 Дата: Среда, 26.06.2024, 22:40 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1269
Репутация: 322 ±
Замечаний: 0% ±

365 Beta Channel
Код
=МИН(8;K2)

вот тут разбирал - МИН(МАКС(... или результат в заданных пределах
и не надо вам ни на какие часы переходить...
К сообщению приложен файл: list_microsoft_excel_2.xlsx (15.1 Kb)
 
Ответить
Сообщение
Код
=МИН(8;K2)

вот тут разбирал - МИН(МАКС(... или результат в заданных пределах
и не надо вам ни на какие часы переходить...

Автор - прохожий2019
Дата добавления - 26.06.2024 в 22:40
Даша4315 Дата: Среда, 26.06.2024, 22:47 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

2019
прохожий2019, Благодарю. Побежала смотреть видео hands
 
Ответить
Сообщениепрохожий2019, Благодарю. Побежала смотреть видео hands

Автор - Даша4315
Дата добавления - 26.06.2024 в 22:47
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!