Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Ночные часы - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Ночные часы
sanyman29 Дата: Понедельник, 01.07.2024, 11:35 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

2013
Здравствуйте помогите сделать формулу, для расчета ночных часов с 22-00 до 03-00, как образец прикрепляю форму с ночными в промежутке с 22-00 до 06-00
К сообщению приложен файл: nochnye.xls (25.5 Kb)


Александр

Сообщение отредактировал sanyman29 - Понедельник, 01.07.2024, 11:36
 
Ответить
СообщениеЗдравствуйте помогите сделать формулу, для расчета ночных часов с 22-00 до 03-00, как образец прикрепляю форму с ночными в промежутке с 22-00 до 06-00

Автор - sanyman29
Дата добавления - 01.07.2024 в 11:35
AlexM Дата: Понедельник, 01.07.2024, 12:13 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4517
Репутация: 1129 ±
Замечаний: 0% ±

Excel 2003
Код
=ЕСЛИ(ДЕНЬ(C2)=ДЕНЬ(D2);ЦЕЛОЕ(C2)+3/24-МИН(ЦЕЛОЕ(C2)+3/24;C2)+МАКС(D2;ЦЕЛОЕ(D2)+22/24)-(ЦЕЛОЕ(D2)+22/24);ЦЕЛОЕ(D2)-МАКС(C2;ЦЕЛОЕ(C2)+22/24)+МИН(D2;ЦЕЛОЕ(D2)+3/24)-ЦЕЛОЕ(D2))
К сообщению приложен файл: nochnye_1.xls (26.0 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Понедельник, 01.07.2024, 12:13
 
Ответить
Сообщение
Код
=ЕСЛИ(ДЕНЬ(C2)=ДЕНЬ(D2);ЦЕЛОЕ(C2)+3/24-МИН(ЦЕЛОЕ(C2)+3/24;C2)+МАКС(D2;ЦЕЛОЕ(D2)+22/24)-(ЦЕЛОЕ(D2)+22/24);ЦЕЛОЕ(D2)-МАКС(C2;ЦЕЛОЕ(C2)+22/24)+МИН(D2;ЦЕЛОЕ(D2)+3/24)-ЦЕЛОЕ(D2))

Автор - AlexM
Дата добавления - 01.07.2024 в 12:13
AlexM Дата: Понедельник, 01.07.2024, 12:33 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4517
Репутация: 1129 ±
Замечаний: 0% ±

Excel 2003
Проверьте такую формулу
Код
=МАКС(0;3/24-ОСТАТ(C2;1))+МИН(2/24;1-ОСТАТ(C2;1))+МИН(3/24;ОСТАТ(D2;1))+МАКС(0;ОСТАТ(D2;1)-22/24)+(ОТБР(D2)-ОТБР(C2)-1)*5/24

Формат ячеек [ч]:мм



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Понедельник, 01.07.2024, 12:34
 
Ответить
СообщениеПроверьте такую формулу
Код
=МАКС(0;3/24-ОСТАТ(C2;1))+МИН(2/24;1-ОСТАТ(C2;1))+МИН(3/24;ОСТАТ(D2;1))+МАКС(0;ОСТАТ(D2;1)-22/24)+(ОТБР(D2)-ОТБР(C2)-1)*5/24

Формат ячеек [ч]:мм

Автор - AlexM
Дата добавления - 01.07.2024 в 12:33
jakim Дата: Понедельник, 01.07.2024, 18:13 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1208
Репутация: 314 ±
Замечаний: 0% ±

Excel 2010
Формула

Код
=IF(INT(D2)>INT(C2);IF(22/24>=MOD(C2;1);1-22/24;1-MOD(C2;1))+IF(6/24>=MOD(D2;1);MOD(D2;1);6/24);6/24-MOD(C2;1))
К сообщению приложен файл: nochnye.xlsx (12.5 Kb)
 
Ответить
Сообщение
Формула

Код
=IF(INT(D2)>INT(C2);IF(22/24>=MOD(C2;1);1-22/24;1-MOD(C2;1))+IF(6/24>=MOD(D2;1);MOD(D2;1);6/24);6/24-MOD(C2;1))

Автор - jakim
Дата добавления - 01.07.2024 в 18:13
sanyman29 Дата: Четверг, 04.07.2024, 08:57 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

2013
jakim, Спасибо большое, теперь не могу сложить часы получается неверная цифра


Александр
 
Ответить
Сообщениеjakim, Спасибо большое, теперь не могу сложить часы получается неверная цифра

Автор - sanyman29
Дата добавления - 04.07.2024 в 08:57
jakim Дата: Четверг, 04.07.2024, 10:50 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1208
Репутация: 314 ±
Замечаний: 0% ±

Excel 2010
Смотрите приложение.
К сообщению приложен файл: 0576276.xlsx (12.8 Kb)
 
Ответить
СообщениеСмотрите приложение.

Автор - jakim
Дата добавления - 04.07.2024 в 10:50
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!