Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Возвращение значения в зависимости от велечены числа - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Возвращение значения в зависимости от велечены числа
Экслевод Дата: Понедельник, 01.07.2024, 22:34 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Добрый вечер. Как реализовать данную задачу?
Есть строки с цифрами 50 ячеек, в ячейках цифры двухзначные от 15 до 80. Далее хотелось пять столбцов, и если находятся в строке цифры от 35 до 44,9 показывалось бы 3, от 45 до 54,9 - "2" и так далее. Если нет, то Ложь или пустая ячейка.
(3) — 35 до 44,9
(2) — 45 до 54,9
(1) — 55 до 64,9
(0) — 65 до 74,9
(8) — более 75
К сообщению приложен файл: 1286458.xlsx (11.3 Kb)


Сообщение отредактировал Экслевод - Понедельник, 01.07.2024, 22:36
 
Ответить
СообщениеДобрый вечер. Как реализовать данную задачу?
Есть строки с цифрами 50 ячеек, в ячейках цифры двухзначные от 15 до 80. Далее хотелось пять столбцов, и если находятся в строке цифры от 35 до 44,9 показывалось бы 3, от 45 до 54,9 - "2" и так далее. Если нет, то Ложь или пустая ячейка.
(3) — 35 до 44,9
(2) — 45 до 54,9
(1) — 55 до 64,9
(0) — 65 до 74,9
(8) — более 75

Автор - Экслевод
Дата добавления - 01.07.2024 в 22:34
gling Дата: Понедельник, 01.07.2024, 23:44 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2531
Репутация: 680 ±
Замечаний: 0% ±

2010
Здравствуйте.
Вариант в файле
Код
=ЕСЛИ(СЧЁТЕСЛИМН($B3:$AY3;">="&AZ$1;$B3:$AY3;"<"&BA$1);"Кол. Чисел: "&СЧЁТЕСЛИМН($B3:$AY3;">="&AZ$1;$B3:$AY3;"<"&BA$1)&"/Число из второй строки: "&AZ$2;"")
Лишнее из формулы можно удалить.
К сообщению приложен файл: 4220295.xlsx (12.4 Kb)


ЯД-41001506838083
 
Ответить
СообщениеЗдравствуйте.
Вариант в файле
Код
=ЕСЛИ(СЧЁТЕСЛИМН($B3:$AY3;">="&AZ$1;$B3:$AY3;"<"&BA$1);"Кол. Чисел: "&СЧЁТЕСЛИМН($B3:$AY3;">="&AZ$1;$B3:$AY3;"<"&BA$1)&"/Число из второй строки: "&AZ$2;"")
Лишнее из формулы можно удалить.

Автор - gling
Дата добавления - 01.07.2024 в 23:44
DrMini Дата: Вторник, 02.07.2024, 05:40 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1754
Репутация: 243 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Здравствуйте Экслевод.
Как вариант:
Код
=СУММПРОИЗВ(($B2:$AY2>=35)*($B2:$AY2<45))

или так:
Код
=СУММПРОИЗВ(($B3:$AY3>=AZ$1)*($B3:$AY3<BA$1))
К сообщению приложен файл: 3740459.xlsx (17.7 Kb)
 
Ответить
СообщениеЗдравствуйте Экслевод.
Как вариант:
Код
=СУММПРОИЗВ(($B2:$AY2>=35)*($B2:$AY2<45))

или так:
Код
=СУММПРОИЗВ(($B3:$AY3>=AZ$1)*($B3:$AY3<BA$1))

Автор - DrMini
Дата добавления - 02.07.2024 в 05:40
Экслевод Дата: Пятница, 05.07.2024, 14:04 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Благодарю все формулы рабочие, себе применил =СУММПРОИЗВ 1 вар
 
Ответить
СообщениеБлагодарю все формулы рабочие, себе применил =СУММПРОИЗВ 1 вар

Автор - Экслевод
Дата добавления - 05.07.2024 в 14:04
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!