Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подтянуть ячейки с частичным совпадением текста - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Подтянуть ячейки с частичным совпадением текста
lilianantw Дата: Вторник, 02.07.2024, 17:44 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Есть ячейка с полным название товара и есть ячейка со сокращенным названием, где совпадает часть текста. Нужно подтянуть формулой короткое название. Например: Деревянный пазл (рамка-вкладка) "Половинки. Овощи" (полное название), а ему надо подставить Пазл "Половинки. Овощи" (короткое название).

Пример во вложении
К сообщению приложен файл: tovar.xlsx (11.2 Kb)


Сообщение отредактировал lilianantw - Вторник, 02.07.2024, 17:45
 
Ответить
СообщениеЕсть ячейка с полным название товара и есть ячейка со сокращенным названием, где совпадает часть текста. Нужно подтянуть формулой короткое название. Например: Деревянный пазл (рамка-вкладка) "Половинки. Овощи" (полное название), а ему надо подставить Пазл "Половинки. Овощи" (короткое название).

Пример во вложении

Автор - lilianantw
Дата добавления - 02.07.2024 в 17:44
Hugo Дата: Вторник, 02.07.2024, 18:55 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3370
Репутация: 722 ±
Замечаний: 0% ±

2019
Частично работу делает
Код
=ВПР("*"&ИНДЕКС(ТЕКСТРАЗД(A2;"""");1;2)&"*";C:C;1;0)

Но наверное тут лучше PQ применить, там есть нечёткое сравнение. Но я не помогу.


excel@nxt.ru
webmoney: E265281470651 Z422237915069
 
Ответить
СообщениеЧастично работу делает
Код
=ВПР("*"&ИНДЕКС(ТЕКСТРАЗД(A2;"""");1;2)&"*";C:C;1;0)

Но наверное тут лучше PQ применить, там есть нечёткое сравнение. Но я не помогу.

Автор - Hugo
Дата добавления - 02.07.2024 в 18:55
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!