Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Нахождение наибольшего числа по условию - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Нахождение наибольшего числа по условию
Fr0st8210 Дата: Среда, 03.07.2024, 00:28 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

2021
Здравствуйте, нужна помощь. Условие: в колонке High найти число которое будет больше предыдущих 8 чисел и 8 последующих чисел меньше, и в колонке G напротив найденного числа в строке указать букву А, если условие не выполняется, то ничего не указывать. Так же чтобы данная формула работала со всеми числами указанными в колонке High, предполагается что таких чисел будет множество исходя из данных в таблице.
К сообщению приложен файл: 2235390.xlsx (398.1 Kb)
 
Ответить
СообщениеЗдравствуйте, нужна помощь. Условие: в колонке High найти число которое будет больше предыдущих 8 чисел и 8 последующих чисел меньше, и в колонке G напротив найденного числа в строке указать букву А, если условие не выполняется, то ничего не указывать. Так же чтобы данная формула работала со всеми числами указанными в колонке High, предполагается что таких чисел будет множество исходя из данных в таблице.

Автор - Fr0st8210
Дата добавления - 03.07.2024 в 00:28
DrMini Дата: Среда, 03.07.2024, 05:24 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1754
Репутация: 243 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Здравствуйте Fr0st8210.
Если правильно понял:
Код
=ЕСЛИ(2-И(МИН(C11:C18)>C10;МАКС(C2:C9)<C10)=1;"А";"")
К сообщению приложен файл: 5920510.xlsx (471.5 Kb)
 
Ответить
СообщениеЗдравствуйте Fr0st8210.
Если правильно понял:
Код
=ЕСЛИ(2-И(МИН(C11:C18)>C10;МАКС(C2:C9)<C10)=1;"А";"")

Автор - DrMini
Дата добавления - 03.07.2024 в 05:24
Светлый Дата: Среда, 03.07.2024, 11:04 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1837
Репутация: 516 ±
Замечаний: 0% ±

Excel 2013, 2016
Формула массива:
Код
=ЕСЛИ(И(C10>C2:C9;C10<C11:C18);"А";"")


Программировать проще, чем писать стихи.
 
Ответить
СообщениеФормула массива:
Код
=ЕСЛИ(И(C10>C2:C9;C10<C11:C18);"А";"")

Автор - Светлый
Дата добавления - 03.07.2024 в 11:04
bigor Дата: Среда, 03.07.2024, 11:37 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1157
Репутация: 221 ±
Замечаний: 0% ±

нет
Светлый, где то давно вычитал, что в формулах массива И и ИЛИ не работают, нужно заменять на * и + . Вашу формулу сейчас нет возможности проверить, неужели И работат в массивной формуле?
 
Ответить
СообщениеСветлый, где то давно вычитал, что в формулах массива И и ИЛИ не работают, нужно заменять на * и + . Вашу формулу сейчас нет возможности проверить, неужели И работат в массивной формуле?

Автор - bigor
Дата добавления - 03.07.2024 в 11:37
Светлый Дата: Среда, 03.07.2024, 12:05 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1837
Репутация: 516 ±
Замечаний: 0% ±

Excel 2013, 2016
неужели И работат в массивной формуле?

И() работает в любых формулах и всегда даёт ОДНО значение. В данном случае нам нужно одно значение, а не МАССИВ значений. Для получения массива значений И() не годится.
*Если формулу модернизировать, то можно начать уже со второй строки в массиве:
Код
=ЕСЛИ(И(C3>СМЕЩ(C2;;;-МИН(8;СТРОКА()-2));C3<C4:C11);"А";"")


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Среда, 03.07.2024, 12:42
 
Ответить
Сообщение
неужели И работат в массивной формуле?

И() работает в любых формулах и всегда даёт ОДНО значение. В данном случае нам нужно одно значение, а не МАССИВ значений. Для получения массива значений И() не годится.
*Если формулу модернизировать, то можно начать уже со второй строки в массиве:
Код
=ЕСЛИ(И(C3>СМЕЩ(C2;;;-МИН(8;СТРОКА()-2));C3<C4:C11);"А";"")

Автор - Светлый
Дата добавления - 03.07.2024 в 12:05
Fr0st8210 Дата: Среда, 03.07.2024, 14:13 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

2021
Светлый, и bigor, спасибо за помощь, но ваши формулы считают не совсем так как мне нужно. Прикрепил пример файла, в нем вытащил кусок данных из таблицы. Еще раз по условию: В колонке Н я указал число из колонки High в этой ячейке нужно будет чтобы в конце расчета отобразилось данное число. Отображение данного числа в этой ячейке соответствует следующим условиям, по обеим сторонам этого числа, что до него что после него в колонке High указаны значения меньше(изначально ошибся в описание условия) этого числа, до этого числа формула должна учитывать 4 строчки, а после этого числа формула должна учитывать только 2 строчки. Если к примеру до этого числа в этих 4 строчках есть значение больше чем искомое и соотвественно если будет значение больше искомого в строчках ниже него, то формула не должна ничего выводить в колонке H. Данные значения нужна возможность менять в виде параметров для определения этого количества.
К сообщению приложен файл: 0587151.xlsx (11.7 Kb)
 
Ответить
СообщениеСветлый, и bigor, спасибо за помощь, но ваши формулы считают не совсем так как мне нужно. Прикрепил пример файла, в нем вытащил кусок данных из таблицы. Еще раз по условию: В колонке Н я указал число из колонки High в этой ячейке нужно будет чтобы в конце расчета отобразилось данное число. Отображение данного числа в этой ячейке соответствует следующим условиям, по обеим сторонам этого числа, что до него что после него в колонке High указаны значения меньше(изначально ошибся в описание условия) этого числа, до этого числа формула должна учитывать 4 строчки, а после этого числа формула должна учитывать только 2 строчки. Если к примеру до этого числа в этих 4 строчках есть значение больше чем искомое и соотвественно если будет значение больше искомого в строчках ниже него, то формула не должна ничего выводить в колонке H. Данные значения нужна возможность менять в виде параметров для определения этого количества.

Автор - Fr0st8210
Дата добавления - 03.07.2024 в 14:13
bigor Дата: Среда, 03.07.2024, 17:56 | Сообщение № 7
Группа: Проверенные
Ранг: Старожил
Сообщений: 1157
Репутация: 221 ±
Замечаний: 0% ±

нет
Я еще не успел вам помочь :) Формула на основе DrMini,
Код
=IF(AND(MAX(INDEX($D$2:$D$8;MATCH(D6;$D$2:$D$8)-$I$1):INDEX($D$2:$D$8;MATCH(D6;$D$2:$D$8)-1))<D6;MAX(INDEX($D$2:$D$8;MATCH(D6;$D$2:$D$8)+1):INDEX($D$2:$D$8;MATCH(D6;$D$2:$D$8)+$I$2))<D6);D6;"")
в I1 сколько смотрим вверх, в I2 сколько смотрим вниз
 
Ответить
СообщениеЯ еще не успел вам помочь :) Формула на основе DrMini,
Код
=IF(AND(MAX(INDEX($D$2:$D$8;MATCH(D6;$D$2:$D$8)-$I$1):INDEX($D$2:$D$8;MATCH(D6;$D$2:$D$8)-1))<D6;MAX(INDEX($D$2:$D$8;MATCH(D6;$D$2:$D$8)+1):INDEX($D$2:$D$8;MATCH(D6;$D$2:$D$8)+$I$2))<D6);D6;"")
в I1 сколько смотрим вверх, в I2 сколько смотрим вниз

Автор - bigor
Дата добавления - 03.07.2024 в 17:56
Fr0st8210 Дата: Пятница, 05.07.2024, 16:04 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

2021
bigor, спасибо за формулу, но когда я ее вставляю пишет ошибку неверная формула.
К сообщению приложен файл: 3639599.xlsx (11.7 Kb)
 
Ответить
Сообщениеbigor, спасибо за формулу, но когда я ее вставляю пишет ошибку неверная формула.

Автор - Fr0st8210
Дата добавления - 05.07.2024 в 16:04
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!