Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос данных за определённую дату с одного в другой - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Перенос данных за определённую дату с одного в другой
caind2015 Дата: Воскресенье, 07.07.2024, 09:34 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 100
Репутация: 0 ±
Замечаний: 0% ±

2016
Здравстуйте. Подскажите можно ли организовать,чтобы данные переносились в другой журнал за сутки .Все что есть в любом виде.По сути и перенос то нужен чтобы вести подсчёт проб за определённую дату за сутки столбца B (отдельно) и общий подсчёт кол-ва данных столбцов C,D,E,F,G .
В Жидкой видно в фомулах выделено зелёным.Данные для подсчёта находятся в журнале сводный . Сутки начинаются с ночи. Данные продолжаются.Это просто кусок за эти сутки.
Данные из сводного в жидкую.
К сообщению приложен файл: cvodnyj_zhurnal1_2024.xlsx (25.5 Kb) · zhidkaja.xlsx (106.8 Kb)


пыпы
 
Ответить
СообщениеЗдравстуйте. Подскажите можно ли организовать,чтобы данные переносились в другой журнал за сутки .Все что есть в любом виде.По сути и перенос то нужен чтобы вести подсчёт проб за определённую дату за сутки столбца B (отдельно) и общий подсчёт кол-ва данных столбцов C,D,E,F,G .
В Жидкой видно в фомулах выделено зелёным.Данные для подсчёта находятся в журнале сводный . Сутки начинаются с ночи. Данные продолжаются.Это просто кусок за эти сутки.
Данные из сводного в жидкую.

Автор - caind2015
Дата добавления - 07.07.2024 в 09:34
caind2015 Дата: Воскресенье, 07.07.2024, 09:40 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 100
Репутация: 0 ±
Замечаний: 0% ±

2016
Если просто то нужен подсчёт количества за сутки в столбце В и столбцах C,D,E,F,G. Извиняюсь уже было написано).


пыпы

Сообщение отредактировал caind2015 - Воскресенье, 07.07.2024, 09:41
 
Ответить
СообщениеЕсли просто то нужен подсчёт количества за сутки в столбце В и столбцах C,D,E,F,G. Извиняюсь уже было написано).

Автор - caind2015
Дата добавления - 07.07.2024 в 09:40
Hugo Дата: Воскресенье, 07.07.2024, 09:46 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3370
Репутация: 722 ±
Замечаний: 0% ±

2019
Нужно бы обновиться чтоб появился ФИЛЬТР()
Ну или макросом делать. И так ведь уде UDF в хозяйстве используете.
Или просто считать СЧЁТЕСЛИ() сразу окончательный результат.
Обе формулы на скрине


excel@nxt.ru
webmoney: E265281470651 Z422237915069


Сообщение отредактировал Hugo - Воскресенье, 07.07.2024, 09:54
 
Ответить
СообщениеНужно бы обновиться чтоб появился ФИЛЬТР()
Ну или макросом делать. И так ведь уде UDF в хозяйстве используете.
Или просто считать СЧЁТЕСЛИ() сразу окончательный результат.
Обе формулы на скрине

Автор - Hugo
Дата добавления - 07.07.2024 в 09:46
caind2015 Дата: Воскресенье, 07.07.2024, 10:10 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 100
Репутация: 0 ±
Замечаний: 0% ±

2016
Hugo, Спасибо за помощь в прошлый раз. Нижайший поклон. Не вижу формулы на скрине СЧЁТЕСЛИ().
По поводу UDF да в хозяйстве то есть..и то благодаря Вам..Но с UDF журнал открывается очень долго. Ду маю вот счёт если был бы в самый раз.но нужно же в зависимости от даты в I1 подсчитать кол-во из сводного. А в сводном суток много, если просто ,то будет считать весь столбец.


пыпы

Сообщение отредактировал caind2015 - Воскресенье, 07.07.2024, 10:12
 
Ответить
СообщениеHugo, Спасибо за помощь в прошлый раз. Нижайший поклон. Не вижу формулы на скрине СЧЁТЕСЛИ().
По поводу UDF да в хозяйстве то есть..и то благодаря Вам..Но с UDF журнал открывается очень долго. Ду маю вот счёт если был бы в самый раз.но нужно же в зависимости от даты в I1 подсчитать кол-во из сводного. А в сводном суток много, если просто ,то будет считать весь столбец.

Автор - caind2015
Дата добавления - 07.07.2024 в 10:10
caind2015 Дата: Воскресенье, 07.07.2024, 10:20 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 100
Репутация: 0 ±
Замечаний: 0% ±

2016
Если с UDF, то как её написать в VB.
Можете мне просто скинуть жидкую уже готовую,я буду пользоваться вашей версией,просто путь поменяю на оригинал сводного журнала.


пыпы

Сообщение отредактировал caind2015 - Воскресенье, 07.07.2024, 10:23
 
Ответить
СообщениеЕсли с UDF, то как её написать в VB.
Можете мне просто скинуть жидкую уже готовую,я буду пользоваться вашей версией,просто путь поменяю на оригинал сводного журнала.

Автор - caind2015
Дата добавления - 07.07.2024 в 10:20
Hugo Дата: Воскресенье, 07.07.2024, 10:31 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3370
Репутация: 722 ±
Замечаний: 0% ±

2019
СЧЁТЕСЛИ() самим названием подсказывает - она считает если что-то где-то... Хотя тут удобнее суммеслимн() или просто сумм() массивно.
Скажите ясно - нужно количество, или и сами значения?
Для второго я показал как с ФИЛЬТР(), или если его нет - можно написать такую UDF


excel@nxt.ru
webmoney: E265281470651 Z422237915069


Сообщение отредактировал Hugo - Воскресенье, 07.07.2024, 10:34
 
Ответить
СообщениеСЧЁТЕСЛИ() самим названием подсказывает - она считает если что-то где-то... Хотя тут удобнее суммеслимн() или просто сумм() массивно.
Скажите ясно - нужно количество, или и сами значения?
Для второго я показал как с ФИЛЬТР(), или если его нет - можно написать такую UDF

Автор - Hugo
Дата добавления - 07.07.2024 в 10:31
caind2015 Дата: Воскресенье, 07.07.2024, 10:37 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 100
Репутация: 0 ±
Замечаний: 0% ±

2016
нужно просто количество столбца B и сумма количества из столбцов C,D,E,F,G. например за какую то дату указанную в I1. Но в жидкую то тогда их надо вставлять,копированием все суточные данные за это число,чтобы вести подсчёт


пыпы

Сообщение отредактировал caind2015 - Воскресенье, 07.07.2024, 10:43
 
Ответить
Сообщениенужно просто количество столбца B и сумма количества из столбцов C,D,E,F,G. например за какую то дату указанную в I1. Но в жидкую то тогда их надо вставлять,копированием все суточные данные за это число,чтобы вести подсчёт

Автор - caind2015
Дата добавления - 07.07.2024 в 10:37
Hugo Дата: Воскресенье, 07.07.2024, 10:56 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3370
Репутация: 722 ±
Замечаний: 0% ±

2019
Так всякого мусора ФИЛЬТР() понатянул, не годится.
Проверил глазом - правильно по B и C-G считают массивные
Код
=СУММ(ЕСЛИОШИБКА((ЕЧИСЛО([cvodnyj_zhurnal1_2024.xlsx]Jul!$B$3:$B$323))*([cvodnyj_zhurnal1_2024.xlsx]Jul!$K$3:$K$323=I1);0))

Код

=СУММ(ЕСЛИОШИБКА((ЕЧИСЛО([cvodnyj_zhurnal1_2024.xlsx]Jul!$C$3:$G$323))*([cvodnyj_zhurnal1_2024.xlsx]Jul!$K$3:$K$323=I1);0))

Результаты: 162 294
Второй проверил - ОК, но там учитывается и дата в F160:
Day 07.07.2024

Пофиксил - результат 293:
Код

=СУММ(ЕСЛИОШИБКА((ЕЧИСЛО([cvodnyj_zhurnal1_2024.xlsx]Jul!$C$3:$G$323))*([cvodnyj_zhurnal1_2024.xlsx]Jul!$K$3:$K$323=I1)*([cvodnyj_zhurnal1_2024.xlsx]Jul!$A$3:$A$323<>"Day");0))


excel@nxt.ru
webmoney: E265281470651 Z422237915069


Сообщение отредактировал Hugo - Воскресенье, 07.07.2024, 11:09
 
Ответить
СообщениеТак всякого мусора ФИЛЬТР() понатянул, не годится.
Проверил глазом - правильно по B и C-G считают массивные
Код
=СУММ(ЕСЛИОШИБКА((ЕЧИСЛО([cvodnyj_zhurnal1_2024.xlsx]Jul!$B$3:$B$323))*([cvodnyj_zhurnal1_2024.xlsx]Jul!$K$3:$K$323=I1);0))

Код

=СУММ(ЕСЛИОШИБКА((ЕЧИСЛО([cvodnyj_zhurnal1_2024.xlsx]Jul!$C$3:$G$323))*([cvodnyj_zhurnal1_2024.xlsx]Jul!$K$3:$K$323=I1);0))

Результаты: 162 294
Второй проверил - ОК, но там учитывается и дата в F160:
Day 07.07.2024

Пофиксил - результат 293:
Код

=СУММ(ЕСЛИОШИБКА((ЕЧИСЛО([cvodnyj_zhurnal1_2024.xlsx]Jul!$C$3:$G$323))*([cvodnyj_zhurnal1_2024.xlsx]Jul!$K$3:$K$323=I1)*([cvodnyj_zhurnal1_2024.xlsx]Jul!$A$3:$A$323<>"Day");0))

Автор - Hugo
Дата добавления - 07.07.2024 в 10:56
caind2015 Дата: Воскресенье, 07.07.2024, 11:25 | Сообщение № 9
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 100
Репутация: 0 ±
Замечаний: 0% ±

2016
Спасибо Hugo, огромное. Всё работает.Вопрос решён и закрыт.


пыпы
 
Ответить
СообщениеСпасибо Hugo, огромное. Всё работает.Вопрос решён и закрыт.

Автор - caind2015
Дата добавления - 07.07.2024 в 11:25
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!