Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/копировать с переносом строки - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
копировать с переносом строки
alina00000001 Дата: Понедельник, 08.07.2024, 10:50 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Есть две таблицы на двух листах. Нужно из первой таблицы перенести данные во вторую, но нужно сделать из 5 столбцов сделать всего 2. В примере данных не много. Всего оборудования больше сотни, вручную переносить будет долго. Пожалуйста, помогите с формулой
К сообщению приложен файл: 0903156.xlsx (13.4 Kb)
 
Ответить
СообщениеЕсть две таблицы на двух листах. Нужно из первой таблицы перенести данные во вторую, но нужно сделать из 5 столбцов сделать всего 2. В примере данных не много. Всего оборудования больше сотни, вручную переносить будет долго. Пожалуйста, помогите с формулой

Автор - alina00000001
Дата добавления - 08.07.2024 в 10:50
Nic70y Дата: Понедельник, 08.07.2024, 11:03 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8857
Репутация: 2308 ±
Замечаний: 0% ±

Excel 2010
Код
=ИНДЕКС(Лист1!B:F;ОКРУГЛВВЕРХ(СТРОКА(A1)/5;)+2;ИНДЕКС({5:2:3:4:1};ОСТАТ(СТРОКА(A1)-1;5)+1))
К сообщению приложен файл: 315.xlsx (13.2 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=ИНДЕКС(Лист1!B:F;ОКРУГЛВВЕРХ(СТРОКА(A1)/5;)+2;ИНДЕКС({5:2:3:4:1};ОСТАТ(СТРОКА(A1)-1;5)+1))

Автор - Nic70y
Дата добавления - 08.07.2024 в 11:03
bigor Дата: Понедельник, 08.07.2024, 11:11 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1157
Репутация: 221 ±
Замечаний: 0% ±

нет
alina00000001, если переставить местами в исходном файле номер кабинета и инвентарный номер, то можно так
Код
=INDEX(Лист1!$B$3:$F$11;INT((ROW(A1)-1)/5)+1;MOD((ROW(A1)-1);5)+1;1)
 
Ответить
Сообщениеalina00000001, если переставить местами в исходном файле номер кабинета и инвентарный номер, то можно так
Код
=INDEX(Лист1!$B$3:$F$11;INT((ROW(A1)-1)/5)+1;MOD((ROW(A1)-1);5)+1;1)

Автор - bigor
Дата добавления - 08.07.2024 в 11:11
alina00000001 Дата: Понедельник, 08.07.2024, 11:59 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, Большое спасибо)))
 
Ответить
СообщениеNic70y, Большое спасибо)))

Автор - alina00000001
Дата добавления - 08.07.2024 в 11:59
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!