Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как убрать #ссылка! - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как убрать #ссылка!
Как убрать #ссылка!
ArkaIIIa Дата: Среда, 10.07.2013, 17:48 | Сообщение № 1
Группа: Проверенные
Ранг: Ветеран
Сообщений: 890
Репутация: 115 ±
Замечаний: 0% ±

2010
Господа, подскажите, пожалуйста, как убивается #ССЫЛКА!

Формула примерно следующая:

Код
=ЕСЛИ(И(A1<>20;A1<>25;A1<>30);B1;A1


Т.е. если А1 не равно 20, 25 или 30, то возвращается то число, которое написано в В1, а если все таки равно, то число из А1.
Проблема в том, что в столбце А иногда возвращается #ССЫЛКА! и тогда формула ЕСЛИ тоже перестает работать.
Нужно сделать так, чтобы в случае, если А1=#ССЫЛКА!, возвращалось B1


Сообщение отредактировал ArkaIIIa - Среда, 10.07.2013, 17:55
 
Ответить
СообщениеГоспода, подскажите, пожалуйста, как убивается #ССЫЛКА!

Формула примерно следующая:

Код
=ЕСЛИ(И(A1<>20;A1<>25;A1<>30);B1;A1


Т.е. если А1 не равно 20, 25 или 30, то возвращается то число, которое написано в В1, а если все таки равно, то число из А1.
Проблема в том, что в столбце А иногда возвращается #ССЫЛКА! и тогда формула ЕСЛИ тоже перестает работать.
Нужно сделать так, чтобы в случае, если А1=#ССЫЛКА!, возвращалось B1

Автор - ArkaIIIa
Дата добавления - 10.07.2013 в 17:48
Pelena Дата: Среда, 10.07.2013, 17:55 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15749
Репутация: 3430 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Используйте ЕОШ(), ЕСЛИОШИБКА() для обработки таких случаев


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеИспользуйте ЕОШ(), ЕСЛИОШИБКА() для обработки таких случаев

Автор - Pelena
Дата добавления - 10.07.2013 в 17:55
KuklP Дата: Среда, 10.07.2013, 17:58 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 2369
Репутация: 486 ±
Замечаний: 0% ±

2003-2010
Не проверял:
Код
=если(еош(a1);B1;ЕСЛИ(И(A1<>20;A1<>25;A1<>30);B1;A1)


Ну с НДС и мы чего-то стoим! kuklp60@gmail.com
WM Z206653985942, R334086032478, U238399322728


Сообщение отредактировал KuklP - Среда, 10.07.2013, 17:59
 
Ответить
СообщениеНе проверял:
Код
=если(еош(a1);B1;ЕСЛИ(И(A1<>20;A1<>25;A1<>30);B1;A1)

Автор - KuklP
Дата добавления - 10.07.2013 в 17:58
vikttur Дата: Среда, 10.07.2013, 21:49 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2924
Репутация: 525 ±
Замечаний: 0% ±

Извините, не так прочитал ("<>" / "=").
Вопрос снимается. Сообщение можно убить.


Сообщение отредактировал vikttur - Среда, 10.07.2013, 21:53
 
Ответить
СообщениеИзвините, не так прочитал ("<>" / "=").
Вопрос снимается. Сообщение можно убить.

Автор - vikttur
Дата добавления - 10.07.2013 в 21:49
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как убрать #ссылка!
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!