Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как сделать ссылку на вышестоящую ячейку +1 ? - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Как сделать ссылку на вышестоящую ячейку +1 ?
РастОК Дата: Вторник, 19.11.2013, 12:51 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здраствуйте форумчане.
Вопрос до боли банален, но чё-т не получается у меня.
Цель: сделать универсальную ячейку с формулой, которая бы отражала вышестоящую ячейку плюс один, а если ячейка пустая то значение должно стать 1.
Моё решение:
Код
=ЕСЛИ(ЕПУСТО(B11)=ИСТИНА;1;B11+1)

Ошибка: В моём случае идёт прямая ссылка на предыдущую ячейку и если ячейка удаляется, то выдаётся ошибка =ЕСЛИ(ЕПУСТО(#ССЫЛКА!)=ИСТИНА;1;#ССЫЛКА!+1)
Моё видение решения: Уйти от прямой ссылки на предыдущую ячейку, а сделать вместо прямой ссылки обращение к текущей ячейке минус одна строка вверх. Как это сделать я не знаю, подскажите пожалуйста.
 
Ответить
СообщениеЗдраствуйте форумчане.
Вопрос до боли банален, но чё-т не получается у меня.
Цель: сделать универсальную ячейку с формулой, которая бы отражала вышестоящую ячейку плюс один, а если ячейка пустая то значение должно стать 1.
Моё решение:
Код
=ЕСЛИ(ЕПУСТО(B11)=ИСТИНА;1;B11+1)

Ошибка: В моём случае идёт прямая ссылка на предыдущую ячейку и если ячейка удаляется, то выдаётся ошибка =ЕСЛИ(ЕПУСТО(#ССЫЛКА!)=ИСТИНА;1;#ССЫЛКА!+1)
Моё видение решения: Уйти от прямой ссылки на предыдущую ячейку, а сделать вместо прямой ссылки обращение к текущей ячейке минус одна строка вверх. Как это сделать я не знаю, подскажите пожалуйста.

Автор - РастОК
Дата добавления - 19.11.2013 в 12:51
_Boroda_ Дата: Вторник, 19.11.2013, 12:59 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16675
Репутация: 6481 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Для ячейки D8
Код
=СУММ(СМЕЩ(D8;-1;);1)

Конечно, для строки номер 1 работать не будет (у нее просто нет строки выше)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДля ячейки D8
Код
=СУММ(СМЕЩ(D8;-1;);1)

Конечно, для строки номер 1 работать не будет (у нее просто нет строки выше)

Автор - _Boroda_
Дата добавления - 19.11.2013 в 12:59
Rustem Дата: Вторник, 19.11.2013, 13:08 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 281
Репутация: 48 ±
Замечаний: 0% ±

Excel 2013
Попробуйте так:
Код
=ЕСЛИ(ЕПУСТО(ИНДЕКС(B:B;СТРОКА()-1))=ИСТИНА;1;ИНДЕКС(B:B;СТРОКА()-1)+1)


WMR: R183220163895

Сообщение отредактировал Rustem - Вторник, 19.11.2013, 13:08
 
Ответить
СообщениеПопробуйте так:
Код
=ЕСЛИ(ЕПУСТО(ИНДЕКС(B:B;СТРОКА()-1))=ИСТИНА;1;ИНДЕКС(B:B;СТРОКА()-1)+1)

Автор - Rustem
Дата добавления - 19.11.2013 в 13:08
РастОК Дата: Вторник, 19.11.2013, 13:34 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Ребят, у меня русский ексель, поэтому ваши формулы выдают ошибку. Сейчас попробую покопаться и перебить на русские формулы. Спасибо за ответы. Отпишусь получилось или нет.


Сообщение отредактировал РастОК - Вторник, 19.11.2013, 13:36
 
Ответить
СообщениеРебят, у меня русский ексель, поэтому ваши формулы выдают ошибку. Сейчас попробую покопаться и перебить на русские формулы. Спасибо за ответы. Отпишусь получилось или нет.

Автор - РастОК
Дата добавления - 19.11.2013 в 13:34
Pelena Дата: Вторник, 19.11.2013, 13:37 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 19281
Репутация: 4445 ±
Замечаний: ±

Excel 365 & Mac Excel
перебить на русские формулы

Проще нажать кнопку с флагом слева от формулы в сообщении


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
Сообщение
перебить на русские формулы

Проще нажать кнопку с флагом слева от формулы в сообщении

Автор - Pelena
Дата добавления - 19.11.2013 в 13:37
РастОК Дата: Вторник, 19.11.2013, 13:54 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
=SUM(OFFSET(D8,-1,),1)

В вашем варианте нельзя ссылаться на текущую ячейку иначе значение в любых случаях будет навно 1. Ссылка должна быть только на отличную ячейку. Но в общем это то решение, что мне нужно, просто нужно ссылаться на промежуточную ячейку (допустим соседнюю) и от неё отталкиваться. Огромаднейшее спасибо)
 
Ответить
Сообщение
=SUM(OFFSET(D8,-1,),1)

В вашем варианте нельзя ссылаться на текущую ячейку иначе значение в любых случаях будет навно 1. Ссылка должна быть только на отличную ячейку. Но в общем это то решение, что мне нужно, просто нужно ссылаться на промежуточную ячейку (допустим соседнюю) и от неё отталкиваться. Огромаднейшее спасибо)

Автор - РастОК
Дата добавления - 19.11.2013 в 13:54
_Boroda_ Дата: Вторник, 19.11.2013, 21:51 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16675
Репутация: 6481 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
В вашем варианте нельзя ссылаться на текущую ячейку иначе значение в любых случаях будет навно 1. Ссылка должна быть только на отличную ячейку.

Это кто вам сказал такую глупость? Плюньте ему на лысину.
Вы что, думаете, что я решение написал, а у себя его не проверил, да?


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
В вашем варианте нельзя ссылаться на текущую ячейку иначе значение в любых случаях будет навно 1. Ссылка должна быть только на отличную ячейку.

Это кто вам сказал такую глупость? Плюньте ему на лысину.
Вы что, думаете, что я решение написал, а у себя его не проверил, да?

Автор - _Boroda_
Дата добавления - 19.11.2013 в 21:51
AlexM Дата: Вторник, 19.11.2013, 22:44 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4517
Репутация: 1129 ±
Замечаний: 0% ±

Excel 2003
Еще вариант
Код
=ИНДЕКС(B:B;СТРОКА()-1)+1



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеЕще вариант
Код
=ИНДЕКС(B:B;СТРОКА()-1)+1

Автор - AlexM
Дата добавления - 19.11.2013 в 22:44
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!