Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Посчитать количество упоминаний символа в диапазоне ячеек - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Excel и другие приложения » Google Docs » Посчитать количество упоминаний символа в диапазоне ячеек (Формулы/Formulas)
Посчитать количество упоминаний символа в диапазоне ячеек
goloburdov Дата: Воскресенье, 17.01.2016, 23:50 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Как в google docs таблиц посчитать количество упоминаний символа в диапазоне ячеек?

Пример в exel прикрепил.
К сообщению приложен файл: 8624719.xlsx(11Kb)
 
Ответить
СообщениеКак в google docs таблиц посчитать количество упоминаний символа в диапазоне ячеек?

Пример в exel прикрепил.

Автор - goloburdov
Дата добавления - 17.01.2016 в 23:50
mathiax90 Дата: Понедельник, 18.01.2016, 07:13 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 164
Репутация: 20 ±
Замечаний: 20% ±

Excel 2007
Суммесли можно попробовать.
К сообщению приложен файл: 7083564.xlsx(10Kb)


webmoney: R242692021885
ЯД:410013877261817


Сообщение отредактировал mathiax90 - Понедельник, 18.01.2016, 07:14
 
Ответить
СообщениеСуммесли можно попробовать.

Автор - mathiax90
Дата добавления - 18.01.2016 в 07:13
_Boroda_ Дата: Понедельник, 18.01.2016, 07:35 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9827
Репутация: 4148 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СЧЁТЕСЛИ(A$1:A$15;1)
К сообщению приложен файл: 8624719_1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СЧЁТЕСЛИ(A$1:A$15;1)

Автор - _Boroda_
Дата добавления - 18.01.2016 в 07:35
mathiax90 Дата: Понедельник, 18.01.2016, 07:54 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 164
Репутация: 20 ±
Замечаний: 20% ±

Excel 2007
Так нужно?

Намного лучше чем мой вариант. Буду иметь ввиду.


webmoney: R242692021885
ЯД:410013877261817
 
Ответить
Сообщение
Так нужно?

Намного лучше чем мой вариант. Буду иметь ввиду.

Автор - mathiax90
Дата добавления - 18.01.2016 в 07:54
goloburdov Дата: Понедельник, 18.01.2016, 11:18 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Суммесли можно попробовать.

Так нужно?

Спасибо


Сообщение отредактировал goloburdov - Понедельник, 18.01.2016, 11:21
 
Ответить
Сообщение
Суммесли можно попробовать.

Так нужно?

Спасибо

Автор - goloburdov
Дата добавления - 18.01.2016 в 11:18
goloburdov Дата: Пятница, 22.01.2016, 18:20 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
=СЧЁТЕСЛИ(A$1:A$15;1)

=СЧЁТЕСЛИ(A$1:A$15;1)

Только сейчас заметил:
мне нужно количество упоминаний, даже если в 1 ячейки несколько цифр.
Т.е. например если в ячейке цифра "1" и не более, то эта формула работает корректно.
А если там будет число "11", то он не зачтёт это. А должен прибавить 2.
 
Ответить
Сообщение
=СЧЁТЕСЛИ(A$1:A$15;1)

=СЧЁТЕСЛИ(A$1:A$15;1)

Только сейчас заметил:
мне нужно количество упоминаний, даже если в 1 ячейки несколько цифр.
Т.е. например если в ячейке цифра "1" и не более, то эта формула работает корректно.
А если там будет число "11", то он не зачтёт это. А должен прибавить 2.

Автор - goloburdov
Дата добавления - 22.01.2016 в 18:20
Pelena Дата: Пятница, 22.01.2016, 18:40 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 10418
Репутация: 2358 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Код
=СУММПРОИЗВ(ДЛСТР($A$1:$A$15)-ДЛСТР(ПОДСТАВИТЬ($A$1:$A$15;C1;"")))
К сообщению приложен файл: 2223988.xlsx(10Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(ДЛСТР($A$1:$A$15)-ДЛСТР(ПОДСТАВИТЬ($A$1:$A$15;C1;"")))

Автор - Pelena
Дата добавления - 22.01.2016 в 18:40
goloburdov Дата: Пятница, 22.01.2016, 18:53 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
=СУММПРОИЗВ(ДЛСТР($A$1:$A$15)-ДЛСТР(ПОДСТАВИТЬ($A$1:$A$15;C1;"")))

О, то, что нужно.
Спасибо большое!
 
Ответить
Сообщение
=СУММПРОИЗВ(ДЛСТР($A$1:$A$15)-ДЛСТР(ПОДСТАВИТЬ($A$1:$A$15;C1;"")))

О, то, что нужно.
Спасибо большое!

Автор - goloburdov
Дата добавления - 22.01.2016 в 18:53
_Boroda_ Дата: Пятница, 22.01.2016, 19:16 | Сообщение № 9
Группа: Модераторы
Ранг: Экселист
Сообщений: 9827
Репутация: 4148 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=СУММПРОИЗВ(--(ПСТР(A$1:A$15;СТОЛБЕЦ(A:Z);1)=C1&""))
К сообщению приложен файл: 2223988_.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=СУММПРОИЗВ(--(ПСТР(A$1:A$15;СТОЛБЕЦ(A:Z);1)=C1&""))

Автор - _Boroda_
Дата добавления - 22.01.2016 в 19:16
Мир MS Excel » Вопросы и решения » Excel и другие приложения » Google Docs » Посчитать количество упоминаний символа в диапазоне ячеек (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!