Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула суммеслимн по частичному совпадению условия - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Excel и другие приложения » Google Docs » Формула суммеслимн по частичному совпадению условия (Формулы/Formulas)
Формула суммеслимн по частичному совпадению условия
msvmsu Дата: Четверг, 08.09.2016, 12:53 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 41
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Здравствуйте!

В документе нужно применить формулу суммеслимн по частичному совпадению условия. Я использую такой вариант
Код
=СУММЕСЛИМН('Регионы'!$E$16:$E$9512,'Регионы'!$A$16:$A$9512,G$2,'Регионы'!$D$16:$D$9512,"*"&$C5)
Но он не работает.

https://docs.google.com/spreads....sharing
В файле на листе Регионы_осн ячейка G5, в которую собираются данные из листа Регионы.
Для проверки скопировал данные из исходного листа и фильтром оставил только то, что соответствует условиям. По фильтру получается 19129, а по формуле 15689
Возможно ошибка в этой части формулы "*"&$C5

Подскажите, в чем проблема?
Заранее благодарен.


Сообщение отредактировал Manyasha - Четверг, 08.09.2016, 13:17
 
Ответить
СообщениеЗдравствуйте!

В документе нужно применить формулу суммеслимн по частичному совпадению условия. Я использую такой вариант
Код
=СУММЕСЛИМН('Регионы'!$E$16:$E$9512,'Регионы'!$A$16:$A$9512,G$2,'Регионы'!$D$16:$D$9512,"*"&$C5)
Но он не работает.

https://docs.google.com/spreads....sharing
В файле на листе Регионы_осн ячейка G5, в которую собираются данные из листа Регионы.
Для проверки скопировал данные из исходного листа и фильтром оставил только то, что соответствует условиям. По фильтру получается 19129, а по формуле 15689
Возможно ошибка в этой части формулы "*"&$C5

Подскажите, в чем проблема?
Заранее благодарен.

Автор - msvmsu
Дата добавления - 08.09.2016 в 12:53
китин Дата: Четверг, 08.09.2016, 13:00 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3450
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
допуска то нет


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Четверг, 08.09.2016, 13:12
 
Ответить
Сообщениедопуска то нет

Автор - китин
Дата добавления - 08.09.2016 в 13:00
msvmsu Дата: Четверг, 08.09.2016, 13:17 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 41
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
открыл доступ на редактирование по ссылке
 
Ответить
Сообщениеоткрыл доступ на редактирование по ссылке

Автор - msvmsu
Дата добавления - 08.09.2016 в 13:17
Manyasha Дата: Четверг, 08.09.2016, 13:43 | Сообщение № 4
Группа: Модераторы
Ранг: Старожил
Сообщений: 1589
Репутация: 669 ±
Замечаний: 0% ±

Excel 2007, 2010
msvmsu, здравствуйте. Ваша формула соответствует фильтру по "текст заканчивается на", чтобы было для "текст содержит", нужно в конец еще звездочку дописать:
Код
=СУММЕСЛИМН('Регионы'!$E$16:$E$9512,'Регионы'!$A$16:$A$9512,G$2,'Регионы'!$D$16:$D$9512,"*"&$C5&"*")


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
Сообщениеmsvmsu, здравствуйте. Ваша формула соответствует фильтру по "текст заканчивается на", чтобы было для "текст содержит", нужно в конец еще звездочку дописать:
Код
=СУММЕСЛИМН('Регионы'!$E$16:$E$9512,'Регионы'!$A$16:$A$9512,G$2,'Регионы'!$D$16:$D$9512,"*"&$C5&"*")

Автор - Manyasha
Дата добавления - 08.09.2016 в 13:43
msvmsu Дата: Четверг, 08.09.2016, 13:51 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 41
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
нужно в конец еще звездочку дописать:

Подозревал подобное, но знаний не хватило. Спасибо большое!


Сообщение отредактировал Manyasha - Четверг, 08.09.2016, 14:03
 
Ответить
Сообщение
нужно в конец еще звездочку дописать:

Подозревал подобное, но знаний не хватило. Спасибо большое!

Автор - msvmsu
Дата добавления - 08.09.2016 в 13:51
Manyasha Дата: Четверг, 08.09.2016, 14:04 | Сообщение № 6
Группа: Модераторы
Ранг: Старожил
Сообщений: 1589
Репутация: 669 ±
Замечаний: 0% ±

Excel 2007, 2010
msvmsu, Не нужно цитировать посты целиком - эту нарушение Правил форума.


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
Сообщениеmsvmsu, Не нужно цитировать посты целиком - эту нарушение Правил форума.

Автор - Manyasha
Дата добавления - 08.09.2016 в 14:04
Мир MS Excel » Вопросы и решения » Excel и другие приложения » Google Docs » Формула суммеслимн по частичному совпадению условия (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!