Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет по уникальным значениям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Excel и другие приложения » Google Docs » Подсчет по уникальным значениям (Формулы/Formulas)
Подсчет по уникальным значениям
stoniq Дата: Среда, 29.11.2017, 20:21 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 38
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Всем доброго времени!
Необходимо сделать на базе гугл докс следующую таблицу:

Закладка "Импорт" добавляется каждый день список ФИО и суммы по этим людям. Закладка "Общая" - в колонке "А" должен быть полный список уникальных ФИО за весь месяц, а по датам должно вписываться значение, соответствующее дате и ФИО человека (если в этот день оно было).
Буду благодарен за помощь!
К сообщению приложен файл: 3481800.xlsx(9Kb)
 
Ответить
СообщениеВсем доброго времени!
Необходимо сделать на базе гугл докс следующую таблицу:

Закладка "Импорт" добавляется каждый день список ФИО и суммы по этим людям. Закладка "Общая" - в колонке "А" должен быть полный список уникальных ФИО за весь месяц, а по датам должно вписываться значение, соответствующее дате и ФИО человека (если в этот день оно было).
Буду благодарен за помощь!

Автор - stoniq
Дата добавления - 29.11.2017 в 20:21
_Boroda_ Дата: Среда, 29.11.2017, 21:32 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Не знаю, как в Гугле, а в Excel так можно
Фамилии (формула массива)
Код
=ИНДЕКС(Импорт!$A:$BJ;ОСТАТ(МИН(ЕСЛИ((Импорт!$A$2:$BJ$2="ФИО")*(Импорт!$A$3:$BJ$22<>"")*ЕНД(ПОИСКПОЗ(Импорт!$A$3:$BJ$22;A$1:A1;));СТОЛБЕЦ(Импорт!$A:$BJ)+СТРОКА(Импорт!$3:$22)%));1)/1%+1%;МИН(ЕСЛИ((Импорт!$A$2:$BJ$2="ФИО")*(Импорт!$A$3:$BJ$22<>"")*ЕНД(ПОИСКПОЗ(Импорт!$A$3:$BJ$22;A$1:A1;));СТОЛБЕЦ(Импорт!$A:$BJ))))&""

Даты
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(Импорт!$A1:$BJ1;СТОЛБЕЦ(A1));"")

Суммы
Код
=ЕСЛИОШИБКА(ВПР($A2;ИНДЕКС(Импорт!$A$3:$BJ$3;ПОИСКПОЗ(B$1;Импорт!$B$1:$BJ$1;)):ИНДЕКС(Импорт!$A$22:$BJ$22;ПОИСКПОЗ(B$1;Импорт!$A$1:$BI$1;));2;);"")
К сообщению приложен файл: 3481800_1.xlsx(20Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНе знаю, как в Гугле, а в Excel так можно
Фамилии (формула массива)
Код
=ИНДЕКС(Импорт!$A:$BJ;ОСТАТ(МИН(ЕСЛИ((Импорт!$A$2:$BJ$2="ФИО")*(Импорт!$A$3:$BJ$22<>"")*ЕНД(ПОИСКПОЗ(Импорт!$A$3:$BJ$22;A$1:A1;));СТОЛБЕЦ(Импорт!$A:$BJ)+СТРОКА(Импорт!$3:$22)%));1)/1%+1%;МИН(ЕСЛИ((Импорт!$A$2:$BJ$2="ФИО")*(Импорт!$A$3:$BJ$22<>"")*ЕНД(ПОИСКПОЗ(Импорт!$A$3:$BJ$22;A$1:A1;));СТОЛБЕЦ(Импорт!$A:$BJ))))&""

Даты
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(Импорт!$A1:$BJ1;СТОЛБЕЦ(A1));"")

Суммы
Код
=ЕСЛИОШИБКА(ВПР($A2;ИНДЕКС(Импорт!$A$3:$BJ$3;ПОИСКПОЗ(B$1;Импорт!$B$1:$BJ$1;)):ИНДЕКС(Импорт!$A$22:$BJ$22;ПОИСКПОЗ(B$1;Импорт!$A$1:$BI$1;));2;);"")

Автор - _Boroda_
Дата добавления - 29.11.2017 в 21:32
stoniq Дата: Среда, 29.11.2017, 22:14 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 38
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
_Boroda_, пока вроде и на гугле получилось, буду проверять. спасибо большое!
 
Ответить
Сообщение_Boroda_, пока вроде и на гугле получилось, буду проверять. спасибо большое!

Автор - stoniq
Дата добавления - 29.11.2017 в 22:14
Мир MS Excel » Вопросы и решения » Excel и другие приложения » Google Docs » Подсчет по уникальным значениям (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!