Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как подтянуть данные из другого документа - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Excel и другие приложения » Google Docs » Как подтянуть данные из другого документа (Формулы/Formulas)
Как подтянуть данные из другого документа
bubanay Дата: Среда, 13.02.2019, 16:32 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте. Имею формулу
Код
=VLOOKUP(A1;'Лист3'!$A$1:$D$20000;2;0)
с помощью которой я могу тянуть данные с Лист3 этого же документа. Могу ли я так же тянуть эти данные с Лист3, но с другого документа, к которому у меня есть полный доступ?
 
Ответить
СообщениеЗдравствуйте. Имею формулу
Код
=VLOOKUP(A1;'Лист3'!$A$1:$D$20000;2;0)
с помощью которой я могу тянуть данные с Лист3 этого же документа. Могу ли я так же тянуть эти данные с Лист3, но с другого документа, к которому у меня есть полный доступ?

Автор - bubanay
Дата добавления - 13.02.2019 в 16:32
Gustav Дата: Среда, 13.02.2019, 23:53 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1647
Репутация: 670 ±
Замечаний: 0% ±

начинал с Excel 4.0...
Можно вот так:
Код
=ВПР(A1;IMPORTRANGE("id_другого_документа"; "Лист3!A1:D20000");2;0)

Это если формула одна, в одной ячейке.

Если же предполагается ее протяжка ячеек на 100 вниз, то 100 одинаковых IMPORTRANGE'й - слишком дорогое удовольствие. В этом случае лучше в текущем документе создать дополнительный лист, скажем, "Лист3импорт" и в его ячейке A1 написать единственную на весь лист формулу:
Код
=IMPORTRANGE("id_другого_документа"; "Лист3!A1:D20000")

а на листе, где нужен ВПР, со ссылкой уже на этот доп.лист записывается и протягиваются практически ваша формула:
Код
=ВПР(A1;'Лист3импорт'!$A$1:$D$20000;2;0)


Мой tip box - яд 41001663842605
 
Ответить
СообщениеМожно вот так:
Код
=ВПР(A1;IMPORTRANGE("id_другого_документа"; "Лист3!A1:D20000");2;0)

Это если формула одна, в одной ячейке.

Если же предполагается ее протяжка ячеек на 100 вниз, то 100 одинаковых IMPORTRANGE'й - слишком дорогое удовольствие. В этом случае лучше в текущем документе создать дополнительный лист, скажем, "Лист3импорт" и в его ячейке A1 написать единственную на весь лист формулу:
Код
=IMPORTRANGE("id_другого_документа"; "Лист3!A1:D20000")

а на листе, где нужен ВПР, со ссылкой уже на этот доп.лист записывается и протягиваются практически ваша формула:
Код
=ВПР(A1;'Лист3импорт'!$A$1:$D$20000;2;0)

Автор - Gustav
Дата добавления - 13.02.2019 в 23:53
Мир MS Excel » Вопросы и решения » Excel и другие приложения » Google Docs » Как подтянуть данные из другого документа (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!