Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос формулы массива в гугл таблицу - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Excel и другие приложения » Google Docs » Перенос формулы массива в гугл таблицу (Формулы/Formulas)
Перенос формулы массива в гугл таблицу
ASM_0408 Дата: Вторник, 28.05.2019, 19:19 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 221
Репутация: 0 ±
Замечаний: 0% ±

2016
Приветствую всех форумчан!
Помогите с решением задачи по переносу формулы из эксэль в гугл таблицу.
раньше таких проблем не испытывал, а сегодня впервые столкнулся с тем что гугл таблица "не приняла" формулу.
А вот собственно и сама формула оригинал эксэль
Код
=СУММ(ЕСЛИОШИБКА(СУММЕСЛИ(ДВССЫЛ(СТРОКА($1:$8)-1&"!$B$7:$C$29");C40;ДВССЫЛ(СТРОКА($1:$8)-1&"!$AJ$7:$AJ$29"));))

и вот что получается в гугл таблице

=ARRAY_CONSTRAIN(ARRAYFORMULA(СУММ(ЕСЛИОШИБКА(СУММЕСЛИ(ДВССЫЛ(СТРОКА($1:$8)-1&"!$B$7:$C$29");C35;ДВССЫЛ(СТРОКА($1:$8)-1&"!$AJ$7:$AJ$29"));))); 1; 1)
Думаю что в моем случае поможет функция Filter, но как прикрутить пока не понимаю


Сообщение отредактировал ASM_0408 - Вторник, 28.05.2019, 19:21
 
Ответить
СообщениеПриветствую всех форумчан!
Помогите с решением задачи по переносу формулы из эксэль в гугл таблицу.
раньше таких проблем не испытывал, а сегодня впервые столкнулся с тем что гугл таблица "не приняла" формулу.
А вот собственно и сама формула оригинал эксэль
Код
=СУММ(ЕСЛИОШИБКА(СУММЕСЛИ(ДВССЫЛ(СТРОКА($1:$8)-1&"!$B$7:$C$29");C40;ДВССЫЛ(СТРОКА($1:$8)-1&"!$AJ$7:$AJ$29"));))

и вот что получается в гугл таблице

=ARRAY_CONSTRAIN(ARRAYFORMULA(СУММ(ЕСЛИОШИБКА(СУММЕСЛИ(ДВССЫЛ(СТРОКА($1:$8)-1&"!$B$7:$C$29");C35;ДВССЫЛ(СТРОКА($1:$8)-1&"!$AJ$7:$AJ$29"));))); 1; 1)
Думаю что в моем случае поможет функция Filter, но как прикрутить пока не понимаю

Автор - ASM_0408
Дата добавления - 28.05.2019 в 19:19
ASM_0408 Дата: Среда, 29.05.2019, 17:53 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 221
Репутация: 0 ±
Замечаний: 0% ±

2016
Приложил файл эксэль.
И вот ссылка на гугл таблицу
https://drive.google.com/file....sharing
Может быть в синтаксисах что то не правильно транспонируется.
Сами функции вроде правильно но очень мало инфы по ним.
К сообщению приложен файл: 8302436.xlsx(33.7 Kb)


Сообщение отредактировал ASM_0408 - Среда, 29.05.2019, 17:55
 
Ответить
СообщениеПриложил файл эксэль.
И вот ссылка на гугл таблицу
https://drive.google.com/file....sharing
Может быть в синтаксисах что то не правильно транспонируется.
Сами функции вроде правильно но очень мало инфы по ним.

Автор - ASM_0408
Дата добавления - 29.05.2019 в 17:53
Мир MS Excel » Вопросы и решения » Excel и другие приложения » Google Docs » Перенос формулы массива в гугл таблицу (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!