Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Нарастающий итог в формулах массива - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Excel и другие приложения » Google Docs » Нарастающий итог в формулах массива (Формулы/Formulas)
Нарастающий итог в формулах массива
book Дата: Среда, 11.08.2021, 09:30 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 98
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день!

В самом простом случае нарастающий итог можно получить вот такой формулой
[vba]
Код
=СУММЕСЛИМН(C:C;A:A;A3;B:B;"<="&B3)
[/vba]

В другой теме уже обсуждался вопрос о том, что эту функцию нельзя использовать в качестве формулы массива и предлагался альтернативный вариант
[vba]
Код
=ArrayFormula(MMULT(
TRANSPOSE(('Производство'!$C:$C=X2)*('Производство'!$A:$A=TRANSPOSE($A3:$A7)));
N('Производство'!$D:$D)
)-C3:C7)
[/vba]
http://www.excelworld.ru/forum/23-38658-256201-16-1530186193

Но у меня никак не получается заставить формулу работать правильно, т.к. в моем случае критерий находится внутри диапазона критериев.

Буду признателен специалистам за помощь.

Хорошего дня!

Файл с моим примером
https://docs.google.com/spreads....sharing


--
С уважением,
Андрей.
 
Ответить
СообщениеДобрый день!

В самом простом случае нарастающий итог можно получить вот такой формулой
[vba]
Код
=СУММЕСЛИМН(C:C;A:A;A3;B:B;"<="&B3)
[/vba]

В другой теме уже обсуждался вопрос о том, что эту функцию нельзя использовать в качестве формулы массива и предлагался альтернативный вариант
[vba]
Код
=ArrayFormula(MMULT(
TRANSPOSE(('Производство'!$C:$C=X2)*('Производство'!$A:$A=TRANSPOSE($A3:$A7)));
N('Производство'!$D:$D)
)-C3:C7)
[/vba]
http://www.excelworld.ru/forum/23-38658-256201-16-1530186193

Но у меня никак не получается заставить формулу работать правильно, т.к. в моем случае критерий находится внутри диапазона критериев.

Буду признателен специалистам за помощь.

Хорошего дня!

Файл с моим примером
https://docs.google.com/spreads....sharing

Автор - book
Дата добавления - 11.08.2021 в 09:30
Gustav Дата: Среда, 11.08.2021, 12:43 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1907
Репутация: 770 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Поизучайте статью нашего признанного гуру таблиц Гугл:
https://contributor.pw/article....-sheets .

Он есть и на этом сайте: http://www.excelworld.ru/index/8-27873 - к большому сожалению, заглядывает редко. Ну, так, с другой стороны, можно (и нужно!) и нам к нему на сайт заглянуть.

Можете сразу глянуть в конец статьи, на формулу-"полного зверя":), и решить надо ли оно вам такое в вашем случае. Прежде всего, с точки зрения дальнейшего сопровождения формулы (вами и, особенно, если не вами - подумайте о кипящих мозгах ближнего, пожалейте его).


Мой tip box - яд 41001663842605
 
Ответить
СообщениеПоизучайте статью нашего признанного гуру таблиц Гугл:
https://contributor.pw/article....-sheets .

Он есть и на этом сайте: http://www.excelworld.ru/index/8-27873 - к большому сожалению, заглядывает редко. Ну, так, с другой стороны, можно (и нужно!) и нам к нему на сайт заглянуть.

Можете сразу глянуть в конец статьи, на формулу-"полного зверя":), и решить надо ли оно вам такое в вашем случае. Прежде всего, с точки зрения дальнейшего сопровождения формулы (вами и, особенно, если не вами - подумайте о кипящих мозгах ближнего, пожалейте его).

Автор - Gustav
Дата добавления - 11.08.2021 в 12:43
book Дата: Среда, 11.08.2021, 13:37 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 98
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Gustav, спасибо за ссылку – там много полезной информации.
Пожалуй, Вы правы – надо хорошо подумать, прежде, чем браться за такого «зверя».
Пока решил сделать с использованием нескольких промежуточных таблиц. Схема решения – в файле, чтобы не писать здесь много текста.
PS
Надеялся именно на Ваш ответ. Еще раз спасибо.


--
С уважением,
Андрей.
 
Ответить
СообщениеGustav, спасибо за ссылку – там много полезной информации.
Пожалуй, Вы правы – надо хорошо подумать, прежде, чем браться за такого «зверя».
Пока решил сделать с использованием нескольких промежуточных таблиц. Схема решения – в файле, чтобы не писать здесь много текста.
PS
Надеялся именно на Ваш ответ. Еще раз спасибо.

Автор - book
Дата добавления - 11.08.2021 в 13:37
Мир MS Excel » Вопросы и решения » Excel и другие приложения » Google Docs » Нарастающий итог в формулах массива (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!