Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выполнение условия для функции "суммеслимн" - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, китин  
Мир MS Excel » Вопросы и решения » Excel и другие приложения » Google Docs » Выполнение условия для функции "суммеслимн" (Формулы/Formulas)
Выполнение условия для функции "суммеслимн"
dminicab Дата: Четверг, 06.01.2022, 23:41 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 20% ±

Доброго времени суток!
Собственно столкнулся с такой задачей. Нужно выполнить подсчет количества заказов по функции "суммеслимн". Но проблема в том, что не могу создать проверку по условию соответствия нужной дате. В моей таблице дата указывается в стандартном формате "дд.мм.гггг", а в таблице из которой производится поиск и суммирование (Лист2) формат даты со временем "дд.мм.гггг чч:мм:сс". В таком формате данные передаются по АПИ, их изменить я не могу. Но проблема скорее всего даже не в этом. Потому что даже приводя дату к нужному формату, формула не работает. Не могу сообразить, как реализовать мою задачу. Не считает формула.

Сейчас моя формула выглядит вот так:
=СУММЕСЛИМН('Лист2'!$G:$G;'Лист2'!$D:$D;B$2;'Лист2'!$Q:$Q;B$1;'Лист2'!$R:$R;"ЛОЖЬ";'Лист2'!$C:$C;"="&$A5)

Пример вот здесь выложил:
Пример

Помогите люди добрые? Как решить задачу, не понимаю даже. И решаема ли она вообще.
 
Ответить
СообщениеДоброго времени суток!
Собственно столкнулся с такой задачей. Нужно выполнить подсчет количества заказов по функции "суммеслимн". Но проблема в том, что не могу создать проверку по условию соответствия нужной дате. В моей таблице дата указывается в стандартном формате "дд.мм.гггг", а в таблице из которой производится поиск и суммирование (Лист2) формат даты со временем "дд.мм.гггг чч:мм:сс". В таком формате данные передаются по АПИ, их изменить я не могу. Но проблема скорее всего даже не в этом. Потому что даже приводя дату к нужному формату, формула не работает. Не могу сообразить, как реализовать мою задачу. Не считает формула.

Сейчас моя формула выглядит вот так:
=СУММЕСЛИМН('Лист2'!$G:$G;'Лист2'!$D:$D;B$2;'Лист2'!$Q:$Q;B$1;'Лист2'!$R:$R;"ЛОЖЬ";'Лист2'!$C:$C;"="&$A5)

Пример вот здесь выложил:
Пример

Помогите люди добрые? Как решить задачу, не понимаю даже. И решаема ли она вообще.

Автор - dminicab
Дата добавления - 06.01.2022 в 23:41
Gustav Дата: Пятница, 07.01.2022, 04:28 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2136
Репутация: 840 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Для ячейки C5 такая формула:
Код
=SUMIFS('Лист2'!$F:$F; 'Лист2'!$D:$D;B$2; 'Лист2'!$L:$L;B$1; 'Лист2'!$M:$M;FALSE; 'Лист2'!$C:$C;">="&$A5; 'Лист2'!$C:$C;"<"&$A5+1)

Или в более наглядном форматированном виде по отдельным условиям:
[vba]
Код
=SUMIFS( 'Лист2'!$F:$F;
'Лист2'!$D:$D; B$2;
'Лист2'!$L:$L; B$1;
'Лист2'!$M:$M; FALSE;
'Лист2'!$C:$C; ">="&$A5; 'Лист2'!$C:$C; "<"&$A5+1 )
[/vba]
[p.s.]Еще вариант - через другую функцию:[/p.s.]
[vba]
Код
=SUMPRODUCT( 'Лист2'!$F:$F;
'Лист2'!$D:$D = B$2;
'Лист2'!$L:$L = B$1;
'Лист2'!$M:$M = FALSE;
ISBETWEEN('Лист2'!$C:$C;$A5;$A5+1;1;0) )
[/vba]


Мой tip box - яд 41001663842605

Сообщение отредактировал Gustav - Пятница, 07.01.2022, 04:51
 
Ответить
СообщениеДля ячейки C5 такая формула:
Код
=SUMIFS('Лист2'!$F:$F; 'Лист2'!$D:$D;B$2; 'Лист2'!$L:$L;B$1; 'Лист2'!$M:$M;FALSE; 'Лист2'!$C:$C;">="&$A5; 'Лист2'!$C:$C;"<"&$A5+1)

Или в более наглядном форматированном виде по отдельным условиям:
[vba]
Код
=SUMIFS( 'Лист2'!$F:$F;
'Лист2'!$D:$D; B$2;
'Лист2'!$L:$L; B$1;
'Лист2'!$M:$M; FALSE;
'Лист2'!$C:$C; ">="&$A5; 'Лист2'!$C:$C; "<"&$A5+1 )
[/vba]
[p.s.]Еще вариант - через другую функцию:[/p.s.]
[vba]
Код
=SUMPRODUCT( 'Лист2'!$F:$F;
'Лист2'!$D:$D = B$2;
'Лист2'!$L:$L = B$1;
'Лист2'!$M:$M = FALSE;
ISBETWEEN('Лист2'!$C:$C;$A5;$A5+1;1;0) )
[/vba]

Автор - Gustav
Дата добавления - 07.01.2022 в 04:28
dminicab Дата: Пятница, 07.01.2022, 05:05 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 20% ±

Gustav, большое спасибо, работает. Но только в этой тестовой таблице почему-то( когда переношу формулу в рабочую таблицу, работать перестает. Все перепроверил, не могу понять почему :(
 
Ответить
СообщениеGustav, большое спасибо, работает. Но только в этой тестовой таблице почему-то( когда переношу формулу в рабочую таблицу, работать перестает. Все перепроверил, не могу понять почему :(

Автор - dminicab
Дата добавления - 07.01.2022 в 05:05
dminicab Дата: Пятница, 07.01.2022, 05:11 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 20% ±

=SUMPRODUCT( 'Лист2'!$F:$F;
'Лист2'!$D:$D = B$2;
'Лист2'!$L:$L = B$1;
'Лист2'!$M:$M = FALSE;
ISBETWEEN('Лист2'!$C:$C;$A5;$A5+1;1;0) )


А вот этот вариант работает :D Спасибо большое еще раз!
 
Ответить
Сообщение
=SUMPRODUCT( 'Лист2'!$F:$F;
'Лист2'!$D:$D = B$2;
'Лист2'!$L:$L = B$1;
'Лист2'!$M:$M = FALSE;
ISBETWEEN('Лист2'!$C:$C;$A5;$A5+1;1;0) )


А вот этот вариант работает :D Спасибо большое еще раз!

Автор - dminicab
Дата добавления - 07.01.2022 в 05:11
Мир MS Excel » Вопросы и решения » Excel и другие приложения » Google Docs » Выполнение условия для функции "суммеслимн" (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!