Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Изменение динамической формулы при заполнении google-формы - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, китин  
Мир MS Excel » Вопросы и решения » Excel и другие приложения » Google Docs » Изменение динамической формулы при заполнении google-формы (Формулы/Formulas)
Изменение динамической формулы при заполнении google-формы
oneandfogh Дата: Воскресенье, 27.02.2022, 10:02 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Привет, друзья! У меня есть облачный документ на сервисе Google Таблицы и форма на сервисе Google Формы. Они связаны между собой → при заполнении формы человеком, информация переносится в таблицу.
Создано 4 листа (названия условные): Проблема1, Проблема2, Выгрузка: Проблема1, Выгрузка: Проблема2. Листы с выгрузкой закреплены за соответствующими формами и заполняются, как стандартные листы без дополнительного форматирования.
Лист Проблема1 и Проблема2 представляют из себя полное копирование информации из одноимённых выгрузочных листов с последующим форматированием с помощью формул, условным форматированием и добавлением рабочих столбцов.

Вид листа Проблема (см. скриншот):
Первая строка отвечает за название информации, которую вносит игрок с помощью формы. Она закреплена и не меняется.
Далее идут формулы в диапазоне A2:J. В диапазоне A2:A (столбец ID) указывается числовой ID заявки, цифра появляется, если соседний столбец имеет какое-либо значение. Формула:
Код
=ЕСЛИ(B7="";"";A6+1)

Потом сплошняком идут одни и те же формулы: ='Выгрузка: Донаты'!A7, ='Выгрузка: Донаты'!A8 и т.п. до столбца «Ссылка на тикет» и «Ник». Там информация проходит дополнительную проверку.
Формула ссылки на тикет:
Код
=ЕСЛИ('Выгрузка: Донаты'!E7="";"";"(тут_домен_сайта_поддержки)/#/ticket/"&'Выгрузка: Донаты'!E7)

Формула ника:
Код
=ЕСЛИ('Выгрузка: Донаты'!D7="Такой же";'Выгрузка: Донаты'!C7;'Выгрузка: Донаты'!D7)


Все остальные строки остаются с формулами ='Выгрузка: Донаты'!E7 (адрес ячейки меняется в соответствии с нужной строкой связанного листа). Все ячейки были заполнены формулой через копирование+вставку, формулы подтянулись корректно, ничего не предвещало беды.

Но возникла загвоздка. При заполнении формы и при переносе информации в лист выгрузки (условно, на строку 6), то формулы ячеек в листе проблемы на строке 6 меняли адрес на строку 7. Таком образом, получалось пропущенное число, приходится вручную каждый раз обновлять формулы. Подскажите, как эту проблему можно решить? Ссылку на документ предоставить не смогу из-за ограничения прав просмотра. Прикладываю подробные скриншоты листов и формул.
К сообщению приложен файл: 1825069.png(71.3 Kb) · 4835417.png(5.6 Kb) · 3385559.png(50.1 Kb)
 
Ответить
СообщениеПривет, друзья! У меня есть облачный документ на сервисе Google Таблицы и форма на сервисе Google Формы. Они связаны между собой → при заполнении формы человеком, информация переносится в таблицу.
Создано 4 листа (названия условные): Проблема1, Проблема2, Выгрузка: Проблема1, Выгрузка: Проблема2. Листы с выгрузкой закреплены за соответствующими формами и заполняются, как стандартные листы без дополнительного форматирования.
Лист Проблема1 и Проблема2 представляют из себя полное копирование информации из одноимённых выгрузочных листов с последующим форматированием с помощью формул, условным форматированием и добавлением рабочих столбцов.

Вид листа Проблема (см. скриншот):
Первая строка отвечает за название информации, которую вносит игрок с помощью формы. Она закреплена и не меняется.
Далее идут формулы в диапазоне A2:J. В диапазоне A2:A (столбец ID) указывается числовой ID заявки, цифра появляется, если соседний столбец имеет какое-либо значение. Формула:
Код
=ЕСЛИ(B7="";"";A6+1)

Потом сплошняком идут одни и те же формулы: ='Выгрузка: Донаты'!A7, ='Выгрузка: Донаты'!A8 и т.п. до столбца «Ссылка на тикет» и «Ник». Там информация проходит дополнительную проверку.
Формула ссылки на тикет:
Код
=ЕСЛИ('Выгрузка: Донаты'!E7="";"";"(тут_домен_сайта_поддержки)/#/ticket/"&'Выгрузка: Донаты'!E7)

Формула ника:
Код
=ЕСЛИ('Выгрузка: Донаты'!D7="Такой же";'Выгрузка: Донаты'!C7;'Выгрузка: Донаты'!D7)


Все остальные строки остаются с формулами ='Выгрузка: Донаты'!E7 (адрес ячейки меняется в соответствии с нужной строкой связанного листа). Все ячейки были заполнены формулой через копирование+вставку, формулы подтянулись корректно, ничего не предвещало беды.

Но возникла загвоздка. При заполнении формы и при переносе информации в лист выгрузки (условно, на строку 6), то формулы ячеек в листе проблемы на строке 6 меняли адрес на строку 7. Таком образом, получалось пропущенное число, приходится вручную каждый раз обновлять формулы. Подскажите, как эту проблему можно решить? Ссылку на документ предоставить не смогу из-за ограничения прав просмотра. Прикладываю подробные скриншоты листов и формул.

Автор - oneandfogh
Дата добавления - 27.02.2022 в 10:02
Kashimirush Дата: Вторник, 01.03.2022, 07:35 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 240
Репутация: 40 ±
Замечаний: 0% ±

Excel 2010
Ссылку на документ предоставить не смогу из-за ограничения прав просмотра

Сделайте пример с повторением проблемы и вымышленными данными.
Скорее всего вашу проблему решит использование формулы массива Arrayformula, поищите в интернетах много видео и документации.


Работа, работа, перейди на Федота...
 
Ответить
Сообщение
Ссылку на документ предоставить не смогу из-за ограничения прав просмотра

Сделайте пример с повторением проблемы и вымышленными данными.
Скорее всего вашу проблему решит использование формулы массива Arrayformula, поищите в интернетах много видео и документации.

Автор - Kashimirush
Дата добавления - 01.03.2022 в 07:35
Мир MS Excel » Вопросы и решения » Excel и другие приложения » Google Docs » Изменение динамической формулы при заполнении google-формы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!