Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула для массива чтоб считалось если три параметра сошло - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, китин  
Мир MS Excel » Вопросы и решения » Excel и другие приложения » Google Docs » Формула для массива чтоб считалось если три параметра сошло (Формулы/Formulas)
Формула для массива чтоб считалось если три параметра сошло
g06lins Дата: Среда, 20.04.2022, 10:13 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 20% ±

Доброго дня есть таблица для подсчёта зп в первом столбце имена Сотрудников во втором конверсия, в третьем средний чек. Нужна формула чтоб увидеть столбец с именами и делал поиск по имени потом смотрела есть ли выполнение конверсии и среднего чека и если да то 500
Формула без массива работает, но это отдельный столбец чтоб напротив каждого имени появлялись 500. Решил сделать через массив чтоб просто в одном месте появился сумма всех этих 500
Код
=ЕСЛИ(И('Март'!B9="Ульяна";'Март'!G9>400;'Март'!J9>100);500;0)
без массива работает
Код
=ARRAYFORMULA(ЕСЛИ(И('Март'!B4:B20="Ульяна";'Март'!G4:G20>400;'Март'!J4:J20>100);500;0))
не работает.
В чем ошибка


Сообщение отредактировал Serge_007 - Среда, 20.04.2022, 13:08
 
Ответить
СообщениеДоброго дня есть таблица для подсчёта зп в первом столбце имена Сотрудников во втором конверсия, в третьем средний чек. Нужна формула чтоб увидеть столбец с именами и делал поиск по имени потом смотрела есть ли выполнение конверсии и среднего чека и если да то 500
Формула без массива работает, но это отдельный столбец чтоб напротив каждого имени появлялись 500. Решил сделать через массив чтоб просто в одном месте появился сумма всех этих 500
Код
=ЕСЛИ(И('Март'!B9="Ульяна";'Март'!G9>400;'Март'!J9>100);500;0)
без массива работает
Код
=ARRAYFORMULA(ЕСЛИ(И('Март'!B4:B20="Ульяна";'Март'!G4:G20>400;'Март'!J4:J20>100);500;0))
не работает.
В чем ошибка

Автор - g06lins
Дата добавления - 20.04.2022 в 10:13
aliramora191 Дата: Среда, 20.04.2022, 11:44 | Сообщение № 2
Группа: Проверенные
Ранг: Новичок
Сообщений: 36
Репутация: 17 ±
Замечаний: 0% ±

2016
Вы бы скинули ссылку на пример


Анастасия
 
Ответить
СообщениеВы бы скинули ссылку на пример

Автор - aliramora191
Дата добавления - 20.04.2022 в 11:44
Serge_007 Дата: Среда, 20.04.2022, 11:50 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 15415
Репутация: 2537 ±
Замечаний: ±

Excel 2016
Код
=ARRAYFORMULA(ЕСЛИ(И('Март'!B4:B20="Ульяна";'Март'!G4:G20>400;'Март'!J4:J20>100);500;0))
не работает.
Так будет работать:
Код
=500*((Март!B4:B20="Ульяна")*(Март!G4:G20>400)*(Март!J4:J20>100))

ARRAYFORMULA() - это функция, которая указывает формуле обрабатывать массив
Но сама по себе ARRAYFORMULA() не производит вычислений
Что Вы от неё хотите?

[admin]Читайте правила форума, оформляйие формулы тегами[/admin]


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Код
=ARRAYFORMULA(ЕСЛИ(И('Март'!B4:B20="Ульяна";'Март'!G4:G20>400;'Март'!J4:J20>100);500;0))
не работает.
Так будет работать:
Код
=500*((Март!B4:B20="Ульяна")*(Март!G4:G20>400)*(Март!J4:J20>100))

ARRAYFORMULA() - это функция, которая указывает формуле обрабатывать массив
Но сама по себе ARRAYFORMULA() не производит вычислений
Что Вы от неё хотите?

[admin]Читайте правила форума, оформляйие формулы тегами[/admin]

Автор - Serge_007
Дата добавления - 20.04.2022 в 11:50
g06lins Дата: Среда, 20.04.2022, 12:12 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 20% ±

Спасибо, заработало, теперь буду думать и понимать как))))
 
Ответить
СообщениеСпасибо, заработало, теперь буду думать и понимать как))))

Автор - g06lins
Дата добавления - 20.04.2022 в 12:12
g06lins Дата: Среда, 20.04.2022, 12:30 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 20% ±

ARRAYFORMULA() - это функция, которая указывает формуле обрабатывать массив
Но сама по себе ARRAYFORMULA() не производит вычислений
Что Вы от неё хотите?

Ваша формула заработала только после того как я засунул ее в массив ARRAYFORMULA()
В начале добавил еще СУММ и тогда получилось то что надо итоговая цифра в одной клетке, а до этого он разбрасывал в столбец оп каждому дню.
Код
=ArrayFormula(СУММ(500*(('Март'!B4:B20="Ульяна")*('Март'!G4:G20>50)*('Март'!J4:J20>30))))
 
Ответить
Сообщение
ARRAYFORMULA() - это функция, которая указывает формуле обрабатывать массив
Но сама по себе ARRAYFORMULA() не производит вычислений
Что Вы от неё хотите?

Ваша формула заработала только после того как я засунул ее в массив ARRAYFORMULA()
В начале добавил еще СУММ и тогда получилось то что надо итоговая цифра в одной клетке, а до этого он разбрасывал в столбец оп каждому дню.
Код
=ArrayFormula(СУММ(500*(('Март'!B4:B20="Ульяна")*('Март'!G4:G20>50)*('Март'!J4:J20>30))))

Автор - g06lins
Дата добавления - 20.04.2022 в 12:30
Serge_007 Дата: Среда, 20.04.2022, 13:08 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 15415
Репутация: 2537 ±
Замечаний: ±

Excel 2016
засунул ее в массив ARRAYFORMULA()
В начале добавил еще СУММ
Это необязательно

Без ARRAYFORMULA():
Код
=СУММПРОИЗВ((Март!B4:B20="Ульяна")*(Март!G4:G20>400)*(Март!J4:J20>100)*500)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
засунул ее в массив ARRAYFORMULA()
В начале добавил еще СУММ
Это необязательно

Без ARRAYFORMULA():
Код
=СУММПРОИЗВ((Март!B4:B20="Ульяна")*(Март!G4:G20>400)*(Март!J4:J20>100)*500)

Автор - Serge_007
Дата добавления - 20.04.2022 в 13:08
Мир MS Excel » Вопросы и решения » Excel и другие приложения » Google Docs » Формула для массива чтоб считалось если три параметра сошло (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!