Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как посчитать сколько раз, одно значение встречается на лист - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, китин  
Мир MS Excel » Вопросы и решения » Excel и другие приложения » Google Docs » Как посчитать сколько раз, одно значение встречается на лист (Формулы/Formulas)
Как посчитать сколько раз, одно значение встречается на лист
stc Дата: Вторник, 03.05.2022, 11:21 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 60% ±

Подскажите, как подсчитать сколько раз, клиент покупал товар.
В таблице есть столбец с ID клиентов.
Они имеют вид
58712420-50-1
72026936-10-1
83009174-41-1
56849502-04-1
58712420-51-1
58712420-52-1
Как напротив каждой строки вывести, число, которое отражает, сколько раз на данном листе встречается каждый ID?
Из перечисленных ID в примере получается, что ID 58712420 = 3. Остальные = 1
 
Ответить
СообщениеПодскажите, как подсчитать сколько раз, клиент покупал товар.
В таблице есть столбец с ID клиентов.
Они имеют вид
58712420-50-1
72026936-10-1
83009174-41-1
56849502-04-1
58712420-51-1
58712420-52-1
Как напротив каждой строки вывести, число, которое отражает, сколько раз на данном листе встречается каждый ID?
Из перечисленных ID в примере получается, что ID 58712420 = 3. Остальные = 1

Автор - stc
Дата добавления - 03.05.2022 в 11:21
_Boroda_ Дата: Среда, 04.05.2022, 09:24 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16359
Репутация: 6352 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
=СЧЁТЕСЛИ(A$1:A$999;ЛЕВБ(A2;8)&"*")


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Код
=СЧЁТЕСЛИ(A$1:A$999;ЛЕВБ(A2;8)&"*")

Автор - _Boroda_
Дата добавления - 04.05.2022 в 09:24
stc Дата: Среда, 04.05.2022, 13:36 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 60% ±

А можете объяснить формулу?
Я добавил тестовую таблицу
https://docs.google.com/spreads....3284608
Лист3
Проблема в том, что нужно из ID брать цифры только до первого дефиса
58712420-50-1
72026936-10-1
83009174-41-1
56849502-04-1
58712420-51-1
58712420-52-1
 
Ответить
СообщениеА можете объяснить формулу?
Я добавил тестовую таблицу
https://docs.google.com/spreads....3284608
Лист3
Проблема в том, что нужно из ID брать цифры только до первого дефиса
58712420-50-1
72026936-10-1
83009174-41-1
56849502-04-1
58712420-51-1
58712420-52-1

Автор - stc
Дата добавления - 04.05.2022 в 13:36
Serge_007 Дата: Среда, 04.05.2022, 13:42 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 15405
Репутация: 2536 ±
Замечаний: ±

Excel 2016
добавил тестовую таблицу
Код
=COUNTIF(A$1:A$10;LEFT(A1;8)&"*")


объяснить формулу
Функция LEFT() возвращает только первые 8 символов ID (до первого дефиса) к которым добавляется любое сочетание символов - &"*"
Функция COUNTIF() считает сколько таких "укороченных" ID есть в просматриваемом диапазоне

Слева исходные данные, справа - обработанные формулой
58712420-50-1 58712420*
72026936-10-1 72026936*
83009174-41-1 83009174*
56849502-04-1 56849502*
58712420-51-1 58712420*
58712420-52-1 58712420*


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
добавил тестовую таблицу
Код
=COUNTIF(A$1:A$10;LEFT(A1;8)&"*")


объяснить формулу
Функция LEFT() возвращает только первые 8 символов ID (до первого дефиса) к которым добавляется любое сочетание символов - &"*"
Функция COUNTIF() считает сколько таких "укороченных" ID есть в просматриваемом диапазоне

Слева исходные данные, справа - обработанные формулой
58712420-50-1 58712420*
72026936-10-1 72026936*
83009174-41-1 83009174*
56849502-04-1 56849502*
58712420-51-1 58712420*
58712420-52-1 58712420*

Автор - Serge_007
Дата добавления - 04.05.2022 в 13:42
Мир MS Excel » Вопросы и решения » Excel и другие приложения » Google Docs » Как посчитать сколько раз, одно значение встречается на лист (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!