Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Задача по фильтрам массово - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena 
Мир MS Excel » Работа и общение » Работа / Фриланс » Задача по фильтрам массово (создание афтоматического фильтра, оплата по договоренности)
Задача по фильтрам массово
kitreklama Дата: Понедельник, 26.09.2016, 11:38 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день, уважаемые специалисты, прошу Вашей помощи.

Стоит специфическая задача делать фильтрацию по большому количеству слов в ячейках по столбу по заведомо указанному списку слов.

Вот примерно так.

Столбец А
Значение 1
Значение 2
*
*
Значение n

Необходимо в данном списке значений выбрать те ячейки в значение которых входят определенные тексты текст1 ; текст2 *** Текст n.

Другими словами фильтр должен показывать ячейки если в нее входит текст1 или текст2 или текс3 и далее по саиску.

В ручную делать обычным фильтром затруднительно и вот почему:

Проблема осложняется тем, что Столбец А содержит порядком 50 000 слов, а значений Текст может содержать до тысячи. Получается ручной режим не подходит.
 
Ответить
СообщениеДобрый день, уважаемые специалисты, прошу Вашей помощи.

Стоит специфическая задача делать фильтрацию по большому количеству слов в ячейках по столбу по заведомо указанному списку слов.

Вот примерно так.

Столбец А
Значение 1
Значение 2
*
*
Значение n

Необходимо в данном списке значений выбрать те ячейки в значение которых входят определенные тексты текст1 ; текст2 *** Текст n.

Другими словами фильтр должен показывать ячейки если в нее входит текст1 или текст2 или текс3 и далее по саиску.

В ручную делать обычным фильтром затруднительно и вот почему:

Проблема осложняется тем, что Столбец А содержит порядком 50 000 слов, а значений Текст может содержать до тысячи. Получается ручной режим не подходит.

Автор - kitreklama
Дата добавления - 26.09.2016 в 11:38
Ivan_kh Дата: Понедельник, 26.09.2016, 11:59 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 4 ±
Замечаний: 0% ±

Создайте в своей таблице дополнительный столбец, в котором с помощью того же ВПР проверьте соответствие заданного текста с необходимым списком.
Потом по этому столбцу и фильтруйте.
 
Ответить
СообщениеСоздайте в своей таблице дополнительный столбец, в котором с помощью того же ВПР проверьте соответствие заданного текста с необходимым списком.
Потом по этому столбцу и фильтруйте.

Автор - Ivan_kh
Дата добавления - 26.09.2016 в 11:59
Pelena Дата: Понедельник, 26.09.2016, 12:02 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9865
Репутация: 2255 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
kitreklama, рекламу из подписи уберите.


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщениеkitreklama, рекламу из подписи уберите.

Автор - Pelena
Дата добавления - 26.09.2016 в 12:02
kitreklama Дата: Понедельник, 26.09.2016, 12:36 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Щас уберу, спасибо!


Сообщение отредактировал kitreklama - Понедельник, 26.09.2016, 12:37
 
Ответить
СообщениеЩас уберу, спасибо!

Автор - kitreklama
Дата добавления - 26.09.2016 в 12:36
Pelena Дата: Понедельник, 26.09.2016, 12:43 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9865
Репутация: 2255 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Написала в личку


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеНаписала в личку

Автор - Pelena
Дата добавления - 26.09.2016 в 12:43
Pelena Дата: Вторник, 27.09.2016, 08:17 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9865
Репутация: 2255 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Ivan_kh, я правильно понимаю, что задача решена Вами?


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеIvan_kh, я правильно понимаю, что задача решена Вами?

Автор - Pelena
Дата добавления - 27.09.2016 в 08:17
Ivan_kh Дата: Вторник, 27.09.2016, 12:52 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 4 ±
Замечаний: 0% ±

Добрый день.
Ничего не решал, просто оставил совет, на этом и ограничился.
 
Ответить
СообщениеДобрый день.
Ничего не решал, просто оставил совет, на этом и ограничился.

Автор - Ivan_kh
Дата добавления - 27.09.2016 в 12:52
kitreklama Дата: Вторник, 27.09.2016, 14:36 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
ДА, спасибо!
Для тех кому будет полезно, отработала формула

=СУММ(СЧЁТЕСЛИ(A2;"*" & $I$2:$I$3 & "*"))
 
Ответить
СообщениеДА, спасибо!
Для тех кому будет полезно, отработала формула

=СУММ(СЧЁТЕСЛИ(A2;"*" & $I$2:$I$3 & "*"))

Автор - kitreklama
Дата добавления - 27.09.2016 в 14:36
Мир MS Excel » Работа и общение » Работа / Фриланс » Задача по фильтрам массово (создание афтоматического фильтра, оплата по договоренности)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!