Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Доработка формулы - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Работа и общение » Работа / Фриланс » Доработка формулы (Необходимо доработать формулу, не хватает знаний)
Доработка формулы
NekrasovAVbr2119 Дата: Среда, 15.05.2024, 10:48 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

2021
Здравствуйте, прошу помощи в доработке формулы

Задача которую нужно решить:
Значение из ячейки "C3" на "листе0" ищем в столбце "С" на "листе2" и если значение ячейки "G3" совпадает с ячейкой "F" из найденной ранее строки, то значение из ячейки "M" вставляем туда где формула, а формула добавляется в ячейку "AF3" "листа0"

Тестовый файл прилагаю

Что сделано:
Значение из ячейки "C3" на "листе0" ищем в столбце "С" на "листе2" и значение из ячейки "M" вставляем туда где формула, а формула добавляется в ячейку "AF3" "листа0"

P.S. в ячейке "C3" "листа0" указано значение с добавлением 2х символов, а в искомом столбце без них. Например "C3" "листа0" = "62318829-0041-1", а в столбце "C" "листа2" значения вида "62318829-0041" В моей формуле это учтено, можно заимствовать

Не могу сделать выполнение второго условия в формуле, а именно когда находится значение "C3" из "листа0" нет проверки ячейки "F" "листа2" с ячейков "G3" "листа0"

УСЛОВИЕ: формулу нужно сделать с возможностью автоматического продления вниз потянув за край в колонке "AF" "листа0"

Уместна ли оплата в 200 рублей за данное задание?
К сообщению приложен файл: testovyj_fajl.xlsx (474.1 Kb)
 
Ответить
СообщениеЗдравствуйте, прошу помощи в доработке формулы

Задача которую нужно решить:
Значение из ячейки "C3" на "листе0" ищем в столбце "С" на "листе2" и если значение ячейки "G3" совпадает с ячейкой "F" из найденной ранее строки, то значение из ячейки "M" вставляем туда где формула, а формула добавляется в ячейку "AF3" "листа0"

Тестовый файл прилагаю

Что сделано:
Значение из ячейки "C3" на "листе0" ищем в столбце "С" на "листе2" и значение из ячейки "M" вставляем туда где формула, а формула добавляется в ячейку "AF3" "листа0"

P.S. в ячейке "C3" "листа0" указано значение с добавлением 2х символов, а в искомом столбце без них. Например "C3" "листа0" = "62318829-0041-1", а в столбце "C" "листа2" значения вида "62318829-0041" В моей формуле это учтено, можно заимствовать

Не могу сделать выполнение второго условия в формуле, а именно когда находится значение "C3" из "листа0" нет проверки ячейки "F" "листа2" с ячейков "G3" "листа0"

УСЛОВИЕ: формулу нужно сделать с возможностью автоматического продления вниз потянув за край в колонке "AF" "листа0"

Уместна ли оплата в 200 рублей за данное задание?

Автор - NekrasovAVbr2119
Дата добавления - 15.05.2024 в 10:48
NekrasovAVbr2119 Дата: Среда, 15.05.2024, 10:57 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

2021
Заранее извиняюсь если кто будет писать, убегаю, часа через 3-4 смогу зайти и посмотреть ответы.
 
Ответить
СообщениеЗаранее извиняюсь если кто будет писать, убегаю, часа через 3-4 смогу зайти и посмотреть ответы.

Автор - NekrasovAVbr2119
Дата добавления - 15.05.2024 в 10:57
Pelena Дата: Среда, 15.05.2024, 11:03 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 19197
Репутация: 4423 ±
Замечаний: ±

Excel 365 & Mac Excel
Здравствуйте.
Код
=ЕСЛИОШИБКА(ВПР(ЛЕВСИМВ(C3;ДЛСТР(C3)-2);Лист2!$C$2:$M$7839;11;ЛОЖЬ);0)*(ЕСЛИОШИБКА(ВПР(ЛЕВСИМВ(C3;ДЛСТР(C3)-2);Лист2!$C$2:$M$7839;4;ЛОЖЬ);0)=G3)

Укоротила немного таблицу на листе 0, чтобы файл прошел на форум
К сообщению приложен файл: 1077454.xlsx (444.3 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=ЕСЛИОШИБКА(ВПР(ЛЕВСИМВ(C3;ДЛСТР(C3)-2);Лист2!$C$2:$M$7839;11;ЛОЖЬ);0)*(ЕСЛИОШИБКА(ВПР(ЛЕВСИМВ(C3;ДЛСТР(C3)-2);Лист2!$C$2:$M$7839;4;ЛОЖЬ);0)=G3)

Укоротила немного таблицу на листе 0, чтобы файл прошел на форум

Автор - Pelena
Дата добавления - 15.05.2024 в 11:03
Мир MS Excel » Работа и общение » Работа / Фриланс » Доработка формулы (Необходимо доработать формулу, не хватает знаний)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!