Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/ИСТИНА, если "/" в ячейке встречается больше одного раза. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 212»
Модератор форума: _Boroda_, Pelena 
Мир MS Excel » Работа и общение » Мозговой штурм » ИСТИНА, если "/" в ячейке встречается больше одного раза. (Формула)
ИСТИНА, если "/" в ячейке встречается больше одного раза.
AlexM Дата: Понедельник, 07.11.2016, 11:47 | Сообщение № 1
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3048
Репутация: 739 ±
Замечаний: 0% ±

ИСТИНА, если определенный символ в ячейке встречается больше одного раза.
Задача простая для начинающих Экселистов-формулистов.
Пусть символ будет "/"
ячейка – ЛОЖЬ
ячейка/строка – ЛОЖЬ
ячейка/строка/лист – ИСТИНА
ячейка/строка/лист/книга – ИСТИНА
Задачу решить формулой меньше 38 (лучше <25) знаков без символа "="


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеИСТИНА, если определенный символ в ячейке встречается больше одного раза.
Задача простая для начинающих Экселистов-формулистов.
Пусть символ будет "/"
ячейка – ЛОЖЬ
ячейка/строка – ЛОЖЬ
ячейка/строка/лист – ИСТИНА
ячейка/строка/лист/книга – ИСТИНА
Задачу решить формулой меньше 38 (лучше <25) знаков без символа "="

Автор - AlexM
Дата добавления - 07.11.2016 в 11:47
_Boroda_ Дата: Понедельник, 07.11.2016, 11:53 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9346
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Пока 23
И другая тоже 23
А третья 22


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПока 23
И другая тоже 23
А третья 22

Автор - _Boroda_
Дата добавления - 07.11.2016 в 11:53
Udik Дата: Понедельник, 07.11.2016, 14:55 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1201
Репутация: 152 ±
Замечаний: 0% ±

Excel 2013
Меня только на 23 хватило :) .


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com
 
Ответить
СообщениеМеня только на 23 хватило :) .

Автор - Udik
Дата добавления - 07.11.2016 в 14:55
SLAVICK Дата: Понедельник, 07.11.2016, 16:09 | Сообщение № 4
Группа: Модераторы
Ранг: Старожил
Сообщений: 1834
Репутация: 613 ±
Замечаний: 0% ±

2007,2010,2013,2016
23 и 22 (без знака равно)


Иногда все проще чем кажется с первого взгляда.
 
Ответить
Сообщение23 и 22 (без знака равно)

Автор - SLAVICK
Дата добавления - 07.11.2016 в 16:09
Nic70y Дата: Понедельник, 07.11.2016, 18:58 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3471
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
//а
?

вопрос снят как глупый :)
пока 23 22


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Понедельник, 07.11.2016, 19:23
 
Ответить
Сообщение//а
?

вопрос снят как глупый :)
пока 23 22

Автор - Nic70y
Дата добавления - 07.11.2016 в 18:58
krosav4ig Дата: Понедельник, 07.11.2016, 19:59 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1334
Репутация: 533 ±
Замечаний: 0% ±

Excel 2007, 2013
и у мну тож 22 и 23 без =


(_)Õvõ(_)
 
Ответить
Сообщениеи у мну тож 22 и 23 без =

Автор - krosav4ig
Дата добавления - 07.11.2016 в 19:59
vikttur Дата: Понедельник, 07.11.2016, 20:07 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 2029
Репутация: 355 ±
Замечаний: 0% ±

Со знаком =
26 - 1
25 - 2
24 - 2
23 - 1

А krosav4ig не знает русского :p


Сообщение отредактировал vikttur - Понедельник, 07.11.2016, 20:08
 
Ответить
СообщениеСо знаком =
26 - 1
25 - 2
24 - 2
23 - 1

А krosav4ig не знает русского :p

Автор - vikttur
Дата добавления - 07.11.2016 в 20:07
AlexM Дата: Понедельник, 07.11.2016, 20:12 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3048
Репутация: 739 ±
Замечаний: 0% ±

Шестеро "начинающих" нашли решение <25 символов это хорошо.
А где начинающие??? ;)
Спугнули наверно. :(

PS. у меня также есть варианты на 23 и 22 без равно.


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Понедельник, 07.11.2016, 20:13
 
Ответить
СообщениеШестеро "начинающих" нашли решение <25 символов это хорошо.
А где начинающие??? ;)
Спугнули наверно. :(

PS. у меня также есть варианты на 23 и 22 без равно.

Автор - AlexM
Дата добавления - 07.11.2016 в 20:12
buchlotnik Дата: Понедельник, 07.11.2016, 21:45 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
2 варианта по 23
Цитата
А где начинающие?
видимо я за них - 22 так и не отыскал отыскал и 22 B)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Вторник, 08.11.2016, 09:12
 
Ответить
Сообщение2 варианта по 23
Цитата
А где начинающие?
видимо я за них - 22 так и не отыскал отыскал и 22 B)

Автор - buchlotnik
Дата добавления - 07.11.2016 в 21:45
Светлый Дата: Понедельник, 07.11.2016, 21:55 | Сообщение № 10
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 226
Репутация: 56 ±
Замечаний: 0% ±

Excel 2007
В лоб два решения по 24 и 23. Над другими пока некогда думать.
22 тоже нашёл.


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Вторник, 08.11.2016, 07:43
 
Ответить
СообщениеВ лоб два решения по 24 и 23. Над другими пока некогда думать.
22 тоже нашёл.

Автор - Светлый
Дата добавления - 07.11.2016 в 21:55
Nic70y Дата: Вторник, 08.11.2016, 20:20 | Сообщение № 11
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3471
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
А krosav4ig не знает русского
, а vikttur не читал правил :p
Цитата
Длина формул считается по количеству символов, без учёта знака "=" и лидирующего и финишного знаков "{" и "}" для формул массива


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
А krosav4ig не знает русского
, а vikttur не читал правил :p
Цитата
Длина формул считается по количеству символов, без учёта знака "=" и лидирующего и финишного знаков "{" и "}" для формул массива

Автор - Nic70y
Дата добавления - 08.11.2016 в 20:20
vikttur Дата: Вторник, 08.11.2016, 20:44 | Сообщение № 12
Группа: Друзья
Ранг: Старожил
Сообщений: 2029
Репутация: 355 ±
Замечаний: 0% ±

Читал. Знаю. Давняя история. Кто умеет считать, отнимет для себя единицу.
 
Ответить
СообщениеЧитал. Знаю. Давняя история. Кто умеет считать, отнимет для себя единицу.

Автор - vikttur
Дата добавления - 08.11.2016 в 20:44
ZORRO2005 Дата: Среда, 09.11.2016, 00:23 | Сообщение № 13
Группа: Друзья
Ранг: Обитатель
Сообщений: 277
Репутация: 112 ±
Замечаний: 0% ±

Excel2010
22
 
Ответить
Сообщение22

Автор - ZORRO2005
Дата добавления - 09.11.2016 в 00:23
AlexM Дата: Среда, 09.11.2016, 00:28 | Сообщение № 14
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3048
Репутация: 739 ±
Замечаний: 0% ±

Есть три варианта формул с 22-я символами.


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Среда, 09.11.2016, 01:27
 
Ответить
СообщениеЕсть три варианта формул с 22-я символами.

Автор - AlexM
Дата добавления - 09.11.2016 в 00:28
_Boroda_ Дата: Среда, 09.11.2016, 01:01 | Сообщение № 15
Группа: Модераторы
Ранг: Экселист
Сообщений: 9346
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Ага


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеАга

Автор - _Boroda_
Дата добавления - 09.11.2016 в 01:01
AlexM Дата: Воскресенье, 13.11.2016, 11:03 | Сообщение № 16
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3048
Репутация: 739 ±
Замечаний: 0% ±

Похоже, больше никто не желает принять участие в решении задачи.
Открываемся.
Формулы меньше которых надо было найти решения <38 и <25
Код
=ДЛСТР(A2)-ДЛСТР(ПОДСТАВИТЬ(A2;"/";))>1
Код
=A2<>ПОДСТАВИТЬ(A2;"/";;2)
Ниже формулы длиной 22 символа.
Код
=СЧЁТЕСЛИ(A2;"*/*/*")=1
Код
=ТИП(ПОИСК("/*/";A2))=1
Код
=ЕОШ(ВПР("*/*/*";A2;;))
Код
=ЕОШ(ГПР("*/*/*";A2;;))
Необычно работают две последние формулы с нулевым третьим аргументом.
Интересно посмотреть на другие формулы длиной 22 символа.


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеПохоже, больше никто не желает принять участие в решении задачи.
Открываемся.
Формулы меньше которых надо было найти решения <38 и <25
Код
=ДЛСТР(A2)-ДЛСТР(ПОДСТАВИТЬ(A2;"/";))>1
Код
=A2<>ПОДСТАВИТЬ(A2;"/";;2)
Ниже формулы длиной 22 символа.
Код
=СЧЁТЕСЛИ(A2;"*/*/*")=1
Код
=ТИП(ПОИСК("/*/";A2))=1
Код
=ЕОШ(ВПР("*/*/*";A2;;))
Код
=ЕОШ(ГПР("*/*/*";A2;;))
Необычно работают две последние формулы с нулевым третьим аргументом.
Интересно посмотреть на другие формулы длиной 22 символа.

Автор - AlexM
Дата добавления - 13.11.2016 в 11:03
Nic70y Дата: Воскресенье, 13.11.2016, 14:43 | Сообщение № 17
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3471
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
=СЧЁТЕСЛИ(A2;"*/*/*")=1

=ТИП(ПОИСК("/*/";A2))=1
аналогично


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Воскресенье, 13.11.2016, 14:51
 
Ответить
Сообщение
=СЧЁТЕСЛИ(A2;"*/*/*")=1

=ТИП(ПОИСК("/*/";A2))=1
аналогично

Автор - Nic70y
Дата добавления - 13.11.2016 в 14:43
vikttur Дата: Воскресенье, 13.11.2016, 18:22 | Сообщение № 18
Группа: Друзья
Ранг: Старожил
Сообщений: 2029
Репутация: 355 ±
Замечаний: 0% ±

=ПОДСТАВИТЬ(A1;"/";;2)<>A1
=И(СЧЁТ(ПОИСК("/*/";A1)))
=НЕ(ЕОШ(ПОИСК("/*/";A1)))
=ЕЧИСЛО(ПОИСК("/*/";A1))
=СЧЁТЕСЛИ(A1;"*/*/*")=1
=ТИП(ПОИСК("/*/";A1))=1


Сообщение отредактировал vikttur - Воскресенье, 13.11.2016, 18:34
 
Ответить
Сообщение=ПОДСТАВИТЬ(A1;"/";;2)<>A1
=И(СЧЁТ(ПОИСК("/*/";A1)))
=НЕ(ЕОШ(ПОИСК("/*/";A1)))
=ЕЧИСЛО(ПОИСК("/*/";A1))
=СЧЁТЕСЛИ(A1;"*/*/*")=1
=ТИП(ПОИСК("/*/";A1))=1

Автор - vikttur
Дата добавления - 13.11.2016 в 18:22
krosav4ig Дата: Понедельник, 14.11.2016, 01:51 | Сообщение № 19
Группа: Друзья
Ранг: Старожил
Сообщений: 1334
Репутация: 533 ±
Замечаний: 0% ±

Excel 2007, 2013
У меня тоже
Код
=СЧЁТ(ПОИСК("/*/";A1))=1

Код
=СЧЁТЕСЛИ(A1;"*/*/*")=1


(_)Õvõ(_)
 
Ответить
СообщениеУ меня тоже
Код
=СЧЁТ(ПОИСК("/*/";A1))=1

Код
=СЧЁТЕСЛИ(A1;"*/*/*")=1

Автор - krosav4ig
Дата добавления - 14.11.2016 в 01:51
buchlotnik Дата: Понедельник, 14.11.2016, 09:55 | Сообщение № 20
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Я ограничился
Код
=ТИП(ПОИСК("/*/";A2))=1


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Понедельник, 14.11.2016, 09:56
 
Ответить
СообщениеЯ ограничился
Код
=ТИП(ПОИСК("/*/";A2))=1

Автор - buchlotnik
Дата добавления - 14.11.2016 в 09:55
Мир MS Excel » Работа и общение » Мозговой штурм » ИСТИНА, если "/" в ячейке встречается больше одного раза. (Формула)
Страница 1 из 212»
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!