Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Необычный РАНГ - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, китин  
Мир MS Excel » Работа и общение » Мозговой штурм » Необычный РАНГ (Ранжировать данные из разорванного диапазона.)
Необычный РАНГ
ZORRO2005 Дата: Суббота, 19.01.2013, 22:33 | Сообщение № 1
Группа: Друзья
Ранг: Обитатель
Сообщений: 381
Репутация: 148 ±
Замечаний: 0% ±

Excel2010
Всем привет!
Нужно ранжировать данные из разорванного диапазона.
Функцию РАНГ() использовать не обязательно. zorro
К сообщению приложен файл: 6830503.xls(31.5 Kb)
 
Ответить
СообщениеВсем привет!
Нужно ранжировать данные из разорванного диапазона.
Функцию РАНГ() использовать не обязательно. zorro

Автор - ZORRO2005
Дата добавления - 19.01.2013 в 22:33
MCH Дата: Суббота, 19.01.2013, 22:41 | Сообщение № 2
Группа: Админы
Ранг: Старожил
Сообщений: 1943
Репутация: 723 ±
Замечаний: ±

вариант вне конкурса, т.к. ссылки нужно задавать вручную:
Код
=РАНГ(C3;(C$3;C$9;C$15;C$21;C$27))

Есть вариант формулы массива - 51 знак, где диапазон задается ссылкой на C$3:C$32


Сообщение отредактировал MCH - Суббота, 19.01.2013, 23:08
 
Ответить
Сообщениевариант вне конкурса, т.к. ссылки нужно задавать вручную:
Код
=РАНГ(C3;(C$3;C$9;C$15;C$21;C$27))

Есть вариант формулы массива - 51 знак, где диапазон задается ссылкой на C$3:C$32

Автор - MCH
Дата добавления - 19.01.2013 в 22:41
ZORRO2005 Дата: Суббота, 19.01.2013, 22:45 | Сообщение № 3
Группа: Друзья
Ранг: Обитатель
Сообщений: 381
Репутация: 148 ±
Замечаний: 0% ±

Excel2010
Цитата (MCH)
вариант вне конкурса, т.к. ссылки нужно задавать вручную:

Такой вариант тоже принимается. smile , но нужно все-таки универсальный.
 
Ответить
Сообщение
Цитата (MCH)
вариант вне конкурса, т.к. ссылки нужно задавать вручную:

Такой вариант тоже принимается. smile , но нужно все-таки универсальный.

Автор - ZORRO2005
Дата добавления - 19.01.2013 в 22:45
vikttur Дата: Суббота, 19.01.2013, 22:51 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2924
Репутация: 525 ±
Замечаний: 0% ±

Диапазон одномерный?
Ранжировать где? Если, например, диапазон в столбце: результат в одном диапазоне или привязан к каждому значению?
Сколько "частей" диапазона?

А файл-то и не заметил smile


Сообщение отредактировал vikttur - Суббота, 19.01.2013, 23:09
 
Ответить
СообщениеДиапазон одномерный?
Ранжировать где? Если, например, диапазон в столбце: результат в одном диапазоне или привязан к каждому значению?
Сколько "частей" диапазона?

А файл-то и не заметил smile

Автор - vikttur
Дата добавления - 19.01.2013 в 22:51
MCH Дата: Суббота, 19.01.2013, 22:53 | Сообщение № 5
Группа: Админы
Ранг: Старожил
Сообщений: 1943
Репутация: 723 ±
Замечаний: ±

Для 2007/2010 есть вариант в 42 знака
Для 2003, формула массива - 35


Сообщение отредактировал MCH - Суббота, 19.01.2013, 22:56
 
Ответить
СообщениеДля 2007/2010 есть вариант в 42 знака
Для 2003, формула массива - 35

Автор - MCH
Дата добавления - 19.01.2013 в 22:53
ZORRO2005 Дата: Суббота, 19.01.2013, 23:06 | Сообщение № 6
Группа: Друзья
Ранг: Обитатель
Сообщений: 381
Репутация: 148 ±
Замечаний: 0% ±

Excel2010
Цитата (vikttur)
Диапазон одномерный?

Да. Столбец С.
Цитата

Ранжировать где? Если, например, диапазон в столбце: результат в одном диапазоне или привязан к каждому значению?

В столбце D.
Раскрой структуру.
 
Ответить
Сообщение
Цитата (vikttur)
Диапазон одномерный?

Да. Столбец С.
Цитата

Ранжировать где? Если, например, диапазон в столбце: результат в одном диапазоне или привязан к каждому значению?

В столбце D.
Раскрой структуру.

Автор - ZORRO2005
Дата добавления - 19.01.2013 в 23:06
vikttur Дата: Воскресенье, 20.01.2013, 05:49 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2924
Репутация: 525 ±
Замечаний: 0% ±

2003, формула массива - 41
 
Ответить
Сообщение2003, формула массива - 41

Автор - vikttur
Дата добавления - 20.01.2013 в 05:49
ZORRO2005 Дата: Воскресенье, 20.01.2013, 13:18 | Сообщение № 8
Группа: Друзья
Ранг: Обитатель
Сообщений: 381
Репутация: 148 ±
Замечаний: 0% ±

Excel2010
Доп. вопрос.
Можно ли решить эту задачу с помощью РАНГ(), запульнув в аргумент ссылка нужный массив со СМЕЩ или т.п.?
 
Ответить
СообщениеДоп. вопрос.
Можно ли решить эту задачу с помощью РАНГ(), запульнув в аргумент ссылка нужный массив со СМЕЩ или т.п.?

Автор - ZORRO2005
Дата добавления - 20.01.2013 в 13:18
MCH Дата: Воскресенье, 20.01.2013, 19:04 | Сообщение № 9
Группа: Админы
Ранг: Старожил
Сообщений: 1943
Репутация: 723 ±
Замечаний: ±

Цитата (ZORRO2005)
ожно ли решить эту задачу с помощью РАНГ(), запульнув в аргумент ссылка нужный массив со СМЕЩ или т.п.?

Скорее всего нет, РАНГ работает только с ссылками, но поэксперементировать можно
 
Ответить
Сообщение
Цитата (ZORRO2005)
ожно ли решить эту задачу с помощью РАНГ(), запульнув в аргумент ссылка нужный массив со СМЕЩ или т.п.?

Скорее всего нет, РАНГ работает только с ссылками, но поэксперементировать можно

Автор - MCH
Дата добавления - 20.01.2013 в 19:04
ZORRO2005 Дата: Вторник, 22.01.2013, 20:12 | Сообщение № 10
Группа: Друзья
Ранг: Обитатель
Сообщений: 381
Репутация: 148 ±
Замечаний: 0% ±

Excel2010
Предлагаю вскрыться.
Решение оказалось простое, но РАНГ отвлек от него.
Миша, выложи, пожалуйста, свое решение с ИНДЕКС+ЧАСТОТА.

Моё решение:
Код
=СУММ(--(ЕСЛИ($B$3:$B$32<>"";9^9+$C$3:$C$32;)>=9^9+C3))

Не подходит для больших чисел(+-).


Сообщение отредактировал ZORRO2005 - Вторник, 22.01.2013, 20:20
 
Ответить
СообщениеПредлагаю вскрыться.
Решение оказалось простое, но РАНГ отвлек от него.
Миша, выложи, пожалуйста, свое решение с ИНДЕКС+ЧАСТОТА.

Моё решение:
Код
=СУММ(--(ЕСЛИ($B$3:$B$32<>"";9^9+$C$3:$C$32;)>=9^9+C3))

Не подходит для больших чисел(+-).

Автор - ZORRO2005
Дата добавления - 22.01.2013 в 20:12
MCH Дата: Вторник, 22.01.2013, 23:50 | Сообщение № 11
Группа: Админы
Ранг: Старожил
Сообщений: 1943
Репутация: 723 ±
Замечаний: ±

51:
Код
=ИНДЕКС(ЧАСТОТА(ЕСЛИ(B$3:B$32>"";C$3:C$32);C3);2)+1

42 (для 2007/2010):
Код
=СЧЁТЕСЛИМН(B$3:B$32;"*";C$3:C$32;">="&C3)

35 (формула массива):
Цитата
=СУММ((B$3:B$32>"")*(C3<=C$3:C$32))


Сообщение отредактировал MCH - Вторник, 22.01.2013, 23:50
 
Ответить
Сообщение51:
Код
=ИНДЕКС(ЧАСТОТА(ЕСЛИ(B$3:B$32>"";C$3:C$32);C3);2)+1

42 (для 2007/2010):
Код
=СЧЁТЕСЛИМН(B$3:B$32;"*";C$3:C$32;">="&C3)

35 (формула массива):
Цитата
=СУММ((B$3:B$32>"")*(C3<=C$3:C$32))

Автор - MCH
Дата добавления - 22.01.2013 в 23:50
vikttur Дата: Среда, 23.01.2013, 23:33 | Сообщение № 12
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2924
Репутация: 525 ±
Замечаний: 0% ±

Формула массива, 2003 кушает. 42:
Код
=СЧЁТ(1/(($B$3:$B$32<>"")*($C$3:$C$32>C3)))+1
 
Ответить
СообщениеФормула массива, 2003 кушает. 42:
Код
=СЧЁТ(1/(($B$3:$B$32<>"")*($C$3:$C$32>C3)))+1

Автор - vikttur
Дата добавления - 23.01.2013 в 23:33
Мир MS Excel » Работа и общение » Мозговой штурм » Необычный РАНГ (Ранжировать данные из разорванного диапазона.)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!