Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Определение числа кластеров в ряду - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, китин  
Мир MS Excel » Работа и общение » Мозговой штурм » Определение числа кластеров в ряду (Посчитать сгустки единиц в ряду.)
Определение числа кластеров в ряду
Понравилось?
Светлый Дата: Четверг, 11.10.2018, 19:54 | Сообщение № 1
Группа: Проверенные
Ранг: Ветеран
Сообщений: 755
Репутация: 201 ±
Замечаний: 0% ±

Excel 2010
И опять задача из жизни, предложенная участником форума. Отсюда.
Убрал из файла лишнее.
Дано: Вертикальный массив (до 999 элементов), неравномерно заполненный 1 (до 99 штук), минимальное расстояние между кластерами (до 9 штук) и минимальное число 1 в кластере. Две 1, расстояние между которыми меньше минимального, принадлежат одному кластеру.
Найти: Написать формулу, подсчитывающую количество кластеров с числом 1, больше или равным минимальному.
Необязательно, но желательно, чтобы формула работала в 2003 офисе.
В оригинальной теме есть два решения 391 и 307 символов (уже для нового файла).
У меня есть решение в 155 символов, которое работает в 2003 офисе.
Вскрываемся 15 22 октября?
К сообщению приложен файл: clasters.xls(54.5 Kb)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Пятница, 12.10.2018, 08:40
 
Ответить
СообщениеИ опять задача из жизни, предложенная участником форума. Отсюда.
Убрал из файла лишнее.
Дано: Вертикальный массив (до 999 элементов), неравномерно заполненный 1 (до 99 штук), минимальное расстояние между кластерами (до 9 штук) и минимальное число 1 в кластере. Две 1, расстояние между которыми меньше минимального, принадлежат одному кластеру.
Найти: Написать формулу, подсчитывающую количество кластеров с числом 1, больше или равным минимальному.
Необязательно, но желательно, чтобы формула работала в 2003 офисе.
В оригинальной теме есть два решения 391 и 307 символов (уже для нового файла).
У меня есть решение в 155 символов, которое работает в 2003 офисе.
Вскрываемся 15 22 октября?

Автор - Светлый
Дата добавления - 11.10.2018 в 19:54
Светлый Дата: Понедельник, 22.10.2018, 06:59 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 755
Репутация: 201 ±
Замечаний: 0% ±

Excel 2010
Понимаю. Не у всех есть время заниматься задачками, которые не приносят материального удовлетворения. Остался я в гордом одиночестве. Ну, хотя бы моральное удовлетворение.
В интеллектуальную копилку форума.
Код
=СУММ(Ч(МУМНОЖ(НАИБОЛЬШИЙ((МУМНОЖ(НАИМЕНЬШИЙ(ЕСЛИ(D7:D277;СТРОКА(D1:D271);999);СТРОКА(1:99)+{0;1});{-1:1})>D2)*СТРОКА(1:99);СТРОКА(1:9)+{0;1});{1:-1})>=D1))
К сообщению приложен файл: clasters-otvet.xlsx(19.4 Kb)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеПонимаю. Не у всех есть время заниматься задачками, которые не приносят материального удовлетворения. Остался я в гордом одиночестве. Ну, хотя бы моральное удовлетворение.
В интеллектуальную копилку форума.
Код
=СУММ(Ч(МУМНОЖ(НАИБОЛЬШИЙ((МУМНОЖ(НАИМЕНЬШИЙ(ЕСЛИ(D7:D277;СТРОКА(D1:D271);999);СТРОКА(1:99)+{0;1});{-1:1})>D2)*СТРОКА(1:99);СТРОКА(1:9)+{0;1});{1:-1})>=D1))

Автор - Светлый
Дата добавления - 22.10.2018 в 06:59
Nic70y Дата: Понедельник, 22.10.2018, 17:58 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4948
Репутация: 1070 ±
Замечаний: 0% ±

Excel 2013
Цитата Светлый, 22.10.2018 в 06:59, в сообщении № 2 ()
Не у всех есть время заниматься задачками, которые не приносят материального
Светлый, ну зачем Вы так?
Ведь причины могут быть разными.
Ну например, когда я заглядывал в эту тему, то был после 1,5 пивка и как-то мысли не лезли в голову
и так каждый раз, а без пивка я просто не помнил,
да и на работе в основном Ютуб смотрю, т.к. покупатели постоянно отвлекают,
а эксель требует сосредоточенности,
у других юзеров могут быть другие проблемы.


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Цитата Светлый, 22.10.2018 в 06:59, в сообщении № 2 ()
Не у всех есть время заниматься задачками, которые не приносят материального
Светлый, ну зачем Вы так?
Ведь причины могут быть разными.
Ну например, когда я заглядывал в эту тему, то был после 1,5 пивка и как-то мысли не лезли в голову
и так каждый раз, а без пивка я просто не помнил,
да и на работе в основном Ютуб смотрю, т.к. покупатели постоянно отвлекают,
а эксель требует сосредоточенности,
у других юзеров могут быть другие проблемы.

Автор - Nic70y
Дата добавления - 22.10.2018 в 17:58
Светлый Дата: Понедельник, 22.10.2018, 18:37 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 755
Репутация: 201 ±
Замечаний: 0% ±

Excel 2010
ну зачем Вы так?

Никого не хотел обидеть. Наверно, сужу по себе. Каюсь! :facepalm:


Программировать проще, чем писать стихи.
 
Ответить
Сообщение
ну зачем Вы так?

Никого не хотел обидеть. Наверно, сужу по себе. Каюсь! :facepalm:

Автор - Светлый
Дата добавления - 22.10.2018 в 18:37
Мир MS Excel » Работа и общение » Мозговой штурм » Определение числа кластеров в ряду (Посчитать сгустки единиц в ряду.)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!