Домашняя страница Undo Do Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Статьи об Excel

МЕНЮ САЙТА
  • 1
  • 2
  • 3

КАТЕГОРИИ РАЗДЕЛА

ОПРОСЫ
Какой версией Excel Вы пользуетесь?
Всего ответов: 35674
Главная » Статьи » Функции Excel » Функции листа. Функции логические

ЕСЛИ() IF()
СИНТАКСИС:
=ЕСЛИ(лог_выражение;значение_если_ИСТИНА;значение_если_ЛОЖЬ)

АРГУМЕНТЫ:
1. лог_выражение - любое значение или выражение, принимающее значения ИСТИНА или ЛОЖЬ.
2. значение_если_ИСТИНА - значение, которое возвращается если лог_выражение = ИСТИНА. Оно может быть числом, текстом, формулой или ссылкой на ячейку (в формулах массива допустимо использовать так же ссылки на диапазон ячеек).
3.
значение_если_ЛОЖЬ - значение, которое возвращается если лог_выражение = ЛОЖЬ. Оно может быть числом, текстом, формулой или ссылкой на ячейку (в формулах массива допустимо использовать так же ссылки на диапазон ячеек).

КОММЕНТАРИИ:
Если аргумент
лог_выражение = ИСТИНА, но аргумент значение_если_ИСТИНА не указан, то возвращается значение 0.
Если аргумент лог_выражение = ЛОЖЬ, но аргумент значение_если_ЛОЖЬ не указан, то возвращается значение 0.

ОГРАНИЧЕНИЯ:
Допускается до 7 вложений функции ЕСЛИ друг в друга в качестве любого из аргументов в Excel
версий до 2003 включительно, до 64 вложений в Excel версии 2007 и до 128 вложений в Excel версии 2010.

ПРИМЕРЫ ИСПОЛЬЗОВАНИЯ:




ФОРМУЛЫ МАССИВА:
Функция работает в формулах массива



ЭТОГО НЕТ В ОФИЦИАЛЬНОЙ СПРАВКЕ EXCEL:
Аргумент
лог_выражение может и не быть выражением. Это может быть просто текст, число или ссылка на ячейку содержащую их.
Если аргумент лог_выражение является текстом, то Вы получите значение ошибки #ЗНАЧ, если числом, то при значении 0 функция ЕСЛИ вернёт ЛОЖЬ, при любом другом значении - ИСТИНА.
Если не указывать аргументы значение_если_ИСТИНА или значение_если_ЛОЖЬ, то при выполнении условий будут возвращаться текстовые значения ИСТИНА или ЛОЖЬ.


В КАКОЙ ВЕРСИИ EXCEL РАБОТАЕТ:
В любой версии.

Категория: Функции листа. Функции логические | Добавил: Serge_007 (22.02.2011)
Просмотров: 54136 | Комментарии: 20 | Рейтинг: 4.4/7


Всего комментариев: 20
+1   Спам
1    kim   (24.02.2011 22:36)
   Хорошая идея. Получается как бы расширенная справка.
От себя хочется добавить, что использование данной функции в формулах массива вместо перемножения массивов, несколько ускоряет расчеты.
К примеру возьмем простой пример формулы массива:
СУММПРОИЗВ((Товары="яблоки")*Цены)
Матричный ввод не требуется
Можно заменить на:
{СУММПРОИЗВ(ЕСЛИ(Товары="яблоки;Цены))}
В данном случае понадобится матричный ввод (Ctrl+Shift+Enter) - еще одна особенность использования данной функции в формулах массивов.

0   Спам
2    лена   (15.12.2012 21:27)
   Помогите пожалуйста, не знаю как написать решение. Очень срочно нужно. пожалуйста

Построить график кусочной функции на участке [a;b] с шагом 0,5.
y= x^4, x<или = 3.14
cos (x), 3.14<x<5
корень x, х больше или равно 5

Спам-сообщение скрыто. Показать
0   Спам
3    Иван   (24.01.2013 10:37)
   Здравствуйте.

Странно у меня не работает функция ЕСЛИ для массива в офисе 2007, выдает ошибку ЗНАЧ!.
Мне нужно решить следующий пример:
если в массиве F7:F17 есть "!"(воскл. знак) то - OK иначе NOK. Подскажите, плиз, каким способом можно это сделать.
Может есть другая функция?.Спасибо

0   Спам
4    Serge_007   (24.01.2013 13:01)
   Все вопросы - на форум

0   Спам
5    Anna   (07.02.2013 12:50)
   Подскажите, как расшифровать данную формулу?
=IF(AND(OR($AL5>0,$AN5>0),DE$2-31<$T5,$T5<=DE$2),$AL5+$AN5,IF(AND($T5<=DE$2,DE$2<=$U5),IF($O5="Model 220",IF(OR(DE$2<$T5,DE$2>$U5),0,IF(MOD(MONTH(DE$2),3),0,IF(YEAR(DE$2)=YEAR($T5),IF(MONTH(DE$2)-MO NTH($T5)<2,$BC5/$AO5*(MONTH(DE$2)-MONTH($T5)+1),$BC5),$BC5))),IF(MOD(MONTH($T5),3),IF(MOD(MONTH($ T5)+1,3),0,$BC5/3),0)),0))

0   Спам
6    Serge_007   (07.02.2013 14:04)
   Все вопросы - на форум

0   Спам
7    KapriZzZza   (14.04.2013 07:07)
   То есть аргумент лог_выражение никак нельзя применить к тексту? Получится ошибка #ЗНАЧ?

0   Спам
8    Serge_007   (14.04.2013 11:42)
   Текст не является логическим выражением smile
А как именно Вы хотите применять функцию ЕСЛИ() к тексту?

0   Спам
9    Юлия   (28.06.2013 19:16)
   Здравствуйте, помогите пожалуйста разобраться: у меня есть два интервала 96 - 98 и 99 - 105. Мне надо получить следующее: если у меня цифра попадает в первый интервал, то должно выскочить значение 1000, если попадает во второй, то выскакивает 2000. Никак не могу формулу сформировать корректную. Заранее спасибо.

0   Спам
10    bsshadow   (06.01.2014 09:40)
   функцию если можно применить к тексту, если этот текст будет одинаковым в каждой ячейке. прим. =ЕСЛИ(K29= "одобрено";1;0)

0   Спам
11    Serge_007   (12.04.2014 02:59)
   Конечно можно!

0   Спам
12    dudic   (21.11.2015 19:50)
   а можно сделать так, чтобы если значение_ложь, то функция ничего не меняла?

0  
13    Serge_007   (22.11.2015 00:25)
   Она и так не меняет...

0   Спам
14    dudic   (22.11.2015 09:04)
   почему не меняет?! или вставляет ложь, или очищает, а мне надо, чтобы осталось то, что было, а менялось только если истина)))

0  
15    Serge_007   (22.11.2015 11:53)
   Потому что функции в принципе не могут что либо менять. Функции могут только возвращать значения. Для решения Вашей задач необходимо указать соответствующий аргумент для ЛОЖЬ

0   Спам
16    dudic   (22.11.2015 14:18)
   и что мне написать в ЛОЖЬ, чтобы функцию вернула то, что там было?

0  
17    Serge_007   (22.11.2015 14:57)
   Укажите то, что Вам необходимо

0   Спам
18    dudic   (24.11.2015 13:15)
   Есть много компаний (столбец А) и есть большой набор стройматериалов и сырья (строка 1). Каждой компании нужно для выпуска продукции разное сырье и разное количество сырья из этого набора. Надо посчитать себестоимость одной единицы выпускаемой продукции в каждой компании. Может измениться только цена сырья (строка 1). Вот как-то так.

0  
19    Serge_007   (24.11.2015 19:14)
   dudic, какое отношение Ваш вопрос имеет к данной статье? И почему Вы не задаете свой вопрос на форуме, где ему и положено быть?

0   Спам
20    dudic   (24.11.2015 21:51)
   здесь же говорят про функцию ЕСЛИ и я увидел здесь многих с вопросами

Добавлять комментарии могут только зарегистрированные пользователи.
[ Регистрация | Вход ]
Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!