Домашняя страница Undo Do Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Статьи об Excel

МЕНЮ САЙТА
  • 1
  • 2
  • 3

КАТЕГОРИИ РАЗДЕЛА

ОПРОСЫ
Какой версией Excel Вы пользуетесь?
Всего ответов: 35788
Главная » Статьи » Эффективная работа в Excel » Приёмы работы с формулами

Как сцепить дату и текст?
    Предположим Вы решили сделать приветствие при открытии файла. Приветствие должно содержать следующий текст: "Привет! Сегодня 07.08.2011". Естественно, дата должна меняться ежедневно. Для этого в ячейку А1 вводим текст "Привет! Сегодня ", в ячейке А2 формулу
Code
=СЕГОДНЯ()
В английской версии:
Code
=TODAY()


В ячейке В2 применяем формулу
Code
=СЦЕПИТЬ(A1;A2)
В английской версии:
Code
=CONCATENATE(A1,A2)

Но результат получается совсем не тот, на который Вы рассчитывали:



Функция СЕГОДНЯ() возвращает текущую дату. Сегодня (день написания статьи) 7-е августа 2011-го года, порядковый номер этой даты - 40762, именно он и красуется в нашей формуле (о том как Excel хранит даты и время читайте в статье Функции даты и времени.). Как перевести его в привычный нам формат? Для этого необходимо перевести порядковый номер даты из числового в текстовый формат, с помощью функции ТЕКСТ().
Code
=ТЕКСТ(A2;"ДД.ММ.ГГГГ")
В английской версии:
Code
=TEXT(A2,"DD.MM.YYYY")



Теперь остаётся только сцепить текст нашего приветствия и преобразованную дату
Готово!

Если Вы не хотите хранить на листе текст приветствия, текущую дату и пользоваться функцией СЦЕПИТЬ(), то есть альтернативное решение - можно использовать одну формулу, в которой одновременно как константа хранится текст приветствия, работает функция СЕГОДНЯ(), переводится в текст в нужном формате порядковый номер текущей даты и функция СЦЕПИТЬ() заменена знаком амперсанд "&":
Code
="Привет! Сегодня "&ТЕКСТ(СЕГОДНЯ();"ДД.ММ.ГГГГ")
В английской версии:
Code
="Привет! Сегодня "&TEXT(TODAY(),"DD.MM.YYYY")




Категория: Приёмы работы с формулами | Добавил: Serge_007 (07.08.2011)
Просмотров: 56637 | Комментарии: 43 | Теги: сцепить, дата, конкатенация, формулы эксель, Текст, формулы Excel | Рейтинг: 5.0/7


Всего комментариев: 411 2 »
0   Спам
1    Катерина   (15.03.2012 19:10)
   У меня не работает: пишет :" Привет! сегодня "ДД.ММ.ГГГГ"???

0   Спам
2    Sergey   (02.08.2012 11:32)
   Величайшая благодарность автору статьи, работает все прекрасно!

0   Спам
3    troja7777777   (27.08.2012 14:08)
   Добрый день, после применения функции "текст(А1;"дд.мм.гггг")" у меня месяц нулевой(( т.е. 27.08.2012 отображается 27.00.2012. Из-за чего это может быть?

+1   Спам
4    Boga   (13.09.2012 00:00)
   troja7777777 - правильно писать ДД.ММ.ГГГГ, т.к. мм - это минуты.

0   Спам
5    Ольга   (21.04.2013 15:01)
   Спасибо, народ!!! Пол дня убила на установление того, почему у меня нолики вместо месяца... только у вас нашла)))))))))))))))

0   Спам
6    Оксана   (17.05.2013 11:17)
   Поддерживаю вопрос Катерины (15.03.2012 19:10)
У меня не работает: пишет :" Привет! сегодня "ДД.ММ.ГГГГ"??? Спасибо.

+1   Спам
7    Serge_007   (17.05.2013 11:29)
   А Вы ответ Irysha видели? Файл с примером скачивали?

+1   Спам
8    vitendo   (31.08.2013 17:20)
   "Boga (13.09.2012 00:00)
troja7777777 - правильно писать ДД.ММ.ГГГГ, т.к. мм - это минуты."

Спасибо.
Намучился с этими нулями вместо месяца. Решил эту проблему более длинной формулой. А как оказалось мешала такая мелочь.
Ещё раз большое спасибо.

0   Спам
9    alexa1965   (17.09.2013 19:16)
   Спасибо!!! Стал более внимательно читать Ваши решения и сам себе удивляюсь, где я был раньше. В очередной раз упростили работу.

0   Спам
10    alexa1965   (18.09.2013 11:45)
   Да.... есть проблемка с амперсандом, - если после сегодня для полной красоты добавить " г.", то прокатывает, а длинный текст пишет что слишком сложная формула. Выход нашел конечно, разделением текста, но осадок обманутого остался...

0   Спам
11    Serge_007   (18.09.2013 11:52)
   Вы что-то неправильно делаете
Формула может содержать более восьми тысяч знаков, вряд ли Ваш "длинный текст" содержит большее количество символов :D

0   Спам
12    alexa1965   (18.09.2013 13:09)
   Блин... получилось. Копирование старого текста выдавало ошибку, а внесение текста ручками заново все проблемы сняло

0   Спам
13    Serge_007   (18.09.2013 13:14)
   Значит копировали неправильно

0   Спам
14    alexa1965   (18.09.2013 18:14)
   Не знаю, наверное зря порадовался, ввел ручками слов 10 вроде получилось, стал продолжать такая же ошибка. А копирую как всегда в строке формул выделяю нужный кусок текста и вставляю куда надо

0   Спам
15    Serge_007   (18.09.2013 20:29)
   Если все делать правильно, то работать все будет тоже правильно

0   Спам
16    Алексей   (24.09.2013 16:08)
   Спасибо!!! Все работает! )

0   Спам
17    Сергей   (12.11.2013 07:11)
   Хорошо работает! Давно хотел так сделать. Спасибо!

0   Спам
18    Закир   (12.02.2014 00:04)
   ДД!
подскажите, как РАСцепить знание в екселе?? например 10 ти значная цифра. номенклатурный номер. нр - 1234567890. необходимо разбить, чтоб был пробел между каждыми 2мя числами. спс!

0   Спам
19    Serge_007   (12.02.2014 00:12)
   Закир, какое отношение Ваш вопрос имеет к данной статье?

0   Спам
20    Закир   (12.02.2014 09:35)
   прямого нет, но в принципе вопрос имеет отношение к теме.

0   Спам
21    Serge_007   (12.02.2014 10:19)
   В статье разбирается пример конкатенации даты и текста
У Вас нет ни даты, ни текста, ни конкатенации
Из трех составляющих статьи в Вашей задачи нет НИ ОДНОГО
Так какое отношение имеет Ваша задача к данной статье?

0   Спам
22    Kirana   (26.02.2014 14:23)
   Хорошая вещь, но что мне делать если необходимо сцепить текст с формулой из соседней ячейки и получаю, например, "осталось 654,88878 р", но хочу чтобы в результате отображалась число без кучи нулей после запятой, а как целое.

0  
23    Serge_007   (02.07.2014 16:15)
   [$-F800]

0   Спам
24    Dee-ma   (03.07.2014 09:23)
   спасибо большое! А что значит этот код? Как-нибудь логически объясняется? Или просто нужно запомнить))

0   Спам
25    S0LDAT   (04.02.2015 03:21)
   Скажите, а как сделать, чтобы месяц был написан правильно
Код
=ТЕКСТ(T3;"ДД ММММ ГГГГ")
результат 04 февраль 2015
а как сделать февралЯ?, ведь в ячейке T3 значение 4 февраля 2015

1-25 26-41
Добавлять комментарии могут только зарегистрированные пользователи.
[ Регистрация | Вход ]
Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!